Very slow printing of PDF files with evince

Bug #516280 reported by Harm van Bakel on 2010-02-02
86
This bug affects 16 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Unassigned
Declined for Lucid by Sebastien Bacher
Nominated for Maverick by Arthur Wiebe

Bug Description

Binary package hint: evince

When I try to print reasonably complex pdf files (see attached example) with evince it can take up to half an hour before the first page emerges from the printer. Preparation of the print job in evince itself is fast (i.e. the progress bar only appears for a few seconds), but the print job just sits for a very long time in the print queue with a message that the printer is spooling. During this time the status message on the printer itself is "busy". The printer is a lexmark C530. When I print the same document through xpdf, which uses lpr, the pdf file is printed almost immediately. I only have this printing problem with evince, all other applications print normally.

ProblemType: Bug
Architecture: amd64
CheckboxSubmission: 464ed6184a4fbf79d6e3084c58b13de8
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Tue Feb 2 16:52:35 2010
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: evince 2.28.1-0ubuntu1.2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-18.55-generic
SourcePackage: evince
Uname: Linux 2.6.31-18-generic x86_64

Harm van Bakel (hvbakel) wrote :
Harm van Bakel (hvbakel) wrote :
Harm van Bakel (hvbakel) wrote :
Harm van Bakel (hvbakel) wrote :
Harm van Bakel (hvbakel) wrote :

It seems that this is somehow related to the converted pdf that is generated from the original by evince/cups and sent for printing. When I do 'print to pdf' in evince and then try to print the resulting file (which is identical to the spool file generated by evince) using lpr, the resulting print job also stays stuck in the print queue. I'm not sure why the conversion step is even needed and why the original pdf file isn't just sent for printing directly.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Is this reproducible with Lucid? Please test and provide us of feedback about it, Thanks in advance.

Changed in evince (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in evince (Ubuntu):
status: Incomplete → Invalid
jan (janwge) wrote :

I'm experiencing this bug on Lucid 32Bit:
Printing PDFs using evince via a cups server takes very long (very long = up to 30 min per page).
Printing the same PDF using acroread works perfectly.

exactt (giesbert) wrote :

confirming as well for lucid 64-bit

Changed in evince (Ubuntu):
status: Invalid → Confirmed
tags: added: apport-collected

Architecture: amd64
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
Package: evince 2.30.3-0ubuntu1.1
PackageArchitecture: amd64
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-2.6.32-24-generic root=UUID=ced4a8cd-337b-40a7-af1a-302ebf22d8f2 ro quiet splash
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-24.38-generic 2.6.32.15+drm33.5
Tags: lucid
Uname: Linux 2.6.32-24-generic x86_64
UserGroups: adm admin cdrom dialout libvirtd lp lpadmin plugdev sambashare vboxusers

apport information

apport information

apport information

Arthur Wiebe (artooro) wrote :

This is a really bad bug. Adobe Reader works fine but I can't switch our Ubuntu deployment to acroread because of other reasons.

Is there any way I can help to get this resolved asap? I am working on another ubuntu deployment Oct 1st and this is one of the issues that needs to be resolved before that can happen.

exactt (giesbert) wrote :

I fixed this by switching the printer driver for my HP LaserJet from Postscript to PCL. Maybe this helps others as well...

Arthur Wiebe (artooro) wrote :

Thanks exactt,

I have three different models of printers on this network:

Lexmark x464de
Lexmark T654DN
Lexmark X264DN

Have not been able to find PCL drivers for those printers yet.

Stefan Oschkera (steff35) wrote :

Same problem here under Lucid 32bit with all updates available to date (01.10.2010). I've noticed, that evince calls pdftops (see top via xterm), which seems to be the cause for both, the massive delay and a heavy CPU workload (100% on one of the cores).

luinfana (tony-mondelli) wrote :

I can confirm this problem as well, with an HP Photosmart C135 and Ubuntu 10.10 x64, 2.6.35-22. This definitely looks like it's a problem with the way evince spools the job, since using xpdf solves the problem for me too. With evince the job would take an absurd amount of time. I also tried changing my print driver from hpcups to hpijs on the advice of some forum instructions, but it didn't seem to make a difference. This is surprising to me, as I've really never had printing problems, HP or otherwise, with 10.04 or previous versions.

carlos (cplopez) wrote :

I can confirm this problem with Maverick. I use a OKI B410D laser printer. The work does not start after a looooong time (for me, up to 4 hours with letter-sized images), but once it finishes sending the work, all pages are printed at normal speed and without interruption.

carlos (cplopez) wrote :

Also, printing of the SAME documents takes some seconds with epdfviewer.

Samuel Wolf (samuel-wolf) wrote :

Same problem here with ubuntu 10.04 x86_64, using okular solved the problem.

lucacerone (lucacerone) wrote :

I can confirm the bug using Ubuntu 11.04 32 bit.
With evince (coming with the default installation) the first page is printed quite
quickly but for the other you have to wait a lot (i'm not sure whether the document would have been
printed because after two minutes of wait for the second page i canceled the process).

Printing with Okular doesn't show this slow response.

For any further information let me know the output of which commands you need and I'll
post them.
Regards, Luca

Hello Customer

Order your replica watch in a simple way and wait for delivery of really amazing quality product. We have money back guarantee, and guarantee the reshipping, if your watch arrive damaged or missing.
Everyone will notice your new expensive-looking watch, but nobody will find out that it is a replica watch. Designed as a genuine one to the tiniest detail replica watch differ only in price.

--------------------------------------------------------------------
My order arrived yesterday via registered mail in good order THE WATCH IS BEAUTIFUL AND EVEN BETTER THAN I EXPECTED.
TUVM
                     Clint Rutherford
--------------------------------------------------------------------

Click here ---> http://kravo.ru

As for me, the pdf I want to print was generated with latex. It contains only text.
And it takes years to get printed on my Ricoh Afficio MP C2050.

Some precision:
Printing with evince is slow, but printing with epdfviewer is a lot faster!

Sebastien Bacher (seb128) wrote :

it's likely a cairo or poppler issue

Not reproducible in Trusty.

Changed in evince (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers