evince assert failure: *** glibc detected *** evince: free(): invalid pointer: 0xb5abf8c9 ***

Bug #513261 reported by fiat1100d on 2010-01-27
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: evince

I was displaying the DVI preview of a Lyx document when I got this error. The DVI wasn't displayed at all.

ProblemType: Crash
Architecture: i386
AssertionMessage: *** glibc detected *** evince: free(): invalid pointer: 0xb5abf8c9 ***
CrashCounter: 1
Date: Wed Jan 27 15:11:12 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/evince
Package: evince 2.29.5-0ubuntu1
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-2.6.32-11-generic root=/dev/sda1 ro rootfstype=ext4 ipv6.disable=1 acpi_enforce_resources=lax
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-11.15-generic
Signal: 6
SourcePackage: evince
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/tls/i686/cmov/libc.so.6
 abort () from /lib/tls/i686/cmov/libc.so.6
 ?? () from /lib/tls/i686/cmov/libc.so.6
 ?? () from /lib/tls/i686/cmov/libc.so.6
Title: evince assert failure: *** glibc detected *** evince: free(): invalid pointer: 0xb5abf8c9 ***
Uname: Linux 2.6.32-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare src vboxusers

fiat1100d (gratteri-email) wrote :

StacktraceTop:
 __kernel_vsyscall ()
 *__GI_raise (sig=6)
 *__GI_abort () at abort.c:92
 __libc_message (do_abort=2,
 malloc_printerr (action=<value optimized out>,

Changed in evince (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public

For me, the problem appeared when trying to open http://paultaylor.eu/diagrams/manual.dvi
Evince crashed before it would show the application window.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a valgrind log following the instructions at https://wiki.ubuntu.com/Valgrind and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in evince (Ubuntu):
status: New → Incomplete

There's some kind of heisenbug here.

I ran evince on http://paultaylor.eu/diagrams/manual.dvi (downloaded it beforehand) and it crashed.

I then ran
     G_SLICE=always-malloc G_DEBUG=gc-friendly valgrind -v --tool=memcheck --leak-check=full --num-callers=40 --log-file=valgrind.log evince manual.dvi

Evince started slower now (expected because of valgrind and the env variables).
Evince no longer crashed, and, even more, after closing evince, calling evince on the same manual.dvi file DID NOT lead to a crash.

So, to make it clear, after making the check with valgrind, evince no longer crashed while loading manual.dvi from http://paultaylor.eu/diagrams/manual.dvi

These are the logs from running evince through valgrind the first time.

fiat1100d (gratteri-email) wrote :

I noticed the same behaviour reported by Lucian:
- evince crashes when opening DVI without Valgrind;
- it displays fine when slowly opening DVI using Valgrind;
- after that the same DVI document still opens correctly when running without Valgrind.

From the debugger logs, I see that the ~/.texmf-var directory is used for generating fonts.
If I try to delete ~/.texmf-var (rm -r .texmf-var from Home directory) after the above passages, and then run evince for opening the same DVI document, it crashes again. But, if I run evince with Valgrind, then the document opens fine as in the above mentioned steps.

Lucian, could you check this?

fiat1100d (gratteri-email) wrote :

This is my Valgrind log, after a correct display

Changed in evince (Ubuntu):
status: Incomplete → New
Timmy Shih Jun Yee (shijun) wrote :

Evince no longer crashes when opening manual.dvi, so I'm closing this bug. However, the file cannot be opened (which itself is a separate bug; please file a new bug report for that).

(I tested this with Evince 2.30.3-0ubuntu1.1 on Lucid.)

Changed in evince (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers