Evince does not print PDF to HP LaserJet 3380

Bug #513058 reported by oss_test_launchpad on 2010-01-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evince

Testing7.04-7.10-8.04-8.10-9.04-9.10-10.4 I observed a constant loss in functionality as far as printing to a HP LaserJet 3380 is concerned.

From 7.04-9.04 printing worked fine.

9.10 showed some akward behaviour: Printing from the default PDF viewer, it sometimes took ages to print. Also, unlike before, when calling the print dialogue, for some seconds the window froze while it said something like "Informationen über Drucker werden geholt" (getting printer data). Printing PDFs, however, worked fine with xpdf.

Now testing 10.04 Alpha 2 with all of today's update, evince again refuses to work. While the printer queue has been reporting the printer as "Ausführend" (= executing print job), on attempt of repeating the print job, the print dialogue says "Bad pattern", whatever that may be.

I can provide additional information if you tell me which would be needed.

The present 10.04 that is being tested is a 32-Bit version. 9.10 and 9.04 have been 64-Bit versions. Prior versions have probably been 32-bit versions.

PS It works here if BEFORE printing with evince the document has been printed with Okular.

PS II When evince tried to print (see first post), CPU load went up to as much as 100% and the machine nearly burnt down.

PS III No problem with xpdf, either, though the printer queue GUI claims that the print job has 0kb.

Micah Gersten (micahg) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:

apport-collect 513058

This will help us to find and resolve the problem. Bear in mind that you may need to install the python-launchpadlib package from the universe repository. Thanks in advance!

Changed in evince (Ubuntu):
status: New → Incomplete

there is no need to use such strong wording in the bug title, the bug settings and comments are enough no need to express your opinion on whether the bug is annoying or not there

summary: - [Lucid, Karmic] MAJOR REGRESSION: Evince does not print PDF to HP
- LaserJet 3380
+ does not print PDF to HP LaserJet 3380
Changed in evince (Ubuntu):
importance: Undecided → Low

Please justify the classification of this bug as of "low" importance.

summary: - does not print PDF to HP LaserJet 3380
+ Evince does not print PDF to HP LaserJet 3380
Stefan L. (idbnowng) wrote :

Evince does not print to LaserJet 2200dtn either. I do not think, it is a problem with HP printer but one with evince or poppler. This bug should be classified important, since a desktop computer is useless, if you cannot print with it.

Could someone please run apport-collect per my comment above? Just 1 or
2 please. I have a feeling this is an apparmor issue, but would like
confirmation.

On 01/28/2010 06:11 PM, Stefan L. wrote:
> Evince does not print to LaserJet 2200dtn either. I do not think, it is
> a problem with HP printer but one with evince or poppler. This bug
> should be classified important, since a desktop computer is useless, if
> you cannot print with it.
>
>

Architecture: i386
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: evince 2.30.1-0ubuntu2
PackageArchitecture: i386
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=afde3f2a-7d67-4528-b996-5188274fd3c2 ro quiet splash
ProcEnviron:
 LANG=nl_BE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Tags: lucid
Uname: Linux 2.6.32-22-generic i686
UserGroups: adm audio cdrom dialout dip fax fuse lpadmin netdev plugdev sambashare tape video

tags: added: apport-collected

apport information

apport information

apport information

Joachim Beckers (jbeckers) wrote :

I have this issue with an officejet pro k550dtn. ran apport-collect just a few seconds ago.

Architecture: i386
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
NonfreeKernelModules: nvidia
Package: evince 2.30.0-0ubuntu1
PackageArchitecture: i386
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=db7dbed5-be06-45dd-a996-411c70e82384 ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Tags: lucid
Uname: Linux 2.6.32-22-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

apport information

apport information

apport information

Gerrit Niezen (gerrit-niezen) wrote :

Added my apport above, as I'm experiencing the exact same problem with evince. I've tried printing via samba to two network printers from evince, both with the same result. CPU load goes up to 100% for a process called "pdftopdf" (one process for each print job) and print dialogue says "Bad pattern".

Printing from epdfview didn't cause any problems, so it does seem to be evince specific.

Micah Gersten (micahg) wrote :

Ok, so it seems we have multiple bugs here. Gerrit Niezen is having a problem with the cups apparmor profile. I'm not sure what issue Joachim Beckers is having as his log is not showing a profile issue. I'm also not sure what issue the original reporter is having either.

So, my advice is that:
Gerrit Niezen should file a new bug against cups (ubuntu-bug cups) explaining the error.
The original reporter should run apport-collect to see if it's an apparmor profile issue.

@Joachim Beckers
I thank you for taking the plunge and running apport collect first, but I have no idea what's causing your issue. If the reporter's bug ends up being the same as Gerrit Niezen's, then we can have you file a new bug and have it triaged separately (which you can do if you want now), if not, then we'll have to see what other information is needed.

Leaving as Incomplete pending the original reporter running apport-collect.

Gerrit Niezen (gerrit-niezen) wrote :

My problem with evince seems to have solved itself. I don't know if this is due to a recent evince and/or cups update, but everything seems to be working fine now, including printing to network printers via samba.

axx (axx) wrote :

I can confirm this behaviour on a 400 KB pdf (PDF-1.5) file created by Adobe InDesign CS5 (7.0) with Evince 2.3.30 using libspectre (0.2.3) and with an HP OfficeJet J6400 series, with HPLip 3.10.2.
This is Ubuntu Lucid Lynx 10.04, 2.6.32-24-generic #42-Ubuntu SMP Fri Aug 20 14:24:04 UTC 2010 i686 GNU/Linux.

Phew ok, enough of the version numbers.

Basically, same issue as the original poster, Evince document viewer says doesn't print the pdf file, it sends it to the print queue but nothing happens, and when one tries to print it a second time, the printer status is set to "bad pattern".

If you need more info I'll be happy to provide it.

Thanks for your help.

mkwa (mkol2006) wrote :

I have ubuntu 10.10 64bit and evince does not print to my HP3330 printer. Evince does print to my other printer (Epson inkjet). Open Office and Firefox print to both printers.

The problem started with 10.10. All printing combinations worked in 10.04.

Joachim Beckers (jbeckers) wrote :

my machine is on natty now. it's fixed afaict

Sebastien Bacher (seb128) wrote :

closing since that works with the current version

Changed in evince (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers