Ubuntu 9.10 Freezes When Resizing Evince

Bug #510573 reported by yoleg
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Fix Released
Medium
Ubuntu Desktop Bugs

Bug Description

I found this in question #97794:

"I've just installed Ubuntu 9.10 on an IBM T42 ThinkPad. When I open a PDF in Evince and attempt to resize the window, the system freezes up badly - not even caps lock responds. It doesn't seem to be an official kernel panic because there are no blinkenlights. So far nothing else has caused the same sort of freeze."

I have the exact same problem as the person above... I also have Ubuntu 9.10 on a T42 thinkpad. I consistently get it from looking at a print preview of a keyboard layout and resizing the window.

yoleg (oleg-yoleg)
summary: - Ubuntu 9.10
+ Ubuntu 9.10 Freezes When Resizing Evince
tags: added: evince
tags: added: t42 thinkpad
Revision history for this message
Pedro Villavicencio (pedro) wrote :

could you please attach that pdf file to the report? Thanks in advance.

affects: yelp (Ubuntu) → evince (Ubuntu)
Changed in evince (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
status: New → Incomplete
Revision history for this message
yoleg (oleg-yoleg) wrote : Re: [Bug 510573] Re: Ubuntu 9.10 Freezes When Resizing Evince

I'm not sure how to attach this pdf or postscript or whatever it is... it's
a print preview of a system file and evince loses its normal menus during
the print preview. The only reason I know it's evince is by the logo on the
upper left. Here's how I got there:

   1. System --> Preferences -> Keyboard --> Layouts
   2. Change Keyboard Model to IBM Thinkpad R60/T60/R61/T61
   3. In the window "Selected Layouts", add a USA layout to have two USA
   layouts (probably not necessary, but that's what I have)
   4. Select the second layout and press "Print"
   5. Press "Print Preview"
   6. Move and resize the print preview window and it will freeze during one
   of the resizes. (I reproduced this three times in a row)

Also let me know if you need any system summaries or error logs (and how to
get them for you). I'm not a complete novice, but I'm still pretty
unfamiliar with Linux. I also did add a few packages to the default install,
including first adding the fglrx driver packages, then removing all
fglrx-related packages and adding the xserver-xorg-video-ati package. Before
doing that, I had slow graphics and other freezing issues, which may or may
not be related.

On Thu, Jan 21, 2010 at 3:49 AM, Pedro Villavicencio <email address hidden>wrote:

> could you please attach that pdf file to the report? Thanks in advance.
>
> ** Package changed: yelp (Ubuntu) => evince (Ubuntu)
>
> ** Changed in: evince (Ubuntu)
> Importance: Undecided => Medium
>
> ** Changed in: evince (Ubuntu)
> Status: New => Incomplete
>
> ** Changed in: evince (Ubuntu)
> Assignee: (unassigned) => Ubuntu Desktop Bugs (desktop-bugs)
>
> --
> Ubuntu 9.10 Freezes When Resizing Evince
> https://bugs.launchpad.net/bugs/510573
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “evince” package in Ubuntu: Incomplete
>
> Bug description:
> I found this in question #97794:
>
> "I've just installed Ubuntu 9.10 on an IBM T42 ThinkPad. When I open a PDF
> in Evince and attempt to resize the window, the system freezes up badly -
> not even caps lock responds. It doesn't seem to be an official kernel panic
> because there are no blinkenlights. So far nothing else has caused the same
> sort of freeze."
>
> I have the exact same problem as the person above... I also have Ubuntu
> 9.10 on a T42 thinkpad. I consistently get it from looking at a print
> preview of a keyboard layout and resizing the window.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/evince/+bug/510573/+subscribe
>

Revision history for this message
yoleg (oleg-yoleg) wrote :

It also froze the system when I viewed another PDF, so it's not just the print preview.

Revision history for this message
Pedro Villavicencio (pedro) wrote :

at the bottom of this page there's a "Add attachment or patch" link, you can click there and attach the pdf causing problems to you. Thanks.

Revision history for this message
Anaxagoras (thomas-ries-net) wrote :

Same problem here. Also on a T42. When i resize the pdf view with the splitter between table of contents on the left and the main view, the system will freeze and all i can do is to power off and reboot. I'll attach an pdf causing the problem.

Linux version 2.6.31-19-generic (buildd@palmer) (gcc version 4.4.1 (Ubuntu 4.4.1-4ubuntu8) ) #56-Ubuntu SMP Thu Jan 28 01:26:53 UTC 2010

Revision history for this message
Anaxagoras (thomas-ries-net) wrote :

The same problem occured with other pdfs before. So I don't think it's related to a special pdf, although I posted one above, that caused the problem reproducable.

Revision history for this message
Jan Schilder (jgm-schilder) wrote :

I also have frequent kernel panics (blinking caps-lock indicator) when reading PDF files in Envince, ever since I upgraded to Karmic.
I have an ACER 1501LMi (AMD Athlon 64 bits processor and Ubuntu installation). I never had this before. Quite enoying, since I need to switch the laptop off by keeping the onoff button pressed for about 20 seconds.

Revision history for this message
Lisa Hsu (chioulienh) wrote :

I've encountered several times with the same problem on my Ubuntu 9.10 system when I was resizing Terminal Windows to make it bigger. I have to power down in order to recover the system.

It seems like when you re-size the window to an odd pixels such as 102x51 (the current one cause the system to freeze). I did not record the previous dimensions to show more possible problem sizes.

Also, when there are more than two windows on the screen, by moving the window around, the window which was overlapped did not get re-draw so the window can't be readable. You have to make it active in order to get i redraw to the normal view.

Is there any way to recover once the system freezes after resizing the window?

Revision history for this message
Lisa Hsu (chioulienh) wrote :

I've installed Ubuntu 10.04 with dual boot on my Asus ULTh80V. There has no window resize problem.
My previous problem might due to my graphic card not configure properly on my Dell laptop PC.

Revision history for this message
P. Oscar Boykin (boykin) wrote :

I've found that evince is virtually unusable on 9.10 on a T42 laptop. Almost every resize will lock the machine up forcing a hard reset. I *can* use xpdf usually without trouble, but it doesn't look as nice.

I can't seem to find any hints from the logs once I restart.

Revision history for this message
Kaj Ailomaa (zequence) wrote :

Same thing here. Total system freeze.
I have an older computer with amd sempron, built in graphics. No 3d.
I also get a system freeze when visiting some web pages with lots of flash content.
Sometimes the freeze happends when resizing a pdf window, or using mouse scroll on web pages. Something seems to go wrong during redraw of the screen. Just a guess.
No problems with my new computer with nvidia graphics, though I had the same problem with the new computer a year ago with Ubuntu 8.10 or 9.04 (can't remember which).

My current setup (old sempron desktop, built-in graphics): Puredyne distro installed with xfce (based on Ubuntu 9.10)
The earlier setup, a year ago (new intel desktop, nvidia 7300): Ubuntustudio (8.10 or 9.04) with gnome

This may not be relevant, but I get this message while booting puredyne:

[ 6.745418] codec_read: codec 0 is not valid [0xfe0000]
[ 6.751798] codec_read: codec 0 is not valid [0xfe0000]
[ 6.758278] codec_read: codec 0 is not valid [0xfe0000]
[ 6.764830] codec_read: codec 0 is not valid [0xfe0000]

Revision history for this message
Kaj Ailomaa (zequence) wrote :

As far as I can tell, this bug is fixed. I have had no crashes after Karmic, on any system.

Revision history for this message
Arian (stolwijk-arian) wrote :

When resizing the document attached in #5, evince still freezes for about 10 seconds. I'm using Ubuntu 10.10 on a HP EliteBook 8530w.

Revision history for this message
IKT (ikt) wrote :

Can't replicate the issue on 11.04, opening the pdf in #5 doesn't cause any freezing but it should be noted that evince freezing for 10 seconds is a completely separate bug to the one originally reported.

Please feel free to re-open if you can duplicate the original issue on 11.04 or 11.10

thanks

Changed in evince (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions