Evince doesn't retain settings in Lucid

Bug #503372 reported by Christopher on 2010-01-05
198
This bug affects 39 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Didier Roche
Lucid
Low
Didier Roche

Bug Description

Binary package hint: evince

 evince (2.30.1-0ubuntu2) lucid-proposed; urgency=low
 .
   * add debian/patches/02_fix_dot_dir_creation.patch:
     fix dot dir creation when launching evince directly (LP: #571725)
 .
 evince (2.30.1-0ubuntu1) UNRELEASED; urgency=low
 .
   * New upstream release:
     Bug fixes:
     - Make inverted colors mode work in presentation mode too
       (#614693, Carlos Garcia Campos)
     - Respect GNOME22_USER_DIR env variable (#613637, Ray Strode)
     - Fix loading of local documents when uri contains a page
       destination (#616515, Carlos Garcia Campos)
     - Take default settings from last document opened. Fixes
       regression caused by migration to gio metadata (#606090, Carlos
       Garcia Campos) (LP: #544639, #503372)
     - Update icons to match gnome-icon-theme appearance (#614747,
       Hylke Bons, Carlos Garcia Campos)
     - Make sure there's a new valid page range before updating caches
       (fdo#27599, Carlos Garcia Campos)
     - Update FSF address everywhere (#514607, Arun Persaud)
     - Fix loading of compressed password-protected documents (#613959,
       Carlos Garcia Campos)
     - Close previewer window with control + w (#612972, Carlos Garcia
       Campos)
     - Fix keybindings in previewer window (#612972, Carlos Garcia
       Campos)
     Translation updates

Test case:
install evince from -proposed, open some pdf document, close them, reopen them to see the window has the same size

-----------------

Previous systems - Karmic, Jaunty and before kept the last settings in Evince. In Lucid, it always opens with the side pane and in mini-mode.

I expected it to open in the mode last used.

ProblemType: Bug
Architecture: i386
Date: Tue Jan 5 09:00:39 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20091225)
Package: evince 2.29.4-0ubuntu1
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-9.13-generic
SourcePackage: evince
Tags: lucid
Uname: Linux 2.6.32-9-generic i686

Christopher (soft-kristal) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?
 * The setting storage is by document, did you try on the same pdf? did you get any installation issue

 This will help us to find and resolve the problem.

Changed in evince (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
Christopher (soft-kristal) wrote :

It happens every time I open any PDF document. In Karmic and previous versions a PDF opened with the settings (page width, side pane or no side pane) as the last document opened.

In Lucid, it always opens with the side pane and uses about a quarter of the display. I can maximize and close the side pane, but it reverts to what I assume is the installed setting the next time I open a PDF.

It's not a serious bug, but it is annoying.

Sebastien Bacher (seb128) wrote :

did you interrupt the upgrade or something? does reinstalling evince fix the issue? it works correctly on my install...

Christopher (soft-kristal) wrote :

It's a clean installation, not a upgrade. Evince was in yesterday's updates and it was not interrupted, but there was no change in behavior.

I'll reboot in Lucid and see what's going on today. I do all my real work in Karmic.

Christopher (soft-kristal) wrote :

Here's a screenshot of Evince opening a PDF.

Sebastien Bacher (seb128) wrote :

so you do open this pdf, change the sidebar, close evince, open the same pdf again and don't get the sidebar config you had?

Christopher (soft-kristal) wrote :

It always opens as on the screenshot. It defaults to an open sidebar regardless of what it was set to on the last use, even with the same PDF.

I have Acoread installed as well and it obeys the preferences.

Christopher (soft-kristal) wrote :

The occasional PDF does open maximized but I haven't found any reason why. As an example, I received two PDF documents from a company related to the same thing. One opens without the side bar and is in full mode while the other opens with the side bar in compact mode.

I checked the Properties of both documents ant they were generated from the same unidentified source program.

This is too weird.

Sebastien Bacher (seb128) wrote :

I just tried on 3 different pdf and that works correctly there, do you have those documents on disk or opened from a browser or something which use different temporary path every time you do open one?

Changed in evince (Ubuntu):
status: Incomplete → New
Christopher (soft-kristal) wrote :

Most are saved to disk before opening, and some seem to retain their settings for a while when opened from the drive, as opposed to directly from Evince. Rebooting often causes Evince to 'forget' the settings that were working correctly.

Opening a PDF from Firefox in Lucid always has the sidebar open and in compact mode.

Ilja Sekler (ilja-sekler-) wrote :

I think, this is the same as the upstream bug <https://bugzilla.gnome.org/show_bug.cgi?id=606090> and its possible dupe <https://bugzilla.gnome.org/show_bug.cgi?id=607475>. I saw the new behavior with Evince 2.29.5 on Karmic and found it utterly annoying too. Unfortunately, I haven't tested with the latest trunk, maybe it has been already reverted.

While per-file settings are generally a good thing, the option to start Evince with the sidebar closed should be available. The other change from 2.28.1 - default zoom value "Fit Page Width" for new Evince windows - is fine IMHO.

Christopher (soft-kristal) wrote :

Would it be difficult to add 'Preferences' to Evince as are in the Adobe Reader? Nothing elaborate, just options to open with or without the sidebar and in full screen, rather than minimized.

The small default Evince window is OK on a big monitor, but too small on a laptop.

Smeuuh (smeuuh) wrote :

I have the same bug, since my upgrade to lynx from karmic.

Smeuuh (smeuuh) wrote :

Precisions : evince saves settings per pdf, and has default as unmaximized and with a side panel. The previous behaviour was much more sensible. I tried to delete ~/.gnome2/evince/ev-metadata.xml, which contains the per-pdf information, but it had no effect, even when reloading gnome and killing evinced (why do they need a daemon for, anyway ?)

Daniel Newman (dmnewman) wrote :

Same problem here with lucid. On first opening any pdf, evince shows a side pane with thumbnails and occupies a very small area of the screen. If I close the side pane, then resize evince to something readable on my monitor, then close evince, subsequent opening of ***the same*** pdf does not open the side pane and retains the resized display. However, opening a new pdf reverts to the original behaviour.

There should be an option to permanently disable the sidebar, and the size should be remembered for all openings of all files, since desired size is more likely dependent on the desktop real estate than on the document content.

Also, it never makes sense to have side panes, thumbnails or indices for one-page documents. This is not user-friendly behaviour.

GrandVizier (grandvizier) wrote :

I can confirme this behavior in Lucid beta 1.

Peter Northup (peter-northup) wrote :

I can confirm this behavior, too. What I find even more annoying is that the Toolbar is on by default--and this setting doesn't stick even in per-document settings, so I have to turn it off--with the mouse, no less, because there's no darn shortcut for it (any possibility of making one)--every time.

This is quite annoying for people with small screens who read lots of PDFs--I'm an academic with a tablet PC, so I'm about the worst-case here. =(

Winzigweich (moooment) on 2010-04-14
Changed in evince (Ubuntu):
status: New → In Progress
status: In Progress → New

This bug seems to be fixed (or maybe working) on my amd64 ubuntu lucid linx.

I have Architecture: amd64
Version: 2.30.0-0ubuntu1

Spoke too soon...

The settings are retained when you close evince after opening a pdf files.

If you open just evince and close it the settings are *not* retained

Akkana Peck (akkzilla) wrote :

Another metoo, worked in karmic until recently, failed in lucid, but:

- I don't use gnome, and I notice stderr has a message:
** (evince:5984): WARNING **: Failed to create dbus proxy for org.gnome.SettingsDaemon: Could not get owner of name 'org.gnome.SettingsDaemon': no such name

- Karmic's evince until recently has been able to save per-document settings like the page it was on, but just recently that stopped working in Karmic too. Karmic still remembers settings like scaling and not showing the sidebar, but not the per-document page any more.

Jeff (jdorenbush) wrote :

This affects me too.

CTenorman (ctenorman) wrote :

There's a workaround, but it's another program - Okular.

In synaptic install Okular. Once Okular is open press "F7" to turn off the sidebar. Then go to "Settings", "Configure Okular", and remove the check next to "Show hints and info messages."

Next, in Nautilus right-click on any pdf. Click "properties", then "Open with", and click the radio button next to Okular and close.

Finally open up firefox, go to "edit", "preferences", and click on "applications." Next to "PDF document" pull down the menu and click "use other." Click the pencil at the top left and paste into the new textbox "/usr/bin/okular".

Now any PDF you open in firefox, nautilus, or anywhere else should open in Okular without the sidebar.

As a bonus you can use reviewing tools, which are a handy way to mark-up a pdf.

CTenorman (ctenorman) wrote :

I take it back. In PDFs without a table of contents, the above works. However, when there's a table of contents Okular shows it every time, and doesn't save even on a per-file basis.

If anyone figures out a way to show nothing but the PDF itself please let me know. I appreciate the work of those who design Evince and Okular, but this is one situation where the newer method could drive academics slightly batty. :)

Didier Roche (didrocks) wrote :

debdiff available in bug 544639

Changed in evince (Ubuntu Lucid):
status: New → Triaged
assignee: nobody → Didier Roche (didrocks)

Accepted evince into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in evince (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Smeuuh (smeuuh) wrote :

The fix works. However, the window still runs in medium size, and is only resized to full size after a small but noticeable amount of time. I believe the previous version did not have this behaviour, so this is a regression. Presumably the settings are now loaded after the main window is created, while they should be loaded before.

Martin Pitt (pitti) on 2010-04-29
tags: added: verification-done
removed: verification-needed
Pedro Villavicencio (pedro) wrote :

There's a regression due to the proposed package bug 571725

tags: added: verification-failed
removed: verification-done
Didier Roche (didrocks) on 2010-04-30
description: updated
Martin Pitt (pitti) wrote :

I accepted 2.30.1-0ubuntu2 into lucid-proposed which fixes that regression. Please test the updated version. Thank you!

tags: added: verification-needed
removed: verification-failed
François Ingelrest (athropos) wrote :

I've installed a fresh Ubuntu 10.04 on Saturday and I'm facing this bug too. It's really annoying...

Didier Roche (didrocks) wrote :

No need to say "I'm affected on lucid too", please install 2.30.1-0ubuntu2 from lucid-proposed and say if it fixes this for you, or wait for the update to be available.

I installed 2.30.1-0ubuntu2 from lucid-proposed and if it fixed this bug for me. Thank you very much!

François Ingelrest (athropos) wrote :

No need to bash a simple user facing an annoying bug. I don't even know what is lucid-proposed.

Martin Pitt (pitti) wrote :

Copied lucid-proposed to maverick.

Changed in evince (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 2.30.1-0ubuntu2

---------------
evince (2.30.1-0ubuntu2) lucid-proposed; urgency=low

  * add debian/patches/02_fix_dot_dir_creation.patch:
    fix dot dir creation when launching evince directly (LP: #571725)

evince (2.30.1-0ubuntu1) UNRELEASED; urgency=low

  * New upstream release:
    Bug fixes:
    - Make inverted colors mode work in presentation mode too
      (#614693, Carlos Garcia Campos)
    - Respect GNOME22_USER_DIR env variable (#613637, Ray Strode)
    - Fix loading of local documents when uri contains a page
      destination (#616515, Carlos Garcia Campos)
    - Take default settings from last document opened. Fixes
      regression caused by migration to gio metadata (#606090, Carlos
      Garcia Campos) (LP: #544639, #503372)
    - Update icons to match gnome-icon-theme appearance (#614747,
      Hylke Bons, Carlos Garcia Campos)
    - Make sure there's a new valid page range before updating caches
      (fdo#27599, Carlos Garcia Campos)
    - Update FSF address everywhere (#514607, Arun Persaud)
    - Fix loading of compressed password-protected documents (#613959,
      Carlos Garcia Campos)
    - Close previewer window with control + w (#612972, Carlos Garcia
      Campos)
    - Fix keybindings in previewer window (#612972, Carlos Garcia
      Campos)
    Translation updates
 -- Didier Roche <email address hidden> Fri, 30 Apr 2010 09:02:33 +0200

Changed in evince (Ubuntu Lucid):
status: Fix Committed → Fix Released
Didier Roche (didrocks) wrote :

@François: I wasn't bashing you, but you should just read the bug report content before answering as it was written that something was done to fix it. Sorry if it sounded aggressive, it wasn't on purpose :(
Also, as an advice for further contribution, to avoid unneeded mail traffic, instead of saying "me too", you can click on the upper part of the bug report:
"This bug affects xx people. Does this bug affect you?"

Martin Pitt (pitti) on 2010-05-03
Changed in evince (Ubuntu Lucid):
status: Fix Released → Fix Committed
Fabio Marconi (fabiomarconi) wrote :

I executed the test case and the -proposed package solved for me.
Every file is reopened in the same size or %

Martin Pitt (pitti) on 2010-05-04
tags: added: verification-done
removed: verification-needed
Fabio Marconi (fabiomarconi) wrote :

I executed the test case and the -proposed package work good.
Every window is reopened in the size or % previous closing.
Sorry for my bad english. :(

ionospheric (berthold1) wrote :

the update from the lucid-proposed package solved the problem for me.

Pedro Villavicencio (pedro) wrote :

There's another regression caused by the package: bug 578996 ; evince is not able to open document with hash in their filenames as in: blah_#blah.pdf .

Martin Pitt (pitti) wrote :

There was a new upload to fix that regression now.

François Ingelrest (athropos) wrote :

May I ask whether this fix will be available in Lucid updates?

ManDay (manday) wrote :

It would indeed be very nice if evince had just ANY method of being configured. Not even a preferences dialog - a plain config file would already be good enough, so one can set settings such as the above or whether to store settings per-file in the first place. I would like evince NOT TO save settings per file but currently its all up to evince's will :/

ManDay (manday) wrote :

And yes: That bug is very annoying

Johannes Hessellund (osos) wrote :

Lucid-updates ???? Please!

This is really annoying!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 2.30.1-0ubuntu3

---------------
evince (2.30.1-0ubuntu3) lucid-proposed; urgency=low

  [ Jamie Strandboge ]
  * debian/apparmor-profile.abstraction: allow writes to removable media
    (LP: #490230)

  [ Didier Roche ]
  * debian/patches/03_fix_opening_hash_filename.patch:
    Fix opening files with '#' in its name (LP: #578996)

evince (2.30.1-0ubuntu2) UNRELEASED; urgency=low

  * add debian/patches/02_fix_dot_dir_creation.patch:
    fix dot dir creation when launching evince directly (LP: #571725)

evince (2.30.1-0ubuntu1) UNRELEASED; urgency=low

  * New upstream release:
    Bug fixes:
    - Make inverted colors mode work in presentation mode too
      (#614693, Carlos Garcia Campos)
    - Respect GNOME22_USER_DIR env variable (#613637, Ray Strode)
    - Fix loading of local documents when uri contains a page
      destination (#616515, Carlos Garcia Campos)
    - Take default settings from last document opened. Fixes
      regression caused by migration to gio metadata (#606090, Carlos
      Garcia Campos) (LP: #544639, #503372)
    - Update icons to match gnome-icon-theme appearance (#614747,
      Hylke Bons, Carlos Garcia Campos)
    - Make sure there's a new valid page range before updating caches
      (fdo#27599, Carlos Garcia Campos)
    - Update FSF address everywhere (#514607, Arun Persaud)
    - Fix loading of compressed password-protected documents (#613959,
      Carlos Garcia Campos)
    - Close previewer window with control + w (#612972, Carlos Garcia
      Campos)
    - Fix keybindings in previewer window (#612972, Carlos Garcia
      Campos)
    Translation updates
 -- Didier Roche <email address hidden> Thu, 13 May 2010 16:31:06 +0200

Changed in evince (Ubuntu Lucid):
status: Fix Committed → Fix Released
François Ingelrest (athropos) wrote :

Just got the update. Now thumbnails settings are kept (shown or hidden) but it doesn't seem to work with the continuous mode. This mode is always enabled by Evince even if I keep disabling it.

co0lingFir3 (coolingfire) wrote :

I also got the update and it works perfectly for me. The continuous mode settings are also retained as a per file setting, so it works for me.

François Ingelrest (athropos) wrote :

For me also continuous mode is saved per file, but I want it to be saved globally. I don't like and don't want to use this mode, previously it has always been a global setting.

co0lingFir3 (coolingfire) wrote :

But the point of this bug report was, that the settings in evince were not retained at all irrespective of per file or globally. If you want the settings to be saved globally you should probably open a new bug.

sz (szeder) wrote :

This bug reappeared in a fresh 10.10 installation. The symptoms are the same as described earlier in the comments:
When opening a pdf, evince displays a small window with side pane and fit page width. Resize the window, close the side pane, change zoom settings, whatever, then close the window. Open the same pdf (or any other, the result is the same), and evince again opens a small window with side pane and fit page width.

Liquen (rwnobrega) wrote :

@Gábor: Same here. This can somehow be alleviated with "Edit > Save Current Settings as Default" (Ctrl-T). It doesn't work perfectly, though. :(

I can't understand why evince keep reviving old bugs every new release.

I'm scared to think that the fact that there's a menu item to "Save
current settings as default" might mean that it's actually intended as a
feature by design... Someone would need to check with upstream about
that.

I also can confirm this bug on Maverick.

The status of the ticket should be changed. Or have we to open new ticket?

Didier Roche (didrocks) wrote :

The behavior changed in maverick. As someone told previously, you have to explicitely save your setting in the File menu now. I think I've heard it's fixed in the new evince we will get in Natty (I mean, no more explicit save needed). I don't think this can be easily backported to maverick.

You can open another bug report if it doesn't exist already.

Carlos Manuel (crolidge) wrote :

It's a pity Evince still has these bugs after all these years, despite being such a basic application.
It's unbelievable the window doesn't launch maximised when we want it, it's unbelievable the absence of a "Set default zoom" option. Those are the basics, honestly.
The problem with the window not maximised is also that round corners provided by the (awkward) window managers don't help at all...

I'm using Linux Mint 10 (= Ubuntu 10.10) and these issues still lingers on....
Can someone speed up resolution of these issues please? Thanks a lot!

This is the only reason why I can't use Evince... This bug is just too annoying to endure, please give this a higher priority.

Fabien Engels (fabienengels) wrote :

I got the same problem (under Natty) until I install this package : libdconf0 (I'm used to install Ubuntu in command line then I add minimal package set I need ...). Maybe you should try this, hoping it'll fix your problem.

(Evince uses dconf to store its settings)

rho (rho-t) wrote :

aaaand, years later, this bug persist.
It is clear that a higher priority needs to be applied, this is probably one of the most annoying bugs I ever confronted...

Pease guys, someone fix this.

I'm running Ubuntu-Gnome 14.04 with Gnome 3.12.2 and the problem persist when a third-party app triggers a pdf to be open. Firefox, sublime, texmaker... when evince opens, none of the preferences are recognized.

Jeff (jdorenbush) wrote :

At some point, this bug stopped being an issue for me, but that was several versions ago. In Ubuntu 14.04, I can confirm that I'm still experiencing this bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.