Evince display error: page "tears" when scrolling

Bug #484527 reported by Neil Cavan on 2009-11-18
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evince

when scrolling (using either the scrollbar or the mouse wheel), the top and bottom portions of the screen are not updated - looks like about the top and bottom 1/8th of the screen. The affected area is in the direction of scrolling, ie if you scroll up the bottom 7/8ths of the page scrolls but the top 1/8th remains constant.
These errors "stack", leading to very illegible text very quickly. The error occurs in every PDF I have tried, in continuous or not, at every zoom level.

Anything that forces a redraw fixes the issue: taking a screenshot, clicking Evince's titlebar, or switching windows all fix the display.

ProblemType: Bug
Architecture: amd64
Date: Tue Nov 17 19:10:40 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/evince
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: nvidia
Package: evince 2.28.1-0ubuntu1.1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: evince
Uname: Linux 2.6.31-14-generic x86_64

Neil Cavan (neilcavan) wrote :
Neil Cavan (neilcavan) wrote :

Because taking a screenshot forces a redraw and corrects the problem, here are pics of what's actually on the monitor. The image sequence is:

174 - correct display
175 - scroll down one mousewheel tick: notice the doubled new region at the bottom. Is the off-screen rendered image segment being copied in twice by accident?
176 - scroll up one tick: same problem at the top, and we still have one bad region on the bottom
177 - scroll down one tick: problem compounds
178 - scroll up one tick: this image SHOULD be identical to 174, and clicking on the titlebar makes it so.

Neil Cavan (neilcavan) wrote :

Hmmm... The problem has disappeared after I closed all running instances of Evince and re-started. This was, of course, the first thing I tried before filing the bug, but I missed an open window on another desktop.

This is probably related to suspend/resume - Evince was working fine this morning, I suspended and resumed, and then the problem showed up.

Dimitrios Symeonidis (azimout) wrote :

marking as incomplete for now.
let us know if this is reproducible
thanks

Changed in evince (Ubuntu):
status: New → Incomplete
Neil Cavan (neilcavan) wrote :

This is reproducible.

The problem occurs every time I suspend/resume with open Evince windows, and is solved by closing all open instances and re-starting Evince. Re-starting X or the computer is not necessary.

ViktigLemma (jorgsk) wrote :

The same thing happens to me. I haven't yet figured out when it starts, but to remove the effect I have to close all Evince windows and open the documents again.

Gary Alexander (alexanderg) wrote :

I have the same issue with Evince as well as with Evolution and Gedit

I am using Nvidia graphics drivers:

nvidia-glx-185:
  Installed: 185.18.36-0ubuntu9
  Candidate: 185.18.36-0ubuntu9
  Version table:
 *** 185.18.36-0ubuntu9 0
        500 http://za.archive.ubuntu.com karmic/restricted Packages
        100 /var/lib/dpkg/status

Gary Alexander (alexanderg) wrote :

After some playing around, I have disabled compiz (System .. Preferences ... Appearance ... Visual Effects tab and Click on None).
This has stopped these issues for me, so try this and see? Suspect this could be a compiz issue...

Changed in evince (Ubuntu):
importance: Undecided → Low
skalka (skalka) wrote :

I can confirm that this issue is related to Compiz, without effects everything works fine. I can live without compiz, but what about mutter? I've tried it in substitution of metacity and inside gnome-shell and I have exactly the same issue. Could it be related to nvidia drivers? Any idea to get rid of this annoying bug?

madbiologist (me-again) on 2010-01-23
Changed in evince (Ubuntu):
status: Incomplete → Confirmed
David Tomaschik (matir) wrote :

I can also confirm this issue and confirm that disabling compiz fixes it. I'm going to attempt to investigate if any particular compiz settings affect it, or if it is just the compiz window manager.

Neil Cavan (neilcavan) wrote :

This bug is now affecting other applications: I have experienced the same symptoms in OpenOffice, gedit, and even the Nautilus file browser.

It is not confined to suspend/resume - i have experienced the issue on a fresh boot.

This appears to be related to compiz/nvidia, rather than evince.

Andrew Bulmer (bulmer) wrote :

I notice that this happens after I change video settings. When I connect a monitor to my laptop and set up dual display (which requires me to change video settings) this happens everytime. but

I'm also using a nvidia graphics card.

Not reproducible in Trusty.

Changed in evince (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers