evince-thumbnailer blocks the system with huge memory-load

Bug #461015 reported by Prunus dulcis on 2009-10-26
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: evince

I am running the Ubuntu Karmic RC with all patches till today applied.
When I accessed a folder in nautilus, suddenly the whole system became unresponsive (like mouse only moved about every five seconds), the disk was constantly being accessed (I presume due to the high memory load caching everything it can on disk), the Internet connection was lost, after a few minutes the window-decorations went down partially and then I had to hard reset the notebook (by pressing the power button for 5 seconds). This is the second time this happened in two days and since this is completely stopping any productive work with the system I hope this can be fixed soon (or already is because this is a duplicate :-)).

Thanks and best regards

ProblemType: Bug
Architecture: i386
Date: Mon Oct 26 11:45:35 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386 (20091020.3)
Package: evince 2.28.1-0ubuntu1
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Error: [Errno 2] No such file or directory: '/proc/version_signature'
SourcePackage: evince
Uname: Linux 2.6.32-020632rc5-generic i686
XsessionErrors:
 (gnome-settings-daemon:1446): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1446): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:1556): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:1536): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (gnome-panel:1535): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -12 and height 26

Prunus dulcis (prunus-dulcis) wrote :
Prunus dulcis (prunus-dulcis) wrote :

It actually might be a problem with the pdf files in the folder, because they were the only ones, which had the -still creating preview- circles in them.

Prunus dulcis (prunus-dulcis) wrote :

I was able to reproduce it once (but not anymore) while using
gksudo nautilus
(and I have used this method the last time, this problem ocurred). This time I managed to kill evince-thumbnailer after a few minutes of unresponsive desktop and tried to make a test-case by moving the pdf files to different folders but I cannot reproduce the symptoms anymore, since the files are already thumbnailed and evince-thumbnailer is not even showing a hint of the problem anymore.

Dimitrios Symeonidis (azimout) wrote :

To trigger thumbnailing again, just remove the folder ~/.thumbnails

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you add a pdf example there?

Changed in evince (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Prunus dulcis (prunus-dulcis) wrote :

I think I have found the one pdf that is actually responsible for choking evince-thumbnailer (regardless wether with gksudo nautilus or normal nautilus - but normal nautilus already had choked once on it and afterwards it seems to know, that it has failed on that file and evince-thumbnailer does not try again - probably one of the entries in the .thumbnails/fails/ folder).

The file was created by myself with graphics from Blender but I am quite sure, I made the pdf with inkscape (though I cannot say that for certain, it may also have been GIMP). I hope I can attach such large files (5.x MB)

Christopher (soft-kristal) wrote :

This bug is now affecting Lucid. It seems to happen when creating a PDF from a business (Filogix) website. Everything grays out and I can't open the System Monitor to kill it.

Charlie Kravetz (charlie-tca) wrote :

Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Using the attached PDF file and Xubuntu Lucid Lynx, I can confirm this issue. Opening the attached PDF brought my 64bit system with 3GB ram to a complete halt.

Changed in evince (Ubuntu):
status: Incomplete → Confirmed
Jon Olav Vik (jonovik) wrote :

It would be nice just to set limits for how big files should be thumbnailed, or maximum memory usage for evince-thumbnailer, or both.

Hauke Holtkamp (h-holtkamp) wrote :

When Nautilus tries to preview pdf files in thumbnails, sometimes evince-thumbnailer grows to the memory limit and the system starts swapping. Killing the process takes several minutes due to the memory swapping. It does not happen always, maybe on every tenth time that I open a folder containing pdfs in thumbnail view. This is on 64bit lucid.

Prunus dulcis, thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Vivid Vervet.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please perform as much as possible of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

tags: added: karmic trusty
Changed in evince (Ubuntu):
importance: Low → Medium
status: Confirmed → Fix Released
asala (asala) wrote :

Still having these issues in the 15.04 version. It fills my 16 GB RAM system from time to time... reisub being the only way to come back to life.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers