evince apparmor profile blocks DVI printing

Bug #452057 reported by Søren Bredlund Caspersen on 2009-10-15
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
High
Jamie Strandboge
Karmic
High
Jamie Strandboge

Bug Description

Binary package hint: evince

I have upgraded to Karmic a few days ago.

Now Document Viewer (evince) won't print .dvi files. I can select the printer, but they don't show up in the print queue. Printing .pdf files works fine.

This worked fine in 9.04.

ProblemType: Bug
Architecture: i386
Date: Thu Oct 15 12:32:22 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/evince
NonfreeKernelModules: nvidia
Package: evince 2.28.0-0ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_DK.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.46-generic
SourcePackage: evince
Uname: Linux 2.6.31-14-generic i686

Related branches

Duncan Sands (baldrick-free) wrote :

Apparmor stops evince from running the helper program /usr/bin/dvipdfm, which evince uses when printing dvi files.
Here's the apparmor audit line from dmesg:

type=1503 audit(1255613594.858:24): operation="exec" pid=2889 parent=2876 profile="/usr/bin/evince" requested_mask="::x" denied_mask="::x" fsuid=1000 ouid=0 name="/usr/bin/dvipdfm"

The result is that it is no longer possible to print dvi files. Presumably the apparmor profile for evince should be taught that running /usr/bin/dvipdfm is ok.

Changed in evince (Ubuntu):
assignee: nobody → Jamie Strandboge (jdstrand)
importance: Undecided → High
milestone: none → ubuntu-9.10
status: New → Triaged
tags: added: regression-potential
summary: - Document Viewer won't print DVI files, but prints .pdf files with no
- trouble.
+ evince apparmor profile blocks DVI printing
Jamie Strandboge (jdstrand) wrote :

Debdiff to fix the bug.

Changed in evince (Ubuntu Karmic):
status: Triaged → In Progress
Changed in evince (Ubuntu Karmic):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 2.28.0-0ubuntu5

---------------
evince (2.28.0-0ubuntu5) karmic; urgency=low

  * debian/apparmor-profile.abstraction: allow execute of dvipdfm, allowing
    for printing of DVI files to work again (LP: #452057)

 -- Jamie Strandboge <email address hidden> Thu, 15 Oct 2009 12:28:40 -0500

Changed in evince (Ubuntu Karmic):
status: Fix Committed → Fix Released
farchumbre (farchumbre) wrote :

Evince 2.28.1 can't print pdf files in ubuntu 9.10 karmic koala.
It was working before with ubuntu 9.04
any suggestions?

You should properly go ahead and file another bug report. This one is 'fix released' and relates to .dvi files.

I have no problem printing .pdf files here. So you may want to supply a test case or more info when you do file the bug.

https://bugs.launchpad.net/ubuntu/+source/evince/+filebug

Florian Ludwig (dino-phidev) wrote :

I got evince 2.30.3-0ubuntu1.1 and still get:

** (evince:18031): WARNING **: Error: Failed to execute child process "dvipdfm" (Permission denied)

dmesg:

[305634.739982] type=1503 audit(1280683743.766:24): operation="exec" pid=18098 parent=18031 profile="/usr/bin/evince" requested_mask="::x" denied_mask="::x" fsuid=1000 ouid=0 name="/usr/bin/dvipdfmx"

/etc/apparmor.d/abstractions/evince, line 54:

  /usr/bin/dvipdfm Ux,

This bug is indeed back in 10.04

Changed in evince (Ubuntu):
status: Fix Released → Confirmed
Jamie Strandboge (jdstrand) wrote :

This bug is marked Fix Released and for what was initially reported, it is:
  /usr/bin/dvipdfm Ux,

The problem you are seeing is that Lucid is apparently using 'dvipdfmx', not 'dvipdfm'. Please file a new bug and we can work towards a solution in that bug.

Changed in evince (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers