evince doesn't render PDF's - not MIME issue

Bug #446062 reported by Graham F on 2009-10-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evince

This is NOT a duplicate of 445689 and doesn't appear to be a mime issue. (mime database update command has no effect) Only started with evince upgrade of the 6th/7th Oct 09. Re-reported as previous bug report incorrectly marked as a fixed duplicate.

ProblemType: Bug
Architecture: i386
Date: Thu Oct 8 07:30:40 2009
DistroRelease: Ubuntu 9.10
Package: evince 2.28.0-0ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-12.41-generic
SourcePackage: evince
Uname: Linux 2.6.31-12-generic i686

Graham F (gandalfmeister) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?
 * Do uyou get the issue on any pdf? Can you run gvfs-info on a pdf example and add the log to the bug?

 This will help us to find and resolve the problem.

Changed in evince (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Graham F (gandalfmeister) wrote :

100% reproducible - absolutely no PDF's can be read via evince
Try opening a PDF in evince with the latest Karmic beta build?

Python_Programming.pdf off the Python intro tutorial website (attached):-

edit name: Python_Programming.pdf
name: Python_Programming.pdf
type: regular
size: 892748
attributes:
  standard::type: 1
  standard::name: Python_Programming.pdf
  standard::display-name: Python_Programming.pdf
  standard::edit-name: Python_Programming.pdf
  standard::copy-name: Python_Programming.pdf
  standard::icon: application-pdf, gnome-mime-application-pdf, x-office-document, application-x-generic
  standard::content-type: application/pdf
  standard::fast-content-type: application/pdf
  standard::size: 892748
  standard::allocated-size: 892928
  etag::value: 1252963379:521407
  id::file: l2049:10120
  id::filesystem: l2049
  access::can-read: TRUE
  access::can-write: TRUE
  access::can-execute: FALSE
  access::can-delete: TRUE
  access::can-trash: TRUE
  access::can-rename: TRUE
  time::modified: 1252963379
  time::modified-usec: 521407
  time::access: 1254986113
  time::access-usec: 594340
  time::changed: 1252963379
  time::changed-usec: 529411
  unix::device: 2049
  unix::inode: 10120
  unix::mode: 33188
  unix::nlink: 1
  unix::uid: 1000
  unix::gid: 1000
  unix::rdev: 0
  unix::block-size: 4096
  unix::blocks: 1744
  owner::user: graham
  owner::user-real: graham
  owner::group: graham
  thumbnail::failed: TRUE

Sebastien Bacher (seb128) wrote :

do you get the issue using a guest session too?

Graham F (gandalfmeister) wrote :

I didn't know how to setup a guest session - so I created a new user, and logged in as the new user. Attempting to view a PDF gave rise to a crash (bug ...478) with an assert failure. So to answer you question - yes - evince still doesn't work even when logged into a difference account.

Graham F (gandalfmeister) wrote :

full bug number = 446748 - this is the ref that prompted me to try the above - and generate the assert failure listed here.

Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Lucid Lynx. I also attempted to reproduce this issue using the final version of Ubuntu 9.10 and the attached PDF file. I was not able to reproduce it.

Changed in evince (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers