evince prints files scaled to portrait orientation, despite needing landscape

Bug #430811 reported by GiuseppeVerde on 2009-09-16
98
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Evince
Fix Released
Medium
evince (Ubuntu)
Low
Ubuntu Desktop Bugs
Karmic
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evince

After upgrading to karmic, evince started printing the attached file (and many others like it) scaled to portrait. Paper orientation is grayed out in the print dialog, so I can't try that, but trying various cups settings and rotating the pages had no effect.

This is printer-independent; printing to pdf reproduced the bug (output.pdf attached).

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

summary: - [karmic] evince prints files scaled to portrait orientation, despite
- needing landscape
+ evince prints files scaled to portrait orientation, despite needing
+ landscape
Changed in evince (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Martin Pitt (pitti) wrote :

I have the same problem here as well.

Changed in evince (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2009-10-05
Changed in evince:
importance: Undecided → Unknown
status: New → Unknown
Changed in evince (Ubuntu):
status: Confirmed → Triaged
Changed in evince (Ubuntu):
status: Triaged → Fix Committed
Xero Xenith (xero-xenith) wrote :

Can we expect a fix for this to be piped down via the standard repos, or is there a PPA supplying it?

(for now I'm using other software, as landscape duplex printing is very important for me, but I'd love to switch back to evince)

Sebastien Bacher (seb128) wrote :

it should be possible to get the change as a karmic stable update, would be nice if somebody could try the patch though

There was an mistake made when the commits were backported from master to the 2.28 branch. Fixed in this commit:

http://git.gnome.org/cgit/evince/commit/?h=gnome-2-28&id=7ff0dbcf7a396eea2de03de59b8259e72908158f

crazyserver (crazyserver) wrote :

Same problem here, but not the graying out. With the Karmic updates installed since today.

This is now fixed in Ubuntu 10.04 (https://lists.ubuntu.com/archives/lucid-changes/2009-November/000132.html). Thanks for reporting.

Changed in evince (Ubuntu):
status: Fix Committed → Fix Released
wilk (j-cubizolles) wrote :

I just built evince from the evince_2.28.1-0ubuntu1 source + the 3 patchs from this thread. The problem is indeed fixed. I think it's ready for packaging.

So it's fixed in Lucid; when's it coming to Karmic?

Sebastien Bacher (seb128) wrote :

the change will go to karmic when there is enough requests for that and somebody spend works on the update

Holger Mauermann (mauermann) wrote :

How many requests do you need??? This is clearly a bug that should be fixed as soon as possible! evince is the default PDF viewer in ubuntu and PDF is a very popular file format - so this bug affects probably almost all users...

I, for one, hereby officially request that Canonical or one of the MOTU fix the bug in Karmic. As noted above, people tend to get mad when printing just stops working after an upgrade. Particularly business users, who I suspect are the hardest hit by this.

(Hint: "Fix Released" implies in the releases in which it's buggy, which just ain't true)

Sebastien Bacher (seb128) wrote :

> I, for one, hereby officially request

you opened the bug there is no need to request it officially this way in comments too

> "Fix Released" implies

the fix released is used when the bug is fixed in the current ubuntu version, there lucid, then tasks can be opened for stable version, I just opened a karmic one

Changed in evince (Ubuntu Karmic):
importance: Undecided → Low
status: New → Triaged

It's not clear how to vote for a bug, so I did what I could.

I'm not sure why the bug that was filed against Karmic didn't stay with Karmic; seems odd. Thanks for (re-)opening the Karmic version.

I'd argue that the priority should be more than "Low", as most people with high-end printers don't like jobs randomly failing.

Sebastien Bacher (seb128) wrote :

> It's not clear how to vote for a bug, so I did what I could.

there is no need to vote, you can use the "Does this bug affect you?" bellow the bug lists

> I'm not sure why the bug that was filed against Karmic didn't stay with Karmic; seems odd. Thanks for (re-)opening the Karmic version.

The bugs are not filed against a version and are closed when fixed in the current unstable version by default, otherwise we would have thousand of bugs polluting the bug tracker because they have been fixed since hardy and not backported

> I'd argue that the priority should be more than "Low", as most people with high-end printers don't like jobs randomly failing.

let's not discuss bug settings nor wasting paper by printing, a sru update is on the way now

Changed in evince (Ubuntu Karmic):
assignee: nobody → Sebastien Bacher (seb128)
assignee: Sebastien Bacher (seb128) → Ubuntu Desktop Bugs (desktop-bugs)

Thanks for the fix! Looking forward to getting it!

Sebastien Bacher (seb128) wrote :
Changed in evince (Ubuntu Karmic):
status: Triaged → Fix Committed

Accepted evince into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Felix Zweig (f.zweig) wrote :

This fexed at least #472400. However, this introduces new bugs; please see comments 8-10 on #472400.

Sebastien Bacher (seb128) wrote :

Those are new bugs compared to karmic or just things which didn't work before and still don't?

Sebastien Bacher (seb128) wrote :

To clarify should the update be dropped because it breaks things?

Felix Zweig (f.zweig) wrote :

The upside-down bug is new. However, I don't think that this is a blocker for the update.

The grayed-out box has been reported as #480895.

Martin Pitt (pitti) wrote :

It seems to me that upside-down printing (where you can just flip the paper) is much better than the current situation in karmic-final, where it just crops half of the page. Do people agree? I'm inclined to count this as verification-done, if there are new bug reports about the remaining issues.

Felix Zweig (f.zweig) wrote :

> It seems to me that upside-down printing (where you can just flip the
> paper) is much better than the current situation in karmic-final,
> where it just crops half of the page. Do people agree? I'm inclined to
> count this as verification-done, if there are new bug reports about
> the remaining issues.

+1

Martin Pitt (pitti) on 2009-11-13
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 2.28.1-0ubuntu1.2

---------------
evince (2.28.1-0ubuntu1.2) karmic-proposed; urgency=low

  * debian/patches/90_git_change_printer_improvements.patch:
    - git changes to fix several printing issues should make orientation
      behave correctly (lp: #430811)

  [ Jamie Strandboge ]
  * debian/apparmor-profile*: adjust to allow opening of bzip2 compressed
    files (LP: #480270)
 -- Sebastien Bacher <email address hidden> Tue, 10 Nov 2009 16:21:06 -0600

Changed in evince (Ubuntu Karmic):
status: Fix Committed → Fix Released
hivar (hihivar) wrote :

I have the version above, but still have this bug.

Changed in evince:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.