Evince can no longer read comicbook archives

Bug #413948 reported by Taylor "Ripps" LeMasurier-Wren on 2009-08-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
High
Jamie Strandboge

Bug Description

Binary package hint: evince

Today, I suddenly can't read any of my comicbook archives anymore. I have tried several .cbz and .cbr archives, but I get a Permission Denied warning on everyone. I've checked the file permissions and there's no reason why they can't be opened.
In order to double check, I installed qcomicbook and it was able to read them just fine. Apparently something has regressed in Evince.

ProblemType: Bug
Architecture: i386
Date: Sat Aug 15 02:43:53 2009
DistroRelease: Ubuntu 9.10
Package: evince 2.27.90-0ubuntu3
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
SourcePackage: evince
Uname: Linux 2.6.31-5-generic i686

Related branches

Okay, I moved one of the comic archives to my home folder and tried opening it from there. I don't get a permission denied warning, instead i get this:
Unable to open document:
File type Zip archive (application/x-zip) is not supported.

It seems that someone removed compressed archive support in Evince.

Changed in evince (Ubuntu):
assignee: nobody → Jamie Strandboge (jdstrand)
importance: Undecided → High
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 2.27.90-0ubuntu4

---------------
evince (2.27.90-0ubuntu4) karmic; urgency=low

  * debian/apparmor-profiles.abstraction and debian/apparmor-profiles:
    allow reading of comic book archives (LP: #413948)
  * debian/apparmor-profiles: allow opening of hyperlinks (LP: #414114)

 -- Jamie Strandboge <email address hidden> Mon, 17 Aug 2009 16:16:38 -0500

Changed in evince (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers