F1 doesn't summon manual

Bug #380428 reported by Ian on 2009-05-26
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evince

What I expected:
Pressing F1 to summon the manual in Yelp.

What happens:
Yelp appears, but tells me:

    Unable to load page
    ===================

    The requested URI "ghelp:evince" is invalid

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/evince
NonfreeKernelModules: nvidia
Package: evince 2.26.1-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: evince
Uname: Linux 2.6.28-11-generic i686

Ian (ian-dalton) wrote :
Dimitrios Symeonidis (azimout) wrote :

Are you on Xubuntu?

Related bug #367602

Changed in evince (Ubuntu):
status: New → Incomplete
Ian (ian-dalton) wrote :

I'm on plain Ubuntu, not Xubuntu. Also, F1 works in other programs, like Nautilus.

Sebastien Bacher (seb128) wrote :

do you get any error on the command line if you run it there

Changed in evince (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Ian (ian-dalton) wrote :

I get:

    OMF category 'Applications|Other' not recognised, ignoring.

Sebastien Bacher (seb128) wrote :

do you get the same issue with other softwares?

Ian (ian-dalton) wrote :

> Also, F1 works in other programs, like Nautilus.

Ian (ian-dalton) wrote :

Oh, but I do get "OMF category 'Applications|Other' not recognised, ignoring." in other programs, even though they work.

Dimitrios Symeonidis (azimout) wrote :

When you click help (or press F1) in evince, the command that the system runs is:
yelp /usr/share/gnome/help/evince/C/evince.xml

Can you try running it from the terminal to see if you're getting the same errors?

Ian (ian-dalton) wrote :

That works for me, and no errors. Am I the only one having this bug or does F1 fail on others, too?

Sebastien Bacher (seb128) wrote :

you are the only one to have this issue

He's not the only one. I can confirm this bug.

Dimitrios Symeonidis (azimout) wrote :

setting to confirmed

Changed in evince (Ubuntu):
status: Incomplete → Confirmed

Is anybody going to fix this problem?

Dimitrios Symeonidis (azimout) wrote :

Timur, does running yelp /usr/share/gnome/help/evince/C/evince.xml open the help for you?

On Mon, 2009-08-31 at 08:12 +0000, Dimitrios Symeonidis wrote:
> yelp /usr/share/gnome/help/evince/C/evince.xml

Sure, it helps.

oboewan (oboewan42) wrote :

I found out the problem!

Evince thinks the location of its help file is ghelp:evince, but it's not. It's man:evince (because Evince has a man page, not a DocBook help file).

Also, there is a full-featured manual on the GNOME Documentation Library, but it's not actually included in the Evince package, and I haven't seen a way to download it as a DocBook.

Basically, someone needs to take the Evince help file in the GDL, convert it into a DocBook and pack it into Evince.

Robert Roth (evfool) wrote :

Can anyone confirm this problem on a later version of the system? I have tried with Natty (current development version) and the help is displayed as expected after pressing F1.

Changed in evince (Ubuntu):
status: Confirmed → Triaged
status: Triaged → Incomplete
Ian (ian-dalton) wrote :

OP here; it works for me on Ubuntu 10.10.

Robert Roth (evfool) wrote :

Marking this as Fix released as per the last comment of the reporter, comment #19.

Changed in evince (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers