dvi render blurry

Bug #376233 reported by Yang Zhao on 2009-05-13
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evince

The dvi rendering quality is bad compared to pdf from the same file. Letters are blurry.
I'll attach a screen shot.

Yang Zhao (zhyang11) wrote :

This is the LyX introduction, in dvi and pdf respectively. The dvi version on the left is blurry compared to the pdf version.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, does it work correctly in other dvi viewers? Can you add an example to the bug?

Changed in evince (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete

I have attached a screen shot comparing evince and xdvi showing the same file at roughly the same zoom (as close as I can get).

xdvi(right) is more readable than evince(left). In the evince render, the letters look like taken with a badly focused camera.

----- Original Message ----
From: Sebastien Bacher <email address hidden>
To: <email address hidden>
Sent: Wednesday, May 13, 2009 6:44:37 PM
Subject: [Bug 376233] Re: dvi render blurry

Thank you for your bug report, does it work correctly in other dvi
viewers? Can you add an example to the bug?

** Changed in: evince (Ubuntu)
   Importance: Undecided => Low

** Changed in: evince (Ubuntu)
       Status: New => Incomplete

** Changed in: evince (Ubuntu)
     Assignee: (unassigned) => Ubuntu Desktop Bugs (desktop-bugs)

--
dvi render blurry
https://bugs.launchpad.net/bugs/376233
You received this bug notification because you are a direct subscriber
of the bug.

Yang Zhao (zhyang11) wrote :

This blurry render seems to be affected by the zooming level. In this particular file (LyX introduction), it's crispy at 70% and 200%, and blurry at 50%, 85%, 100%, 125%, 150%, 175%, 300%. It's hard to tell if it is still there at 400%.

----- Original Message ----
From: Sebastien Bacher <email address hidden>
To: <email address hidden>
Sent: Wednesday, May 13, 2009 6:44:37 PM
Subject: [Bug 376233] Re: dvi render blurry

Thank you for your bug report, does it work correctly in other dvi
viewers? Can you add an example to the bug?

** Changed in: evince (Ubuntu)
   Importance: Undecided => Low

** Changed in: evince (Ubuntu)
       Status: New => Incomplete

** Changed in: evince (Ubuntu)
     Assignee: (unassigned) => Ubuntu Desktop Bugs (desktop-bugs)

--
dvi render blurry
https://bugs.launchpad.net/bugs/376233
You received this bug notification because you are a direct subscriber
of the bug.

Changed in evince (Ubuntu):
status: Incomplete → New
Dimitrios Symeonidis (azimout) wrote :

You need to install texlive-latex-recommended, which contains the missing metafonts.
Without it, it struggles to create substitution fonts and the result is what you see...

Yang Zhao (zhyang11) wrote :

It's already installed when I took the screen shots.

----- Original Message ----
From: Dimitrios Symeonidis <email address hidden>
To: <email address hidden>
Sent: Thursday, May 14, 2009 3:57:16 AM
Subject: [Bug 376233] Re: dvi render blurry

You need to install texlive-latex-recommended, which contains the missing metafonts.
Without it, it struggles to create substitution fonts and the result is what you see...

--
dvi render blurry
https://bugs.launchpad.net/bugs/376233
You received this bug notification because you are a direct subscriber
of the bug.

Dimitrios Symeonidis (azimout) wrote :

Here's what I see in Jaunty. Are you maybe on an older Ubuntu version?

Changed in evince (Ubuntu):
status: New → Incomplete
Yang Zhao (zhyang11) wrote :

This is what evince gives me at 400%, and difference with your picture. Clearly there is something wrong with my system - yours looks clearer.
I installed hardy on my system and upgrade to intrepid and jaunty later. These package versions are installed:
||/ Name Version Description
+++-=========================-=========================-==================================================================
ii evince 2.26.1-0ubuntu1 Document (postscript, pdf) viewer
ii libevdocument1 2.26.1-0ubuntu1 GNOME document viewer backend library
ii libevview1 2.26.1-0ubuntu1 GNOME document viewer view library
ii libpoppler-glib4 0.10.5-1ubuntu2 PDF rendering library (GLib-based shared library)

----- Original Message ----
From: Dimitrios Symeonidis <email address hidden>
To: <email address hidden>
Sent: Friday, May 15, 2009 4:41:44 AM
Subject: [Bug 376233] Re: dvi render blurry

Here's what I see in Jaunty. Are you maybe on an older Ubuntu version?

** Attachment added: "Screenshot-Intro.dvi.png"
   http://launchpadlibrarian.net/26752605/Screenshot-Intro.dvi.png

** Changed in: evince (Ubuntu)
       Status: New => Incomplete

--
dvi render blurry
https://bugs.launchpad.net/bugs/376233
You received this bug notification because you are a direct subscriber
of the bug.

Dimitrios Symeonidis (azimout) wrote :

switching back to new for now...

Changed in evince (Ubuntu):
status: Incomplete → New
Trifon Trifonov (triffon) wrote :

I also see the same problem, and it also started with the upgrade to Jaunty. What could be the difference between an upgrade and a clean install that might be impacting evince?

I tried to clean the font cache, but didn't help. Then I saw that xdvi uses type1 fonts and so I tried recompiling evince with type1 support for dvi (it's not turned on in the default jaunty package). Now evince seems to be using type1 fonts, judging from the output of

KPATHSEA_DEBUG=-1 evince /tmp/test.dvi

Unfortunately, still no change - blurry DVI output.

Anyone have some other ideas?

John B. (jbuncher) wrote :

I'd like to confirm this bug in Karmic. Blurry dvi rendering in evince, but PDF rendering is fine. dvi rendering in okular has a different problem in okular, as the anti-aliasing isn't on for some reason. xdvi seems to render the fonts sharply/correctly.

Zeppe (giuseppe-passino) wrote :

I confirm this bug as well, now I'm in karmic, but I was experiencing it in jaunty as well.

Zeppe (giuseppe-passino) wrote :

it looks like being a zoom-related problem. I downloaded the Intro.dvi file, and on 100% it would render blurry. Setting the zoom to "best fit" (with buttons, *not* with the drop-down menu) and increasing to 100% (with "increase zoom"), it would look right (not perfect, but much less blurry). Setting the zoom to "fit page width" and then reducing to 100% (with "decrease zoom"), it would look blurry again. Other documents work the other way round.

In Lucid Lynx evince seems to become the default renderer for dvi-files. I use Tex-Suite in Vim. The output is really blurry so have to switch back to xdvi.

For what it's worth, I can confirm this problem in Jaunty as well. I also upgraded from Intrepid, but had the problem originally there as well. (Actually, I think Intrepid was an upgrade from an initial Hardy install as well.)

Does anyone experience this bug on a fresh install of Jaunty or a later release? It's not 100% clear if all posters here have an upgraded distro.

mirajshah (mirajshah) wrote :

I'd also like to confirm that I'm having this problem. In any case, I found that if you export to LaTeX and remove the "\usepackage[T1]{fontenc}" line and then regenerate the pdf, the problem goes away. I can zoom upto 6400% without any blurriness or pixelation. This is rather inelegant but clearly theres a bug in that particular package that needs to be fixed.

http://permalink.gmane.org/gmane.editors.lyx.general/45084

Cheers!

mirajshah (mirajshah) wrote :

This assumes that you are using LyX

Pedro Villavicencio (pedro) wrote :

just tried the document on Oneiric and it looks fine , could somebody else confirm? Thanks.

Changed in evince (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in evince (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers