No thumbnails for some file types on network shares

Bug #298072 reported by Brice Terzaghi on 2008-11-14
4
Affects Status Importance Assigned to Milestone
Evince
Fix Released
Medium
evince (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

I've set Nautilus preferences to generate thumbnails in all folders (not only local ones), even for big files (< 1 Gb). When browsing a network share (either Samba or mounted through SSH), video thumbnails are generated fine but not some other file types ones : PDF, CBZ or CBR show the default icon instead of a preview. There's no problem with these files in a local folder : thumbnails are generated in that case.

Using up-to-date Intrepid with Nautilus 1:2.24.1-0ubuntu1.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?

 This will help us to find and resolve the problem.

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Brice Terzaghi (terzag) wrote :

Well, "reproducible" doesn't really apply there. As for specific steps, it just happens, there are no specific steps apart from sharing a folder that contains PDF or CB archives (CBR / CBZ...).

It seems like Nautilus can't generate a thumbnail for some file types from the network. It works well with videos and pictures.

Is it the same process that creates thumbnails for all file types in Nautilus ? or filetype-specific (i.e. maybe videos are generated by gstreamer, pictures by another process and so on) ?

Sebastien Bacher (seb128) wrote :

could you add an example to the bug?

Brice Terzaghi (terzag) wrote :

What kind of example ? A screenshot ?

The problem is quite simple : on a local drive, if I go in a folder containing PDF files, thumbnails are generated. With video files, thumbnails are generated.
On a remote drive (either Samba or mounted as SFTP), a folder containing video files generates thumbnails but a folder with PDF files doesn't generate thumbnails for them.

While browsing a folder with a lot of video files, I saw there was a process running with "thumbnail" in its name (I don't remember and can't check now : was like gnome-video-thumbnailer or something). I could'nt check the process running when generating thumbnails for other filetypes but I guess the problem might not be related to nautilus itself but rather to a specific thumbnailer (used for documents like PDF, CBZ or CBR) that doesn't support network access. That's just a theory, I'll check this when my server works again and I have access to my usual remote folders.

Sebastien Bacher (seb128) wrote :

not confirming on my hardy or intrepid installation, pdf are thumbnailed correctly over ssh

Brice Terzaghi (terzag) wrote :

Ok. So it seems to be a problem on my system. I'll check my setup to see if I can narrow the problem (the only thing that leaps to my mind is that my files are on an external USB hard drive connected to the remote computer, but I don't see why it would be treated differently than the internal hard drive).

Sebastien Bacher (seb128) wrote :

could you try using a different user on the same installation?

Brice Terzaghi (terzag) wrote :

It doesn't work better with a new user (just created, so he has default configuration). I also tried to put some PDF files in a shared folder directly on the Ubuntu Server hard drive (rather than keeping them on the FAT32 formated hard drive where I put my data) and check for permissions with no change.

Sebastien Bacher (seb128) wrote :

could you add an example to the bug and a screenshot showing the issue when trying to browse a location which has the example listed?

Brice Terzaghi (terzag) wrote :

I'll try when I can : my server is dead since three weeks ago. When I'll have it repaired and set up, I'll post a screenshot.

Darren Blair (darrenwblair) wrote :

I'm also having this problem, so I can try to add an example/screenshot and some more info. In the screenshot, item #1 is the example file in a VNC window of the server itself, item #2 is the same file in a Nautilus window on the client, and item #3 is the result of dragging the file from the Nautilus window to the client desktop.

Some other relevant info:

1) This example file was created on the server, but the problem also occurs when files created elsewhere are copied to the server.
2) Files created on the client then copied over work fine. Also, if I were to copy the example file on the client desktop back to the network share, the thumbnail information would persist.
3) Nautilus is definitely trying to generate thumbnails. It will take a while to process folders with large amounts of files and everything will work properly except PDF/CBR files (as far as I've seen).
4) My server is running OpenSolaris 2008.11 and sharing through Samba via ZFS. Client is Linux Mint 6.0 with Nautilus 2.24.1. Problem is reproducible with Ubuntu Intrepid live CD. Thumbnails work fine with Windows Vista client.

Darren Blair (darrenwblair) wrote :
Sebastien Bacher (seb128) wrote :

the recent comment suggests that the evince thumbnailer is called but failed to create the image, could you try on jaunty and try calling the thumbnailer manually if that's still an issue there?

affects: nautilus (Ubuntu) → evince (Ubuntu)
Brice Terzaghi (terzag) wrote :

Upgraded to Jaunty yesterday. The problem is still there. As before, copying a file from the Samba share to the local computer creates the thumbnail fine. Copying a file with thumbnail in the Samba share keeps the thumb.

Anyway, it seems that evince-thumbnailer isn't started when browsing a Samba share. How do I run it manually ? I guess the input is the file to create a thumbnail for but what is the output ? Also, how do I use it with the Samba share : with the ~/.gvfs "virtual dir" ?

Sebastien Bacher (seb128) wrote :

run evince-thumbnailer SOURCE_URI IMAGE

Sebastien Bacher (seb128) wrote :

run evince-thumbnailer SOURCE_URI IMAGE it should write the local image

Brice Terzaghi (terzag) wrote :

I'm not sure how to do. I have a Samba share "documents" on "server". I've tried the following commands :
evince-thumbnailer smb://server/documents/test.pdf test.jpg
evince-thumbnailer smb://server/documents/test.pdf smb://server/documents/test.jpg
evince-thumbnailer .gvfs/documents\ on\ server/test.pdf test.jpg
evince-thumbnailer .gvfs/documents\ on\ server/test.pdf .gvfs/documents\ on\ server/test.jpg

I get no image nor thumbnail for the test.pdf file, either locally or on the server. Also tried with sudo. Did I misunderstood what I had to type ?

Sebastien Bacher (seb128) wrote :

does evince-thumbnailer example.pdf example.png works for you?

Brice Terzaghi (terzag) wrote :

On the local machine on a local PDF : yes. I get an image file.

Sebastien Bacher (seb128) wrote :

the comments confirm the issue is an evince one

Changed in evince (Ubuntu):
status: Incomplete → New
schmolch (saschaheid) wrote :

I would like to confirm this issue.
PDF previews over any kind of network share have never worked for me.
I have 3 different computers running jaunty and karmic and is does not work and never has.

This should be fixed in evince 2.30 which is shipped with Ubuntu Lucid. I tested with a "fake" smb share on my local computer and thumbnailing worked for PDFs - please reopen the bug by resetting the status to new if the issue is not fixed for you.

Changed in evince (Ubuntu):
status: New → Fix Released
Changed in evince:
status: Unknown → Fix Released
Changed in evince:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.