Ubuntu

8.10 Printed PDF missing parts / corrupt

Reported by Ehud Gavron on 2008-11-05
44
Affects Status Importance Assigned to Milestone
Evince
Unknown
Medium
cairo (Ubuntu)
Medium
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Medium
Unassigned
evince (Ubuntu)
Medium
Ubuntu Desktop Bugs
Intrepid
Undecided
Unassigned
Jaunty
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: cups-pdf

The attached file prints JUST FINE from an 8.04 Hardy system.
The attached file is missing the boarding group and number on an 8.10 Ibex system.

Print a Southwest Airlines Boarding Pass using "CUPS-PDF"
8.04 - works fine. You can also send it to a printer.
8.10 - The created PDF lacks the boarding group letter or number. It's actually NOT IN THE PDF!!! (Broken thing #1)

Print a Southwest Airlines Boarding Pass using "print to file" and select PDF
The created file looks fine on e.g. evince.
8.04 - Evince can print this file
8.10 - Evince sends the file to the printer but its hows up without the boarding group letter or number (Broken thing #2)

THE SAME FILE prints fine from an 8.04 system but prints WITHOUT the info from an 8.10 system.

The 8.10 system is an upgraded 8.04 system.

E
$ lsb_release -rd
Description: Ubuntu 8.10
Release: 8.10

assuming it's cups:
$ apt-cache policy cups
cups:
  Installed: 1.3.9-2
  Candidate: 1.3.9-2
  Version table:
 *** 1.3.9-2 0
        500 http://us.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

What I expect to happen: the file will print as displayed
What happened instead: missing information when printed on an 8.10 system. Missing info not missing when same PDF file printed from 8.04 system.

Ehud Gavron (gavron) wrote :
Till Kamppeter (till-kamppeter) wrote :

The problem is that perhaps the pstopdf filter breaks the input data somehow.

Can you all replace your /usr/lib/cups/filter/pstopdf by the attached file? Please do not forget to make it executable

sudo chmod 755 /usr/lib/cups/filter/pstopdf

Can you print correctly now?

Till Kamppeter (till-kamppeter) wrote :

I have fixed another bug. Please test with this new version of pstopdf, not with the one of the previous comment.

I can't get another Southwest boarding pass until my return flight Monday.
I can't re-print the previous document using the new pstopdf because I'm
in a hotel in Las Vegas as of an hour ago ;)

I have used the second replacement pstopdf, and I have setup the +x on
it. Hopefully someone else can confirm the fixes.
Otherwise I will on Sunday when I generate the PDF and also on Monday
when I have access to a printer.

My appreciation for the quick attention. My apologies I cannot
immediately test it.

E

Till Kamppeter wrote:
> I have fixed another bug. Please test with this new version of pstopdf,
> not with the one of the previous comment.
>
> ** Attachment added: "New replacement pstopdf filter"
> http://launchpadlibrarian.net/19405638/pstopdf
>
>

--
Legal Disclaimer that you are now contractually bound to under all laws with no recourse:
http://attrition.org/security/rants/z/disclaimers.html

Martin Pitt (pitti) wrote :

This new filter has been incorporated into the pending intrepid update in intrepid-proposed (version 1.3.9-2ubuntu1). Can you please try this and check if it fixes your problem? Thanks!

Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed.

Changed in cups:
status: New → Incomplete
Ehud Gavron (gavron) wrote :

Having done the updates manually this did not fix the resultant PDF.

The Southwest boarding pass as created by "print to PDF" is missing the
boarding group letter and number.

The file as made by "print to file" and selecting pdf format (generating
"mozilla.pdf") is correct. HOWEVER printing it from e.g. evince "print
to PDF" again loses those two items and they are blank.

Ehud

Changed in cups:
importance: Undecided → Medium
status: Incomplete → Confirmed
Till Kamppeter (till-kamppeter) wrote :

I have investigated the problem and it is a bug of evince. Both methods shown in the initial posting lead to a PDF-to-PostScript conversion via evince. Firefox is not able to display PDF files by itself and therefore it calls evince in a default installation of Ubuntu. And in the second method evince is explicitly called by the user.

I can print the boarding pass just fine with okular, Adobe Reader, and directly sending it to CUPS with the "lpr" command.

Saivann Carignan (oxmosys) wrote :

Attaching evince upstream bug. I also confirm that this problem is specific to evince and does not happen with Adobe Reader.

Saivann Carignan (oxmosys) wrote :

According to upstream bug report, that seems to be a libcairo2 bug. Can someone install libcairo2 version 1.8.4 from my repository and confirm if the bug is still reproducible?

deb http://ppa.launchpad.net/saivann/ubuntu intrepid main

Important : If you don't want to get updates from my repository which might often contains experimental packages, you should remove it from your sources after you installed libcairo2.

Also note that my build of libcairo2 comes with no dependency to make it possible to test it on intrepid. If you keep this version installed, this might be the source of problems in the future.

Achim (ach1m) wrote :

libcairo2:
  Installiert: 1.8.4-0ubuntu2
  Kandidat: 1.8.4-0ubuntu2
  Versions-Tabelle:
 *** 1.8.4-0ubuntu2 0
        500 http://ppa.launchpad.net intrepid/main Packages
        100 /var/lib/dpkg/status
     1.8.0-0ubuntu1 0
        500 ftp://local intrepid/main Packages

I can confirm that the version of libcairo2 from your PPA solved the problem for me.
The print preview is working again and the printout is also okay.

Regards
Achim

Changed in evince:
assignee: nobody → desktop-bugs
status: Confirmed → Triaged
Changed in evince:
assignee: desktop-bugs → saivann
rawphi (raphael-ist) wrote :

I just tried out your libkairo2 packages as I had similar problems with some reproducibly missing pictures within pdf files when printing, and it fixes the problem!

tried with:
evince: 2.24.1-0ubuntu1
libcairo2: 1.8.4-0ubuntu2

I'm looking forward to a quick update of intrepid, as this bug probably (i had it in about 1/3 pdf printouts) causes a lot of inconvenience. you don't instantly notice it, but can make printouts potentially harmful (missing sponsor logos, in my case...)

Saivann Carignan (oxmosys) wrote :

Changing package to libcairo since this is a libcairo bug and not a evince bug

Changed in evince:
assignee: saivann → desktop-bugs
status: Triaged → Invalid
Changed in libcairo:
importance: Undecided → Medium
status: New → Triaged
Saivann Carignan (oxmosys) wrote :

This bug has been fixed in libcairo trunk by this commit :

3c18d95b293eddaa25232bc06398c78bc8043cb4
Compute device_transform_inverse.

However, patching 1.8.0 libcairo with the patch from this commit is not enough, that probably means that this is only a part of the fix and that another commit holds the missing part of the puzzle. I wonder how to find the fix at this point. I attached current incomplete patch if someone can take a look.

Martin Pitt (pitti) wrote :

(Next time: Please *change* the affected package, don't create a new task and invalidate the other one; but don't worry for now)

Changed in evince:
status: New → Invalid
Martin Pitt (pitti) wrote :

This patch is already applied in Jaunty.

Changed in cairo:
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

Uploaded to the queue, thanks for digging out the patch!

Changed in cairo:
status: New → In Progress
Saivann Carignan (oxmosys) wrote :

Martin Pitt : Thanks for the advice, however I said in my last comment that this patch is not complete. It shouldn't be uploaded to intrepid until it is reported to work. I'm currently searching deep to find what's missing and I attached the patch so more experienced people might be able to help me finding what's wrong. Thank you very much.

Martin Pitt (pitti) wrote :

OK, rejected from the queue. Please let me know (here) if you need something sponsored.

Changed in cairo:
status: In Progress → Confirmed
vistor (laiglesiaesunnegocio) wrote :

The pdf printer not work if PDF folder not exist
the problem is solved by creating a PDF folder in your home

example:

mkdir PDF

Saivann Carignan (oxmosys) wrote :

Martin Pitt : Due to a dumb packaging error from my side, my last comment is wrong. I attach a debdiff which definitively fix this issue, tested on two computers. Can you sponsor it for intrepid-proposed so all people can test it and give feedback? Many thanks.

Saivann Carignan (oxmosys) wrote :

vistor : This is not the same bug as the symptoms are not the same. You can refer to bug 270046 instead.

Martin Pitt (pitti) wrote :

Sponsored intrepid update. Thanks!

Changed in cairo:
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in cairo:
status: In Progress → Fix Committed
Saivann Carignan (oxmosys) wrote :

I went back to current broken packages (bug present) and updated to the fixed packages in -proposed. The bug is definitively fixed for me and I don't see any regression at that point.

Achim (ach1m) wrote :

I also have installed the proposed packages and everything is working again.
Print Preview in evince and the printout show the picture. I have tested this on a notebook 32-bit and PC 64-bit.

libcairo2:
  Installiert: 1.8.0-0ubuntu1.1
  Kandidat: 1.8.0-0ubuntu1.1

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cairo - 1.8.0-0ubuntu1.1

---------------
cairo (1.8.0-0ubuntu1.1) intrepid-proposed; urgency=low

  * 05_pdf_missing_pictures.dpatch: Include upstream fix
    for missing pictures when printing PDF files. (LP: #293883)

 -- Saivann Carignan <email address hidden> Fri, 12 Dec 2008 02:26:14 -0500

Changed in cairo:
status: Fix Committed → Fix Released
Colin Watson (cjwatson) wrote :

Copied to intrepid-updates following successful verification.

Changed in evince:
status: Unknown → Invalid
Changed in evince:
importance: Unknown → Medium
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.