Ubuntu

Google PDF won't work right. Is this a bug?

Reported by Kevin Gabbert on 2008-10-04
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evince

I downloaded this PDF book from Google:

http://books.google.com/books/pdf/The_Major_Tactics_of_Chess.pdf?id=1ulCAAAAIAAJ&output=pdf&sig=ACfU3U28DjSj80r4I-GXYxWRvAWAsCp2Tg

it has a number of picture examples in it that can't be seen (I am using Ubuntu Hardy).

for what its worth, Sumatra in Windows sees the pictures but not the words. (and crashes)

Is this a bug or bad format?

Should evince be able to handle this?

ProblemType: Bug
Architecture: i386
Date: Sat Oct 4 01:13:33 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/evince
NonfreeKernelModules: nvidia
Package: evince 2.22.2-0ubuntu1
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: evince
Uname: Linux 2.6.24-19-generic i686

Ahmad Tarek (ahmadtarek) wrote :

I tried to open the link but it didn't work...

Did you tried the file with any other PDF reader?

For me, it seems that the problem is related to the file.

Changed in evince:
status: New → Incomplete
Stefan Kottwitz (stefan.k) wrote :

The link doesn't work for me too.

Changed in evince:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in evince:
status: Incomplete → Invalid
Changed in evince (Ubuntu):
status: Invalid → New

Example of file with issues

I'm attaching an example of a PDF with this problem, though it happens on virtually all PDF books downloaded from Google Books. The black and white images display but no color images will display, there's just a white square where they should be. Try opening the attachment with Acrobat reader and evince and comparing page by page, there's a big difference.

In the console it produces this error message over and over:

Error (525061): Error in JPX stream
Error (525061): Error in JPX stream
Error (880521): Error in JPX stream
Error (895025): Error in JPX stream
Error (901617): Error in JPX stream
Error (908034): Error in JPX stream

Googling the message I found this link:

http://lists.freedesktop.org/archives/poppler-bugs/2009-October/003910.html

in which a commentor replied:

"The problem is ubuntu is not using openjpeg when building poppler so the old
and deprecated decoder is used and it fails. You should open a bug against
ubuntu asking them to use openjpeg when building poppler."

Thanks

Robert Roth (evfool) on 2011-03-31
Changed in evince (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers