Evince should include DVI support

Bug #27403 reported by Owen Cliffe on 2005-12-20
8
Affects Status Importance Assigned to Milestone
evince (Debian)
Fix Released
Unknown
evince (Ubuntu)
Medium
Sebastien Bacher

Bug Description

evince 0.4.0 includes resaonable DVI support which in many respects is much more
useful than xdvi,

The ubuntu build of evince does not have this compiled in.

While DVI is rarely used as a document format for interchange it is very useful
to have a good viewer (like evince) when one is authoring in latex.

fix:
add a dependency on libkpathsea
add --enable-dvi to the configure options

Source: evince
Source-Version: 0.3.0-2

We believe that the bug you reported is fixed in the latest version of
evince, which is due to be installed in the Debian FTP archive:

evince_0.3.0-2.diff.gz
  to pool/main/e/evince/evince_0.3.0-2.diff.gz
evince_0.3.0-2.dsc
  to pool/main/e/evince/evince_0.3.0-2.dsc
evince_0.3.0-2_i386.deb
  to pool/main/e/evince/evince_0.3.0-2_i386.deb

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Sebastien Bacher <email address hidden> (supplier of updated evince package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sat, 7 May 2005 14:40:25 +0200
Source: evince
Binary: evince
Architecture: source i386
Version: 0.3.0-2
Distribution: unstable
Urgency: low
Maintainer: Sebastien Bacher <email address hidden>
Changed-By: Sebastien Bacher <email address hidden>
Description:
 evince - Document (postscript, pdf) viewer
Closes: 308021
Changes:
 evince (0.3.0-2) unstable; urgency=low
 .
   * debian/control.in:
     - updated the Build-Depends and the description.
   * debian/rules:
     - build with djvu and dvi options (Closes: #308021).
   * debian/watch:
     - updated.
Files:
 2f7be980b311870ffe6b8f1802784a16 1683 gnome optional evince_0.3.0-2.dsc
 71ca4e413fb9c0bff0ac0ea3c57f0a09 3973 gnome optional evince_0.3.0-2.diff.gz
 cc98d1d34aa539c3bac27478eba84eb3 399370 gnome optional evince_0.3.0-2_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)

iD8DBQFCfNliQxo87aLX0pIRAlMCAJ4vdyy/vEz5uSjkV0fCw6axP0M/iQCgmmRk
X/6P0Z30jOBrgu26VYZkqzA=
=+slg
-----END PGP SIGNATURE-----

Owen Cliffe (occ) wrote :

evince 0.4.0 includes resaonable DVI support which in many respects is much more
useful than xdvi,

The ubuntu build of evince does not have this compiled in.

While DVI is rarely used as a document format for interchange it is very useful
to have a good viewer (like evince) when one is authoring in latex.

fix:
add a dependency on libkpathsea
add --enable-dvi to the configure options

Daniel Holbach (dholbach) wrote :

debian/control.in:
Build-Depends: ... libkpathsea4-dev, ...

debian/rules:
DEB_CONFIGURE_EXTRA_FLAGS := --disable-scrollkeeper --enable-djvu --enable-dvi
--enable-t1lib --enable-pixbuf

Could you elaborate on what the problem is?

Daniel Holbach (dholbach) wrote :

It's like that since

evince (0.3.0-2) unstable; urgency=low

  * debian/control.in:
    - updated the Build-Depends and the description.
  * debian/rules:
    - build with djvu and dvi options (Closes: #308021).
  * debian/watch:
    - updated.

 -- Sebastien Bacher <email address hidden> Sat, 7 May 2005 14:40:25 +0200

Sebastien Bacher (seb128) wrote :

Works fine for me on dapper, closing as fixing. Feel free to reopen with a reply to the asked questions if that's still an issue for you

Changed in evince:
status: Needs Info → Fix Released
Changed in evince:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.