Loading PDF file hang on Loading...

Bug #256048 reported by mbrennwa on 2008-08-08
176
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Evince
Fix Released
Medium
evince (Ubuntu)
Low
Ubuntu Desktop Bugs
Hardy
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evince

When I double click a PDF file in Nautilus, Evince opens and shows a window showing "Loading...". However, the loading never completes. When I close the window and double click the file again in Nautilus, Evince loads the file properly. This used to happen __sometimes__ in the past, but it recently occurrs virtually always. As far as I can tell this problem occurs with all sorts of PDF files only (i.e. it is not related to a specific file). I have Ubuntu 8.04 on a Lenovo T61:

lsb_release -rd
Description: Ubuntu 8.04.1
Release: 8.04

apt-cache policy evince
evince:
  Installed: 2.22.2-0ubuntu1
  Candidate: 2.22.2-0ubuntu1
  Version table:
 *** 2.22.2-0ubuntu1 0
        500 http://ch.archive.ubuntu.com hardy-updates/main Packages
        100 /var/lib/dpkg/status
     2.22.1.1-0ubuntu1 0
        500 http://ch.archive.ubuntu.com hardy/main Packages

TEST CASE:
1) Open a pdf file with evince.
2) Move the mouse while evince displays "Loading..." with a grey background.
3) Observe a blank white page with "Loading..." appear, which stays like this indefinitely (unless the window is resized or a new page is selected). This is the bug which is present on Hardy in evince 2.22.2-0ubuntu1 and prior.

Pedro Villavicencio (pedro) wrote :

Thanks for the report, may you attach the pdf file to the report? thanks.

Changed in evince:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Chris Coulson (chrisccoulson) wrote :

Pedro - I've seen this in Evince as well, but only when the window opens maximized. What actually appears to happen is that the Evince window opens and then never refreshes. As soon as you unmaximise the window by dragging the titlebar from the top of the screen, the Evince window refreshes and the correct PDF content is shown.

mbrennwa - could you please try this to see if the behaviour you see is similar to what I see?

mbrennwa (mbrennwa) wrote :

Yes, indeed, changing the window size refreshes the window and the PDF content is displayed. However, at least in my case the problem seems not to be limited to 'when the window opens maximized'. Also (to Pedro): my initial description may have been confusing, but the problem is NOT related to a specific PDF file. As far as I can tell it happens with any file. It is therefore useless to attach a PDF file.

Pedro Villavicencio (pedro) wrote :

Can someone facing this issue forward it upstream to bugzilla.gnome.org? that works fine for me, thanks.

Chris Coulson (chrisccoulson) wrote :

Pedro,

I would do if I was sure it was an Evince one. I can't reproduce this with Compiz disabled, so I don't know whether it could be a Compiz issue.

I might discuss it with Compiz upstream first and see what they think.

Thanks

Saivann Carignan (oxmosys) wrote :

I confirm this bug report. I've been able to reproduce it on both compiz and metacity. Most of time when evince opens maximized. It seems to happen more regularly with compiz than metacity and it happens something like 40% of the time.

Changed in evince:
status: Incomplete → Confirmed
Saivann Carignan (oxmosys) wrote :

Reported upstream.

Changed in evince:
status: Unknown → New
Andreas Moog (ampelbein) wrote :

Thanks for taking this upstream.

Changed in evince:
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

upstream bug comment

"I cannot reproduce it, but if anybody who is able to reproduce it could run
evince in debug mode, the output would be very useful. Here are the
instructions to run evince in debug mode:

http://live.gnome.org/Evince/Debugging

Thanks. "

could somebody having the issue try to get those debug informations?

Saivann Carignan (oxmosys) wrote :

Strangely, with latest recent updates, I've tried many times and I've not been able to reproduce this in the last days. Can someone reproduce the problem with a up-to-date intrepid?

Hew (hew) wrote :

I can still reproduce it with up-to-date Intrepid (evince 2.23.92-0ubuntu1).

PS. I tried compiling the source for evince but I still suck at that sort of thing, it tells me I need gnome-common from CVS. It's probably best if someone who knows what they're doing attempts the debug.

Chris Coulson (chrisccoulson) wrote :

Hew - When I get a few minutes (hopefully later), I'll build a package and upload it in my PPA for people to test.

Saivann Carignan (oxmosys) wrote :

Chris Coulson : We had the same idea, it's just uploaded to my PPA.
New McLachlan : You can install evince with debug enabled from my PPA if you want (should be build in a few minutes), and follow debugging steps in the upstream bug report. Thanks for your work on this!

deb http://ppa.launchpad.net/saivann/ubuntu intrepid main

Hew (hew) wrote :

Thanks for building that package, I've attached the log of opening the pdf and watching it stick on "Loading...". Hopefully it is of some use :-)

I just noticed that this is caused by moving the mouse while evince is starting up! There seem to be two loading stages: The first has the whole application greyed out and "Loading..." (while opening the document), and the second has a blank page displayed with "Loading..." (the actual bug). If you keep your mouse still while the document is opening in the first stage, it will open successfully. If you move the mouse even one pixel while it is loading in this first stage, the blank page will appear and still be "Loading...". This is most easily reproducible with a large document that takes a while to load, but you can also wave your mouse madly on small documents to trigger it. (The more you concentrate / don't move for testing, the harder it is to find the bug! Typical :-P)

Saivann Carignan (oxmosys) wrote :

Know what? You're right. This bug happens when moving the mouse while opening a document! I confirm.

Can you forward your debug log and this useful information to the upstream bug?
http://bugzilla.gnome.org/show_bug.cgi?id=552382

Hew (hew) wrote :

I have posted my info upstream.

mogwai (scruffy-mogwai) wrote :

Same problem here. Though, after reading through the comments I want to say that resizing the window does cause evince to render the PDF.

I have found that this happens more often than not where you open a PDF that has not been opened since the last session/reboot.

Christian Ramseier (cramseier) wrote :

I'm new to the evince code but I thought I should share what I found out.
I noticed that the rendering job somehow gets cancelled and the page then just shows that it is "Loading..."

here's my stacktrace:
ev-jobs.c: ev_job_cancel
ev-pixbuf-cache.c: copy_job_to_job_info
ev-pixbuf-cache.c: ev_pixbuf_cache_get_link_mapping
ev-view.c: ev_view_get_link_at_location
ev-view.c: ev_view_handle_cursor_over_xy
ev-view.c: ev_view_motion_notify_event <- gets called when the mouse moves, here we go...

copy_job_to_job_info cancels the job because the "job_info->job" object still exists. it normally gets destroyed the moment the idle calls emit_finished (ev-jobs.c), but this hasn't happend yet.

In the ev-pixbuf-cache.c you'll find several comments like this: /* We don't need to wait for the idle to handle the callback */.
I think you do have to wait for the callback or you have to clean the job_info->job before calling copy_info_to_job. Otherwise the job gets cancelled and that's what causes this bug.

I don't have the big picture so I won't commit anything but I hope this helps resolving this annoying bug..

Cheers, Chris

Sebastien Bacher (seb128) wrote :

could you look at the upstream bug? upstream commited a fix that should fix it, would be nice to give it a try and maybe add your comment there too

Changed in evince:
status: New → Fix Released
Christian Ramseier (cramseier) wrote :

Just tried the fix. Unfortunately I can still reproduce the bug with some pdf files (see attachement for an example pdf file) and therefore this bug should not be closed.
After opening and moving the mouse the screen hangs on "loading..." again.

ChangeLog says: Make sure copy_job_page_and_selection_to_job_info is always called before copy_job_to_job_info. Fixes bug #552382.

I'm still not seeing the whole concept behind the all the pixbuf stuff but I think I was able to fix it on my machine by adding ...

g_signal_emit (pixbuf_cache, signals[JOB_FINISHED], 0, job_info->region);

... to "copy_job_to_job_info" after "copy_job_page_and_selection_to_job_info" was called. Hope this helps.

Cheers, Chris
@Sebastien Bacher: What do you mean by "add my comment to the upstream"? Isn't this the official place for bug-reporting?

Sebastien Bacher (seb128) wrote :

ubuntu is a distribution, it means we distribute free software code written by other people and try to integrate it to give a good user experience, upstream are the people writting the software. the ubuntu team is small and often the people triaging the bug on launchpad don't know the code concerned as well as upstream. in this case GNOME is using bugzilla.gnome.org and if you want to interact directly with the people writting the code you should comment on their bug tracker rather than on launchpad

Saivann Carignan (oxmosys) wrote :

Sebastien Bacher : The bug is now fixed upstream. I successfully tested the patches of revision 3092 and 3207 and created a debdiff for intrepid, which I also built and tested. Can you review the debdiff for intrepid?

Sebastien Bacher (seb128) wrote :

thank you for your work on this bug, I'm going to sponsor the upload now

Sebastien Bacher (seb128) wrote :

the bug would be nice to fix in hardy too

Changed in evince:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 2.24.0-0ubuntu2

---------------
evince (2.24.0-0ubuntu2) intrepid; urgency=low

  * debian/patches/70_pdf_loading.patch: Evince does not get stuck
    on "Loading.." anymore when opening a PDF file. (LP: #256048)

 -- Saivann Carignan <email address hidden> Sat, 04 Oct 2008 14:37:23 -0400

Changed in evince:
status: Triaged → Fix Released
Saivann Carignan (oxmosys) wrote :

Sebastien Bacher : Here's a debdiff for hardy-proposed, based on 2.22.1.1-0ubuntu1 in hardy-updates. I successfully built and tested this patch, evince works perfectly so far. Should I start a standard SRU procedure or you can take care of it?

Christian Ramseier : Many thanks for completing the upstream fix!

Saivann Carignan (oxmosys) wrote :

Oh sorry, I attached the wrong debdiff. Here's the good one, based on evince_2.22.2-0ubuntu1 .

Sebastien Bacher (seb128) wrote :

the bug seems to have most of the required information, I'll subscribe the sru team when I sponsor the upload, would be nice to edit the bug to add a testcase though

Hew (hew) wrote :

I have added a test case to the bug description.

description: updated
Sebastien Bacher (seb128) wrote :

why did you change the bug to be private now?

Chris Coulson (chrisccoulson) wrote :

Was just about to ask the same question!

Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in evince:
status: Confirmed → Fix Committed
Saivann Carignan (oxmosys) wrote :

I tested 2.22.2-0ubuntu2 from hardy-proposed on a clean hardy install and I can't reproduce the bug, I see no regression in all functions I tried.

However, a side note : I was also not able to reproduce the bug with the un-fixed 2.22.2-0ubuntu1 evince version on Hardy.

mbrennwa (mbrennwa) wrote :

I installed 2.22.2-0ubuntu2 and tried to reproduce the problem I had with evince. Looks like works now as expected. Thanks!

Martin Pitt (pitti) wrote :

Copied hardy-proposed to hardy-updates.

Changed in evince:
status: Fix Committed → Fix Released
Dhanu (mrdhanu-yahoo) wrote :

The problem still on after updated.

Page still hang on Loading when it open Maximize until Minimize it and then Maximize again or load up correct with forced Unmaximize (unexpectedly).

FTI, Thanks.

I confirm : The problem still on after an update from hardy-updates.

I have seen the Evince Window is not maximized but cover all my screen. A simple maximization is enough to display the pdf.

Saivann Carignan (oxmosys) wrote :

Indeed, I was able to reproduce the bug once on Hardy after trying many many times. However, it is very rarely reproducible here. Not sure what to do since I re-verified last patch and saw no possible mistake, it would be hard to say exactly what is missing for Hardy.

Changed in evince:
status: Fix Released → Confirmed

I confirm that I am also affected by this bug.
It happens exactly as described, every time.

The situation experienced is the following :
Reading PDF files from an NTFS partition mounted in rw mode. They are all scientific articles (at most a few megabytes, a few pages of text and illustrations, no dynamic content except for links in some of them).
Ubuntu 8.04 with the latest updates as of November 18, 2008.

Michael

I confirm that I am also affected by this bug. I'm using Hardy up-to-date.

Joe le Kiffeur (joelekiffeur) wrote :

Hi!

I confirm this bug, and that's why I report this.
I'm using the 8.04.2 LTS.

I hope this will be fixed soon.

Hi Joe,

I believe this bug has fix in 9.04 (as far as I try).

FYI

--- On Sun, 5/17/09, Joe le Kiffeur <email address hidden> wrote:

From: Joe le Kiffeur <email address hidden>
Subject: [Bug 256048] Re: Loading PDF file hang on Loading...
To: <email address hidden>
Date: Sunday, May 17, 2009, 8:50 PM

Hi!

I confirm this bug, and that's why I report this.
I'm using the 8.04.2 LTS.

I hope this will be fixed soon.

--
Loading PDF file hang on Loading...
https://bugs.launchpad.net/bugs/256048
You received this bug notification because you are a direct subscriber
of the bug.

MFeif (matt-feifarek) wrote :

Bug still exists in Karmic 64bit.

Sebastien Bacher (seb128) wrote :

unsubscribing the sponsors since there is nothing waiting for sponsoring there

JB (jmb365) wrote :

This bug still exists in Ubuntu 9.04 Jaunty (64bit). If I try to open certain ps documents that have graphics it just sits there forever showing "Loading". The same file opens fine under "gv".

There is no evince --version for me to report!
uname -a
2.6.28-19-generic #61-Ubuntu SMP Wed May 26 23:32:46 UTC 2010 x86_64 GNU/Linux

JMB

Changed in evince:
importance: Unknown → Medium
Adolfo Jayme (fitojb) on 2013-07-09
Changed in evince (Ubuntu Hardy):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.