Evince blanks some pages, and keeps that in cache.

Bug #25488 reported by jdo on 2005-11-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Evince shows the pdf fine when starting. But after opening other pdf's and
working with other programs, sometimes a page is turned blank. Not always
complete blank, sometimes a line of text (mostly the start of a new paragraph or
table or so) does show. Reopening the same file (while leaving the first one on
the screen) shows the same blank page. Completely closing all evince windows,
and then reopening the file will show everything normal.

Evince 0.4.0
Ubuntu 5.10
kernel: K7
mem: 512MB

Sebastien Bacher (seb128) wrote :

Thanks for your bug. Does it happen on some particular document? Does it hang
when that happen? Could you do a screenshot of the issue?

jdo (jdo-deactivatedaccount) wrote :

(In reply to comment #1)

It happened a few times in the last days. The program didn't hang, I could
scroll through the document. It was not in a specific document. I also used the
'reload' from the menu, but the blank page stayed that way.

I could not find a way to trigger it, so I have no screenschot. However I saw
that a page update is occasionally slower than normal.

jdo (jdo-deactivatedaccount) wrote :

One way to trigger it: Select a few characters or words with the mouse, and
select reload from the menu. Most of the page will be blanked and sometimes
evince will crash. I think there are other ways to blank a page, but I haven't
found those.

Daniel Holbach (dholbach) wrote :

The crashes seem to be already mentioned in
http://bugzilla.ubuntu.com/show_bug.cgi?id=16226 and
http://bugzilla.ubuntu.com/show_bug.cgi?id=14032 - could you try to get a back
trace (the bug buddy dialog), so we could compare the output?

jdo (jdo-deactivatedaccount) wrote :
Download full text (7.3 KiB)

(In reply to comment #4)
I hope this is what you asked for. But this is when evice actually crashes. Most
of the time when a page is blanked, it doesn't crash.

Backtrace was generated from '/usr/bin/evince'

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1229138240 (LWP 9141)]
[New Thread -1231000656 (LWP 9143)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0xffffe410 in __kernel_vsyscall ()
#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb701a56b in waitpid () from /lib/tls/i686/cmov/libc.so.6
#2 0xb7ea3508 in libgnomeui_module_info_get ()
   from /usr/lib/l...

Read more...

Sebastien Bacher (seb128) wrote :

The crash on reload is fixed, do you still have the blank page issue?

jdo (jdo-deactivatedaccount) wrote :

(In reply to comment #6)

I have now evince 0.4.0-0ubuntu4, and tried to install the 0.4.0-1ubuntu4 with
dpkg, but that was not possible, because it needs a number of newer dependencies.

Sorry, but I don't know how to test it right now.

Daniel Holbach (dholbach) wrote :

Were you able to upgrade to Dapper to try it there?

Changed in evince:
assignee: seb128 → desktop-bugs
jdo (jdo-deactivatedaccount) wrote :

I tried evince in Dapper. The known problem (blanking a page when selecting something) is gone. Evince is also more responsive.

The problem I reported was slightly different (opening other pdf's, and doing a lot of other things), but I was never able to reproduce it. I guess it is due to the same bug, and I assume it has gone also.

This bug can be closed.
Thanks.

jdo.

Daniel Holbach (dholbach) wrote :

Thanks for following up.

Changed in evince:
status: Needs Info → Fix Released
wasantha (wasanthadesha) wrote :

I am using Ubuntu 18.04 and most of the content of pdf files are not shown. I as a bypass upload those docs to Google Drive and it opens files without any hitch. It is the same with Okular, xpdf and Atril too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.