Evince renders white pages after scroll/zoom commands

Bug #24963 reported by Pierluigi Rolando on 2005-11-03
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evince
Fix Released
Medium
evince (Ubuntu)
Medium
Sebastien Bacher

Bug Description

Evince fails to render correctly some (maybe all) pdf files.

If I open a pdf file and then I repeatedly change the zoom level and/or scroll
up/down the page sometimes it happens that evince renders the page it was
currently showing as white.
The bug can not immediatly be reproduced (sometimes it is necessary a good
amount of zooming in and out and fiddling with the scroll bar) but it always
happens at last. After the page disappers no Evince option/command (including
the view/update - in the Italian version it is 'Visualizza/Aggiorna (CTRL+R)')
makes it redraw correctly again.

I'm using Ubuntu Breezy and keeping it updated. It happens with different pdf
files and under both the i386 and the amd64 distribution versions. It happens
with 2 different graphics card (i815, integrated on my laptop, and geforce 6600
on my amd64 desktop, using proprietary nvidia drivers) under 2 different
systems. It happens with different pdf files, which I believe were generated in
different ways.

I've tried to take a screenshot of the bug with the system/take screenshot
utility. In the screenshot the left page looks blank (which is not) (I use the
dual view just as an example, it looks like every option combination can cause
the bug to occour) but after taking the screenshot evince redrawed correctly the
page. Maybe it is just a redraw bug? When zooming it can happen that the page
appears briefly, until redraw is complete, but at that point the whole page
returns white. Covering the evince window with other windows doesn't appear to
trigger the redraw, only taking a screenshot does.

I'll try to attach a sample pdf file and my screenshot (if I can figure out how
BugZilla attachments work).

Sorry for my poor English, I'm not a native speaker.

http://bugzilla.gnome.org/show_bug.cgi?id=321077: http://bugzilla.gnome.org/show_bug.cgi?id=321077

Pierluigi Rolando (lanugo) wrote :

Created an attachment (id=4862)
Sample pdf file with which the problem occours

Pierluigi Rolando (lanugo) wrote :

Created an attachment (id=4863)
Bug screenshot. The first page is blank, which should not be.

Pierluigi Rolando (lanugo) wrote :

(In reply to comment #0)
> If I open a pdf file and then I repeatedly change the zoom level and/or scroll
> up/down the page sometimes it happens that evince renders the page it was
> currently showing as white.

It appears that some amount of left/right scrolling might be necessary in order
to trigger the bug.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. It seems to be specific to the dual page mode, I've
forwarded it upstream: http://bugzilla.gnome.org/show_bug.cgi?id=321077

Pierluigi Rolando (lanugo) wrote :

(In reply to comment #4)
> Thanks for your bug. It seems to be specific to the dual page mode, I've
> forwarded it upstream: http://bugzilla.gnome.org/show_bug.cgi?id=321077

I'm afraid it is not dual-page mode specific. In fact I can trigger it even in
continuous (non dual page) mode (it just requires more effort).

As an aside, there seems to be some kind of bug (maybe it is the same, just
triggered in some other way) with text highlighting. Sometimes, when trying to
highlight some text, the page (the highlighted portion or just some other random
text) fails to redraw corretcly. Check the following attachment for a
screenshot. The bug has been reproduced with Ubuntu 5.10 (kept up-to-date) under
my amd64 and i386 systems. They are taken with the same sample file available
above. Again, taking a screenshot causes the problem to disappear.

Pierluigi Rolando (lanugo) wrote :

Created an attachment (id=4909)
Text highlighting bug

Pierluigi Rolando (lanugo) wrote :

Created an attachment (id=4910)
some text hightlighted, page portions not redrawn

Sebastien Bacher (seb128) wrote :

the text highligth is another bug: http://bugzilla.ubuntu.com/show_bug.cgi?id=16681

Sebastien Bacher (seb128) wrote :

If you use dapper could you try if you still have that issue?

> If you use dapper could you try if you still have that issue?

Sorry, I'm not using dapper here and ATM I don't have a spare hd to
install it. I tried downloading the .deb package but it won't install
under breezy, too many unmet dependencies. Is there another way I can
help?

Pierluigi Rolando

Sebastien Bacher (seb128) wrote :

There is no hurry. When you update to dapper just put a comment to the bug saying if that's still happening or not

towsonu2003 (towsonu2003) wrote :

doesn't happen to me with dapper (never tried with breezy) with either dual or continuous view

Wouter Bolsterlee (uws) wrote :

So, can this bug be closed?

Sebastien Bacher (seb128) wrote :

seems to work fine on edgy. Marking as fixed. Feel free to reopen if you still have the issue

Changed in evince:
status: Unconfirmed → Fix Released
Changed in evince:
status: Unconfirmed → Fix Released
Changed in evince:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.