Print and Submit buttons on fill-in form don't work

Bug #242256 reported by Scott on 2008-06-23
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: evince

Received a pdf form to fill in from the doctor. The fill-in worked great (couldn't save a copy with the data, but that's a different bug report). There was a 'print' and a 'submit' button on the form's last page that did nothing when pushed. I've attached the PDF so you can see what I'm talking about.

Thanks, Scott

ProblemType: Bug
Architecture: amd64
Date: Sun Jun 22 20:13:14 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/evince
NonfreeKernelModules: nvidia
Package: evince 2.22.2-0ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: evince
Uname: Linux 2.6.24-19-generic x86_64

Scott (firecat53) wrote :
Pedro Villavicencio (pedro) wrote :

that's probably not supported yet

Changed in evince:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

thank you for your bug report, that seems to be an upstream issue, could you open it on bugzilla.gnome.org too?

Dimitrios Symeonidis (azimout) wrote :

i can confirm this behaviour

Changed in evince:
status: New → Confirmed
Colan Schwartz (colan) wrote :

I couldn't find an open bug for this on bugzilla.gnome.org so I looked into setting up an account. It looks like they don't hide or obfuscate e-mail addresses, so I'd rather not. Can someone who already has an account (or doesn't care) open the bug report? Thanks.

I confirm this bug.
There's a bug report at Red Hat here: https://bugzilla.redhat.com/show_bug.cgi?id=866485

Reported at bugzilla.gnome.org and linked.

Changed in evince:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in evince (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Confirmed → Triaged

Scott, this is not reproducible in Trusty via Print to PDF.

Changed in evince (Ubuntu):
status: Triaged → Invalid
Scott (firecat53) wrote :

Still exists in Archlinux for me 6 years later :) I'm not familiar with the options that Evince is compiled with on Arch, but I do get this message (printed twice) when I open the original test file from the command line:

    ~ $ evince /home/firecat53/.local/tmp/dreggert.pdf

    ** (evince:30738): WARNING **: Unimplemented action: POPPLER_ACTION_JAVASCRIPT, please post a bug report in Evince bugzilla (http://bugzilla.gnome.org) with a testcase.

    ** (evince:30738): WARNING **: Unimplemented action: POPPLER_ACTION_JAVASCRIPT, please post a bug report in Evince bugzilla (http://bugzilla.gnome.org) with a testcase.

ProblemType: Bug
Architecture: amd64
Date: Friday Dec 12 2014
DistroRelease: Archlinux
ExecutablePath: /usr/bin/evince
NonfreeKernelModules: None
Package: 3.14.1-2
PackageArchitecture: amd64
Uname -a: Linux scotty 3.17.4-1-ARCH #1 SMP PREEMPT Fri Nov 21 21:14:42 CET 2014 x86_64 GNU/Linux

Thanks!
Scott

Scott (firecat53) wrote :

Sorry, forgot to add the poppler-glib version: 0.28.1, and glib2 version: 2.42.1

Scott

Scott, thanks for the quick follow up. Unfortunately, Arch is not Ubuntu. Please feel free to report this to them via their bugtracker.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Scott (firecat53) wrote :

Fair enough...however I just tested again with Ubuntu 14.04.1 Desktop live CD with the same file and it still doesn't work. Are you sure you were able to push the 'Print Form' button in the middle of the page on the last page of the PDF and it worked to open the printing dialog?

<later>Well I think you can close this bug, but for an entirely different reason. I just opened the file with Master PDF Editor, and those two buttons on the last page are javascript buttons. Which would (unless I'm missing something) explain why they don't work in Evince. I don't believe javascript support has been added.

Thanks,
Scott

Scott, while I did not click the Print Form button, I checked my desired boxes > File > Print... > tab General > Print to File > PDF > Print and the new PDF had the checkmarks checked.

You are correct in that javascript support is being worked on.

So, as this bug is yours, this is your call. If you would like a lowest priority WISHLIST javascript support request, then this report can be scoped to that. However, if you being able to print the form as previously advised with the checked checkboxes works for you, then we can leave the report as is.

Scott (firecat53) wrote :

The checkmarks have always worked...that wasn't the original bug. It was just the functionality of the 'Print Form' and 'Submit Form' buttons.

I'm happy closing this bug. I'm not really concerned about Javascript support, to be honest. I would have closed this a long time ago had I realized what the root cause was. If Javascript is implemented, then this will be fixed anyways, so no sense having another bug report floating around.

Thanks!
Scott

Changed in evince:
status: Confirmed → Expired
no longer affects: evince (Ubuntu)
affects: evince → evince (Ubuntu)
Changed in evince (Ubuntu):
importance: Medium → Undecided
status: Expired → New
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.