evince crash while highlighting certain text

Bug #22432 reported by John Dong on 2005-09-24
10
Affects Status Importance Assigned to Milestone
Evince
Fix Released
Critical
evince (Ubuntu)
Medium
Sebastien Bacher

Bug Description

Evince has trouble with highlighting text in certain PDF's. At first, I thought
this was #14032, but the symptoms are completely different.

REPRODUCE:
1. Download ftp://people.redhat.com/jakub/prelink/prelink.pdf and open with
Evince (better if from a terminal)
2. On the first page, start highlighting some text, and keep on dragging down to
highlight more.

WHAT HAPPENS:

Evince suddenly shuts down, at the console, an X Windows error is reported:
jdong@ubuntu:~$ evince prelink.pdf
The program 'evince' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 4549 error_code 8 request_code 59 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

jdong@ubuntu:~$ evince prelink.pdf --sync
The program 'evince' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 12341 error_code 8 request_code 59 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

http://bugzilla.gnome.org/show_bug.cgi?id=314526: http://bugzilla.gnome.org/show_bug.cgi?id=314526

Sebastien Bacher (seb128) wrote :

Thanks for your bug, that's known upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=314526

John Dong (jdong) wrote :

lol, I've just been having this knack for reporting upstream bugs lately, huh?

Changed in evince:
status: Unconfirmed → Confirmed
status: Unconfirmed → Confirmed
Carthik Sharma (carthik) wrote :

Closing this bug since the upstream bug has been resolved and there are comments in the upstream bug that say the problem has been fixed in the Ubuntu packages too.

Thank you for reporting this bug. If this still persists when using the latest Ubuntu Dapper packages, please reopen this bug.

Changed in evince:
status: Confirmed → Fix Released
Changed in evince:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.