Evince won't open another pdf from a link within a pdf file

Bug #218361 reported by TerpInHotLanta on 2008-04-16
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evince

I have a PDF file that has links to other pdf files within it (e.g. the table of contents). When I click on one of these links nothing happens.

Previously, I was able to run these files with no problem in Gutsy, but since upgrading to Hardy, it has stopped working.

Pedro Villavicencio (pedro) wrote :

thanks for your report, can you attach that pdf file? thanks.

Changed in evince:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
TerpInHotLanta (ccampjr) wrote :

I should also add that the file worked in KPDF just fine.

As for attaching the file, I'll try and make a file that does the same thing-- the file I tested is copyrighted (and I'm not in the financial situation to get sued)

-Charlie

Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in evince:
status: Incomplete → Invalid
miroune (miroune) wrote :

I have encountered this problem too :
My pdf is not copyrighted and everything should work...but it's not the case
My version is 2.22.2

Mark Edgington (edgimar) wrote :

This is still a problem in Jaunty (using AMD64). I have attached a file which demonstrates the problem.
When the link in the file is clicked with evince (assuming the target -- /tmp/test.pdf -- is present), evince *SHOULD* open the file, but it does not, and the new evince window which is launched contains an error message: "Error opening file: No such file or directory".

If the same PDF file is opened in Adobe's acrobat reader, it opens the target file with no problems.

Changed in evince (Ubuntu):
status: Invalid → New
Dimitrios Symeonidis (azimout) wrote :

confirmed here, on latest jaunty

Changed in evince (Ubuntu):
status: New → Confirmed
summary: - [Hardy] Evince won't open another pdf from a link within a pdf file
+ Evince won't open another pdf from a link within a pdf file

Not reproducible in Trusty.

Changed in evince (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments