evince not respecting default printer

Bug #198134 reported by Michael Blinn on 2008-03-03
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
evince (Debian)
New
Unknown
evince (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evince

I've seen this bug on FC6 and Ubuntu Hardy Heron Alpha 5

FC6 'yum info evince':
Name : evince
Arch : x86_64
Version: 0.6.0
Release: 6.fc6
Size : 2.7 M
Repo : installed
Summary: Document viewer

Hardy Heron Alpha 5 'apt-cache policy evince':
evince:
  Installed: 2.21.92-0ubuntu1
  Candidate: 2.21.92-0ubuntu1
  Version table:
 *** 2.21.92-0ubuntu1 0
     500 http://us.archive.ubuntu.com hardy/main Packages
     100 /var/lib/dpkg/status

Running 'lpoptions -d PrinterName' to set a default printer is respected by most other programs (OOo, Firefox) but not by evince - I've run this command from a script in /etc/profile.d as well as typing it into a gnome-terminal session.

After 'File->Print', the correct printer specified by the lpoptions command should be hilighted in print dialog. Instead, the default CUPS printer is hilighted. This stinks when you use something like LTSP because you can have 10 or 20 printers connected and the default should be based on workstation location and set by a login script using lpoptions.

TerryG (tgalati4) wrote :

Thanks for your bug submission.

Does this work correctly under Gutsy but not Hardy Alpha 5?

Does your /etc/profile.d script run as root?

Please post the output of:

 ~/.cups/lpoptions

 (user defaults and instances created by non-root users.)

and

 /etc/cups/lpoptions

system-wide defaults and instances created by the root user.

Perhaps as simple as putting /.cups/lpoptions in each of the local user accounts?

Marking as Incomplete pending output.

Changed in evince:
status: New → Incomplete
Michael Blinn (mblinn-gmail) wrote :

.lpoptions are not respected in Gutsy either - though I've only tried i386 arch.

[root@mail log]# cat /etc/cups/lpoptions
Default UpstairsMain scp-fc5=true
[root@mail log]# cat ~user1/.cups/lpoptions
Default DownstairsMain
[root@mail log]# cat ~user2/.cups/lpoptions
Default UpstairsDahl
[root@mail log]# cat ~user3/.cups/lpoptions
Default Keith_Color_Printer

each of the ~user/.cups/lpoptions are set at login with the following script in /etc/profile.d/set_printer.sh - I'm using LTSP and thin clients, with printer based on hostname, not user.

#!/bin/sh
ws=$(echo $LTSP_CLIENT|cut -d. -f1)
case $ws in
   ws0-007 ) lpoptions -d UpstairsDahl ;;
   ws0-010 ) lpoptions -d DownstairsDahl ;;
   ws0-016 ) lpoptions -d UpstairsDahl ;;
   ws0-017 ) lpoptions -d Keith_Color_Printer ;;
esac

This may be an upstream GTK bug: https://bugs.launchpad.net/fedora/+source/libgnomeprint/+bug/34112

Wendy (e-launchpad-satan-nl) wrote :

Using Evince Document Viewer 2.20.1 in Ubuntu Gutsy, I noticed that the the default printer settings are ignored and when entered in the print setup, are forgotten as soon as Evince is exited and re-entered.

My default printer (a Brother) is remembered by my other applications, but not by Evince. The same about paper size (A4). I know it's easy to open the Print Setup menu and change "Any Printer" to "Brother..." and Paper Size from "US Letter" to "A4", but hey, since other applications can remember such basic settings, I thought, well, let's just ask.

Thanks for your attention. Kind regards,
Wendy

Wendy (e-launchpad-satan-nl) wrote :

Output of lptoptions:

media=A4 finishings=3 copies=1 job-hold-until=no-hold job-priority=50 number-up=1 auth-info-required=none job-sheets=none,none printer-info=MFC9420CN printer-is-accepting-jobs=1 printer-is-shared=1 printer-location=Kantoor printer-make-and-model='Brother MFC-9420CN BR-Script3' printer-state=3 printer-state-change-time=1207243782 printer-state-reasons=none printer-type=168012

Wendy

Wendy (e-launchpad-satan-nl) wrote :

Output of lpoptions:

media=A4 finishings=3 copies=1 job-hold-until=no-hold job-priority=50 number-up=1 auth-info-required=none job-sheets=none,none printer-info=MFC9420CN printer-is-accepting-jobs=1 printer-is-shared=1 printer-location=Kantoor printer-make-and-model='Brother MFC-9420CN BR-Script3' printer-state=3 printer-state-change-time=1207243782 printer-state-reasons=none printer-type=168012

Wendy

Changed in evince:
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

thank you for your bug report, that seems to be an upstream issue, could you open it on bugzilla.gnome.org too?

Changed in evince:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

could you try if that's still an issue in intrepid?

Changed in evince:
status: New → Incomplete
Michael Blinn (mblinn-gmail) wrote :

My Hardy boxes are production boxes. I'll see about setting up an Intrepid box but it may be awhile. Anyone else subscribing to this bug: if you have easy access to an II box to test it would be appreciated.

Sebastien Bacher (seb128) wrote :

did anybody try that on intrepid yet?

Samuel Schluep (schluep) wrote :

I confirm this behavior on intrepid (Ubuntu 8.10). When I open the print... dialog in Evince Document Viewer, another printer than the default one is selected. I set the default printer using the Ubuntu menu System > Preferences > Default Printer. The default printer is correctly preselected in other applications such as Firefox, gedit, Thunderbird, OpenOffice...

Neither ~/.cups/lpoptions nor /etc/cups/lpoptions seem to work on my computer.

Changed in evince:
status: Incomplete → New
floflooo (florent-angly-gmail) wrote :

I also confirm this bug on Ubuntu Intrepid 8.10, Evince 2.24.1.
I set the default printer using the Ubuntu menu System > Preferences > Default Printer. Then Evince uses the system default, not the default that I have set up. Other applications like Firefox or OpenOffice respect the user's defaut printer.

Dimitrios Symeonidis (azimout) wrote :

multiple confirmations, marking as confirmed

Changed in evince (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

is that still an issue in jaunty?

John Pye (jdpipe) wrote :

This issue is still present. Tested with Evince 2.26.1 on Jaunty.

John Pye (jdpipe) wrote :

is there an upstream bug, btw?

floflooo (florent-angly-gmail) wrote :

I upgraded to Jaunty. The issue is still present (Evince 2.26.1, Poppler 0.10.5).

wilk (j-cubizolles) wrote :

I'm running evince 2.29.4, with poppler 0.12.0 in Karmic, this but is still present.

papukaija (papukaija) on 2010-05-15
tags: added: intrepid jaunty karmic lucid
Changed in evince (Debian):
status: Unknown → New
Changed in evince (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.