evince can't start local installation of vivaldi browser

Bug #1895664 reported by Rolf Leggewie on 2020-09-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apparmor (Ubuntu)
Undecided
Unassigned
evince (Ubuntu)
Low
Unassigned

Bug Description

evince 3.28.4-0ubuntu1.2 running on bionic. I cannot call the vivaldi-browser by clicking on a link. Instead an error is shown "Failed to execute child process “/usr/bin/vivaldi-stable” (Permission denied)". Some lines from syslog:

Sep 15 14:28:28 work kernel: [46945.893234] audit: type=1400 audit(1600172908.761:241): apparmor="DENIED" operation="create" profile="/usr/bin/evince//sanitized_helper" pid=4709 comm="pool" family="netlink" sock_type="raw" protocol=0 requested_mask="create" denied_mask="create"
Sep 15 14:28:29 work kernel: [46946.523153] audit: type=1400 audit(1600172909.393:242): apparmor="DENIED" operation="create" profile="/usr/bin/evince//sanitized_helper" pid=4709 comm="pool" family="netlink" sock_type="raw" protocol=0 requested_mask="create" denied_mask="create"
Sep 15 14:28:29 work kernel: [46946.716721] audit: type=1400 audit(1600172909.585:243): apparmor="DENIED" operation="create" profile="/usr/bin/evince//sanitized_helper" pid=4709 comm="pool" family="netlink" sock_type="raw" protocol=0 requested_mask="create" denied_mask="create"
Sep 15 14:28:29 work kernel: [46946.748450] audit: type=1400 audit(1600172909.617:244): apparmor="DENIED" operation="create" profile="/usr/bin/evince//sanitized_helper" pid=4709 comm="pool" family="netlink" sock_type="raw" protocol=0 requested_mask="create" denied_mask="create"
Sep 15 14:28:53 work kernel: [46970.973331] audit: type=1400 audit(1600172933.841:256): apparmor="DENIED" operation="exec" profile="/usr/bin/evince" name="/opt/vivaldi/vivaldi" pid=5390 comm="evince" requested_mask="x" denied_mask="x" fsuid=1000 ouid=0

Changed in evince (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, vivaldi isn't a known webbrowser though and is a locally installed software in /opt so probably something you need to handle locally

summary: - problem in apparmor configuration of evince
+ evince can't start local installation of vivaldi browser
Changed in evince (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers