SRU the current 3.36.5 stable update

Bug #1879475 reported by Sebastien Bacher on 2020-05-19
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Unassigned
Focal
Undecided
Unassigned

Bug Description

* Impact
That's the current GNOME stable update, including some fixes and translation updates
https://gitlab.gnome.org/GNOME/evince/-/blob/master/NEWS

* Test case

The update is part of GNOME stable updates
https://wiki.ubuntu.com/StableReleaseUpdates/GNOME

Open some pdf and ps documents, check that they render properly

* Regression potential

There is no specific change or feature to test in this update

Changed in evince (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 3.36.1-1

---------------
evince (3.36.1-1) unstable; urgency=medium

  * New upstream release (lp: #1879475)
  * debian/rules:
    - override the dh_translations call to delete the outdated template
      which is provided by upstream (lp: #1877401)

 -- Sebastien Bacher <email address hidden> Tue, 19 May 2020 16:23:45 +0200

Changed in evince (Ubuntu):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) on 2020-05-22
summary: - SRU the current 3.36.2 stable update
+ SRU the current 3.36.1 stable update

--- evince-3.36.0/libdocument/ev-form-field.h 2017-10-03 18:15:33.000000000 +0000
+++ evince-3.36.1/libdocument/ev-form-field.h 2020-05-11 04:34:35.000000000 +0000
@@ -113,6 +113,7 @@

        EvPage *page;
        gboolean changed;
+ gchar *alt_ui_name;
 };

 struct _EvFormFieldClass

Doesn't this change the ABI of a public library? This appears to be a public header file included in libevince-dev, and EvFormField is the first subelement of several other structures defined in this header, which will invalidate offsets into these structures compiled into reverse-dependencies.

Changed in evince (Ubuntu Focal):
status: New → Incomplete
summary: - SRU the current 3.36.1 stable update
+ SRU the current 3.36.5 stable update
Changed in evince (Ubuntu Focal):
status: Incomplete → In Progress

Hello Sebastien, or anyone else affected,

Accepted evince into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/evince/3.36.5-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in evince (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Paul White (paulw2u) wrote :

With -proposed enabled I upgraded evince to version 3.36.5-0ubuntu1.

As per test case I opened a number of .pdf and .ps files which I found on my PC or the web. All were found to render as intended.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 3.36.5-0ubuntu1

---------------
evince (3.36.5-0ubuntu1) focal; urgency=medium

  * New upstream release (lp: #1879475)
  * debian/patches/git_armhf_build.patch:
    - cherry pick an upstream fix 'backend: Fix -Werror=format=2 on
      dvi', fixes the build on armhf
  * debian/rules:
    - override the dh_translations call to delete the outdated template
      which is provided by upstream (lp: #1877401)

 -- Sebastien Bacher <email address hidden> Tue, 19 May 2020 16:23:45 +0200

Changed in evince (Ubuntu Focal):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for evince has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers