Can't type anything in search box

Bug #1588197 reported by Robert Hrovat on 2016-06-02
80
This bug affects 29 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Unassigned

Bug Description

Since Ubuntu 16.04, I can't search strings in PDF using Evince viewer. Clicking search button or CTRL+F shows search box, but I can't type anything inside.

affects: mozplugger (Ubuntu) → evince (Ubuntu)
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, does it happen on any pdf? What desktop environment do you use? I can't confirm the issue here

Changed in evince (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Robert Hrovat (robi-hipnos) wrote :

Yes, any PDF. It's Ubuntu Unity with all updates installed. Searching the internet shows at least one more user with this issue: http://askubuntu.com/questions/779872/cant-type-in-evince-search-field

Robert Hrovat (robi-hipnos) wrote :

I came home and tried the same on another computer with the same version of Ubuntu and got the same symptom.

I just noticed this. 16.04, GNOME desktop. I can't remember when the last time I did a successful search in Evince was but it's something I do regularly. Maybe two or three days at most since it last worked.

I'm attaching an apt-cache show if it'll help.

A little more Google tells me this is probably a duplicate of bug #1587968. I too just switched to installing from "proposed" - did any of the others on this bug?

Robert Hrovat (robi-hipnos) wrote :

I guess this one is duplicate. And I do have proposed enabled.

I think the bug is in one of the underlying libraries, not Evince itself - when I enabled "Proposed" it updated a few GNOME libraries but I don't recall a change in Evince itself.

Miguel Romão (romao-miguel) wrote :

Bug affects me too, Ubuntu GNOME 16.04, with "proposed" enable with Evince 3.18.2

This bug affects me too, Ubuntu 16.04 with evince 3.18.2.

Earl Kinsley (earlkinsley) wrote :

This bug affected me too, Ubuntu 16.04 with Evince 3.18.2 wouldn't allow any text input. Also Firefox 46.0.1 was affected. Turns out I had "xenial-proposed" enabled (Hmmm, I don't remember enabling this) I was able to disable "xenial-proposed" and back out all the "proposed" updates. Both Evince and Firefox are working normal again.

Same here ... seems like a total lack of response / troubleshooting assistance from Ubuntu so I've dropped back to "stock" Xenial and am taking myself off the email list for this bug.

Robert Hrovat (robi-hipnos) wrote :

I removed proposed and got back to stable. Evince is working properly again.

Those packages were reverted:

bsdutils grep im-config initscripts ipmitool klibc-utils libappstream-glib8 libblkid1 libfdisk1 libglib2.0-0 libglib2.0-bin libglib2.0-data libimobiledevice6 libklibc libmetacity-private3a libmount1
libnih-dbus1 libnih1 libnm-gtk-common libnm-gtk0 libnma-common libnma0 librados2 librbd1 libsemanage-common libsemanage1 libsmartcols1 libuuid1 libuuid1:i386 linux-generic linux-headers-generic linux-image-generic linux-libc-dev metacity metacity-common mount mtr-tiny network-manager-gnome p7zip p7zip-full sysv-rc sysvinit-utils thermald util-linux uuid-runtime

gpl (gpl-mac) wrote :

If I launch evince from the command line, I get this as soon as I try to type something (e.g., in the search field):

(evince:28540): IBUS-WARNING **: Unable to connect to ibus: Ne eblis konekti: Mankas permeso

(evince:28540): IBUS-WARNING **: Events queue growing too big, will start to drop.

(evince:28540): IBUS-WARNING **: Events queue growing too big, will start to drop.

(evince:28540): IBUS-WARNING **: Events queue growing too big, will start to drop.

The last message repeats ad nauseam.

Sebastien Bacher (seb128) wrote :

the issue was due to that SRU candidate
https://launchpad.net/ubuntu/+source/im-config/0.29-1ubuntu12.1

the update was considered (rightly it seems) buggy and deleted since, if you have the issue you should reinstall the xenial version

Changed in evince (Ubuntu):
status: Incomplete → Invalid
gunwald (gunwald) wrote :

I have the same issue on Ubuntu 16.04 using the Gnome PPA. Can someone post a step by step work around pleas.

I was able to resolve the issue with searching a PDF in Evince on Ubuntu Gnome 16.04 by following these steps.

1. Launch "Software & Updates".
2. Select "Developer Options" tab.
3. Uncheck "Pre-released updates (xenial-proposed)
4. Follow these instructions: http://www.webupd8.org/2013/11/how-to-downgrade-proposed-repository.html
5. Reboot, searching works in PDFs using Evince.

Thomas Mayer (thomas303) wrote :

Right after upgrading from 16.04 to 18.04, I can't type in evince's search field any more. Proposed packages where never installed on that system.

Thomas Mayer (thomas303) wrote :

For some PDFs I can type something in the search field. Seems to be related to the PDF (if it contains text or not).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers