Evince windows cannot be resized after upgrade to Xenial

Bug #1579142 reported by Karl Kastner on 2016-05-06
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
High
Unassigned

Bug Description

Since upgrade to Xenial, windows of evince cannot be resized on my machine. Windows can be maximized and restored, but windows cannot be resized with the mouse to arbitrary width and height. Works fine for windows of other applications.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: evince 3.18.2-1ubuntu4
ProcVersionSignature: Ubuntu 3.19.0-58.64~14.04.1-generic 3.19.8-ckt16
Uname: Linux 3.19.0-58-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: GNOME
Date: Fri May 6 18:27:55 2016
InstallationDate: Installed on 2015-11-05 (183 days ago)
InstallationMedia: Ubuntu 14.04.3 LTS "Trusty Tahr" - Beta amd64 (20150805)
SourcePackage: evince
UpgradeStatus: No upgrade log present (probably fresh install)

Karl Kastner (kastner-karl) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evince (Ubuntu):
status: New → Confirmed
affects: evince (Ubuntu) → gnome-shell (Ubuntu)
Changed in gnome-shell (Ubuntu):
importance: Undecided → High
Karl Kastner (kastner-karl) wrote :

The problem still persists in 16.04, which is, that the resize cross hairs do not show up when the mouse is howevered over the borders of the window. This is only the case for some applications, most applications, like gnome-terminal, are not affected. However, at least in the latest release I can resize the window in evince by right clicking in the menu bar and selecting "resize". There is also the keyboard shortcut alt-f8, but I guess only a contortionist can move the mouse with one hand and hit alt-f8 single handed with the other.

John McPherson (john-mcpherson) wrote :

still happens in 17.04.

This happens if using the Ambiance theme with gnome-flashback, so I think it is theme related and not specifically any app window. You can work around this by modifying your .config/gtk-3.0/gtk.css file to leave some margin space around your window, like:

.background.csd decoration { margin: 10px; }

[see https://askubuntu.com/questions/733466/cant-resize-nautilus-window-in-gnome-flashback-using-ambiance-theme for more info]

Alex (alexbennett) wrote :

I was unable to reproduce this bug using Bionic Daily - 26/03/2018. Resizing the window worked as expected when dragging form the corner with the mouse.

Daniel van Vugt (vanvugt) wrote :

Yes it's been fixed and working for quite some time. Verified again on 18.04 today.

If only we knew what the fix was we could backport it to 16.04.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
Ian Turner (vectro) wrote :

I am experiencing this on Ubuntu 18.04 with evince 3.28.2-1. A possible regression?

Changed in gnome-shell (Ubuntu):
status: Fix Released → Confirmed
Andor Kormanyos (akormanyos) wrote :

I am experiencing this problem on Kubuntu 18.04 with evince 3.28.2-1

John Ladasky (jladasky) wrote :

I have experienced this problem over the years. I am currently seeing it with Ubuntu 18.04.1 and Evince Document Viewer 3.28.2.

The symptoms I observe are more extensive than others have described: When the document is opened, its window is pinned to the upper left corner. The window cannot be dragged out of the corner. The window size is also fixed, none of the edges or corners can be dragged. None of the buttons on the window's top bar work, so I have to press the Super key and close Evince from the desktop.

However, I have just determined that this problem only occurs with certain PDF's and not others. Attached is an example PDF that causes the problem in my hands.

Daniel van Vugt (vanvugt) wrote :

I'm not sure this is definitely a gnome-shell bug. Window resizing is at the discretion of the app, and not the shell. So reassigning to evince.

affects: gnome-shell (Ubuntu) → evince (Ubuntu)
WH (wha) wrote :

The same problem in kubuntu 18.04 and evince 3.28.4. However, I have noticed the following: window resizing works in the top of the window but not in the bottom or sides (so you can change the hight). If you press alt and the right button of the mouse, resizing may work in all directions, but it is unpredictable, may depend on the pdf.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers