Evince does not display PDF annotations

Bug #1571980 reported by Karl Kastner on 2016-04-19
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
High
Unassigned

Bug Description

Evince does not display the content of PDF annotations. It only displays an obtuse yellow symbol, but not the annotation text. This affects not only documents where annotations were added with adobe reader to existing pdf files, but also pdf files where the annotations are created with the document, for example with pdflatex and the pdfmarginpar package.

File to test: http://tug.ctan.org/macros/latex/contrib/pdfmarginpar/doc/pdfmarginparexample.pdf

The annotations in this file are properly displayed in the Firefox internal pdf-viewer. If downloaded and opened with evince, the annotation text is not displayed on my machine.

This does not seem to be directly a problem of evince, but rather of one of the underlying libraries, because the annotations are also not properly displayed in okular.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: evince 3.10.3-0ubuntu10.2
ProcVersionSignature: Ubuntu 4.2.0-19.23~14.04.1-generic 4.2.6
Uname: Linux 4.2.0-19-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.19
Architecture: amd64
CurrentDesktop: GNOME
Date: Tue Apr 19 08:13:05 2016
InstallationDate: Installed on 2015-11-05 (165 days ago)
InstallationMedia: Ubuntu 14.04.3 LTS "Trusty Tahr" - Beta amd64 (20150805)
SourcePackage: evince
UpgradeStatus: No upgrade log present (probably fresh install)

Karl Kastner (kastner-karl) wrote :
gunwald (gunwald) wrote :

I can confirm, that this bug exists still in Evince 3.24.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evince (Ubuntu):
status: New → Confirmed
Hauke Wintjen (hwintjen) wrote :

Still present also in Evince 3.28.4.

Strangely also in Okular....

Hauke Wintjen (hwintjen) wrote :

In Evince it shows the annotation in text as strike-through text (similair as in Adobe Reader DC on Win), but when clicking on the annotation in the text, it shows an empty box without the annotation text.

Sebastien Bacher (seb128) wrote :

The issue could be the same as https://gitlab.freedesktop.org/poppler/poppler/issues/656 , could you give details on those annotations/how they were added?

Changed in evince (Ubuntu):
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

The annotations are displayed fine in the current version

Changed in evince (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers