Specially crafted postscript file forces a segfault

Bug #1528928 reported by Niles Rogoff on 2015-12-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Unassigned

Bug Description

Running `evince temp.ps' causes a segmentation fault. The file was generated by doing `sudo systemd-analyze plot|a2ps > temp.ps'.

Evince version: "GNOME Document Viewer 3.18.2"
Running XFCE 4.12 on Arch

Sorry I can't find any more detailed logs, don't really know what I'm looking for.

I have attached the file temp.ps

Niles Rogoff (nilesrogoff) wrote :
Niles Rogoff (nilesrogoff) wrote :

Ok I tried it a fourth time and this time it opened, but then segfaulted when I tried to resize the window.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in evince (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments