evince crashed with SIGSEGV in atk_object_notify_state_change()

Bug #1436555 reported by dulbirakan on 2015-03-25
124
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Evince
Fix Released
Critical
evince (Ubuntu)
High
Unassigned

Bug Description

Just some random error message, I don't know what trigerred it.

ProblemType: Crash
DistroRelease: Ubuntu 15.04
Package: evince 3.14.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-9.9-generic 3.19.1
Uname: Linux 3.19.0-9-generic x86_64
ApportVersion: 2.16.2-0ubuntu4
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Mar 25 13:41:32 2015
ExecutablePath: /usr/bin/evince
InstallationDate: Installed on 2015-03-21 (4 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150320)
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-3.19.0-9-generic root=UUID=839483f2-46c1-46c7-aa60-848b27c31a16 ro quiet splash vt.handoff=7
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f4e8eab7eaf <atk_object_notify_state_change+31>: cmp %rax,(%rcx)
 PC (0x7f4e8eab7eaf) ok
 source "%rax" ok
 destination "(%rcx)" (0x6800000043) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: evince
StacktraceTop:
 atk_object_notify_state_change () from /usr/lib/x86_64-linux-gnu/libatk-1.0.so.0
 ev_view_accessible_set_page_range () from /usr/lib/libevview3.so.3
 ?? () from /usr/lib/libevview3.so.3
 ?? () from /usr/lib/libevview3.so.3
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: evince crashed with SIGSEGV in atk_object_notify_state_change()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

dulbirakan (iekanat) wrote :

StacktraceTop:
 atk_object_notify_state_change () from /tmp/apport_sandbox_ZLglF6/usr/lib/x86_64-linux-gnu/libatk-1.0.so.0
 ev_view_accessible_set_page_range (accessible=0x1367bb0, start=start@entry=2, end=end@entry=2) at /build/buildd/evince-3.14.2/./libview/ev-view-accessible.c:583
 view_update_range_and_current_page (view=view@entry=0x1504140) at /build/buildd/evince-3.14.2/./libview/ev-view.c:789
 on_adjustment_value_changed (adjustment=<optimized out>, view=0x1504140) at /build/buildd/evince-3.14.2/./libview/ev-view.c:7343
 g_closure_invoke (closure=0x149d0b0, return_value=0x0, n_param_values=1, param_values=0x7ffc558a7190, invocation_hint=0x7ffc558a7130) at /build/buildd/glib2.0-2.43.92/./gobject/gclosure.c:768

Changed in evince (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
Changed in evince (Ubuntu):
importance: Medium → High
status: New → Triaged
Changed in evince:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in evince:
importance: Medium → Critical
Changed in evince (Ubuntu):
status: Triaged → Fix Committed
Changed in evince:
status: Confirmed → Fix Released
tags: added: xenial
PeterPall (peterpall) wrote :

My evince just has crashed again (current yakkety). What has triggered the problem is that I have viewed a bug pdf file and then have changed this file by attempting another LaTeX run => The file grew and I suspect that evince tried to display it while it was still being writen. What I don't know if the fix isn't committed in Yakkety but will be in the next days.

which Ubuntu package is supposed to be fixing this problem?

Stephan Springer (geryon) wrote :

Just got this crash with evince 3.18.2.

I was viewing a PDF which had changed while the viewer was open. Evince crashed apparently when trying to reload the PDF.

In which version is this supposedly fixed? I can't find this information here.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.