evince-thumbnailer crashed with SIGSEGV in cmsGetColorSpace()

Bug #1435004 reported by frank mahler on 2015-03-22
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Poppler
Fix Released
Medium
evince (Ubuntu)
Medium
Unassigned

Bug Description

1) >>lsb_release -rd
Description: Ubuntu Vivid Vervet (development branch)
Release: 15.04

2) >>apt-cache policy evince
evince:
  Installed: 3.14.2-0ubuntu1
  Candidate: 3.14.2-0ubuntu1
  Version table:
 *** 3.14.2-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
        100 /var/lib/dpkg/status

3) what I expected to happen:
I found an oversized icon in my nautilus gui. it was the DefaultProject.osp icon for OpenShot video editor. It was in my $HOME/Documents folder.
I deleted it. I expected nothing to happen.

4) What happened:
once deleted, and after about 5 minutes, I noticed a bug trace had been kicked off. I assume it had to do with the deletion of the oversized icon, especially as it was named default

ProblemType: Crash
DistroRelease: Ubuntu 15.04
Package: evince 3.14.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-9.9-generic 3.19.1
Uname: Linux 3.19.0-9-generic x86_64
ApportVersion: 2.16.2-0ubuntu4
Architecture: amd64
CurrentDesktop: GNOME
Date: Sun Mar 22 15:47:24 2015
ExecutablePath: /usr/bin/evince-thumbnailer
InstallationDate: Installed on 2014-03-05 (382 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-3.19.0-9-generic root=UUID=8c7a808f-9888-4106-9ae6-0c49ee66af44 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x7f341e18c990 <cmsGetColorSpace>: mov 0x50(%rdi),%eax
 PC (0x7f341e18c990) ok
 source "0x50(%rdi)" (0x00000050) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: evince
StacktraceTop:
 cmsGetColorSpace () from /usr/lib/x86_64-linux-gnu/liblcms2.so.2
 GfxICCBasedColorSpace::parse(Array*, OutputDev*, GfxState*, int) () from /usr/lib/x86_64-linux-gnu/libpoppler.so.49
 GfxColorSpace::parse(GfxResources*, Object*, OutputDev*, GfxState*, int) () from /usr/lib/x86_64-linux-gnu/libpoppler.so.49
 Page::loadThumb(unsigned char**, int*, int*, int*) () from /usr/lib/x86_64-linux-gnu/libpoppler.so.49
 poppler_page_get_thumbnail () from /usr/lib/x86_64-linux-gnu/libpoppler-glib.so.8
Title: evince-thumbnailer crashed with SIGSEGV in cmsGetColorSpace()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm bumblebee cdrom dip libvirtd lpadmin plugdev sambashare sudo

frank mahler (crmhound) wrote :

StacktraceTop:
 cmsGetColorSpace (hProfile=0x0) at cmsio0.c:926
 GfxICCBasedColorSpace::parse (arr=<optimized out>, out=out@entry=0x0, state=state@entry=0x0, recursion=recursion@entry=0) at GfxState.cc:2027
 GfxColorSpace::parse (res=res@entry=0x0, csObj=csObj@entry=0x7ffc74d930f0, out=out@entry=0x0, state=state@entry=0x0, recursion=recursion@entry=0) at GfxState.cc:389
 Page::loadThumb (this=<optimized out>, data_out=data_out@entry=0x7ffc74d93190, width_out=width_out@entry=0x7ffc74d93184, height_out=height_out@entry=0x7ffc74d93188, rowstride_out=rowstride_out@entry=0x7ffc74d9318c) at Page.cc:675
 poppler_page_get_thumbnail (page=0x1d7de40) at poppler-page.cc:490

Changed in evince (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evince (Ubuntu):
status: New → Confirmed
C de-Avillez (hggdh2) wrote :

Same crash, on 16.04.

Evince 3.18.2-1ubuntu4

information type: Private → Public
Changed in poppler:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.