Evince opens attached PDF file as locked

Bug #1404645 reported by Vasilis Ilioglou on 2014-12-21
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Poppler
Fix Released
Medium
evince (Ubuntu)
Low
Unassigned

Bug Description

1) lsb_release -rd
Description: Ubuntu Vivid Vervet (development branch)
Release: 15.04

2) apt-cache policy evince libcairo2 libpoppler[0-9]
evince:
  Installed: 3.14.1-0ubuntu1
  Candidate: 3.14.1-0ubuntu1
  Version table:
 *** 3.14.1-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
        100 /var/lib/dpkg/status
libcairo2:
  Installed: 1.13.0~20140204-0ubuntu1
  Candidate: 1.13.0~20140204-0ubuntu1
  Version table:
 *** 1.13.0~20140204-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
        100 /var/lib/dpkg/status
libpoppler47:
  Installed: 0.28.1-1ubuntu1
  Candidate: 0.28.1-1ubuntu1
  Version table:
 *** 0.28.1-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen via https://launchpadlibrarian.net/193158556/1%CE%B7%20%CE%94%CE%B9%CE%AC%CE%BB%CE%B5%CE%BE%CE%B7.pdf is it opens successfully, just as it does in Adobe Reader.

4) What happens instead is it prompts for a password. This was first reported against Ubuntu 14.04.1, Evince 3.10.3-0ubuntu10.1.

WORKAROUND: Open with Firefox's built-in PDF viewer:
apt-cache policy firefox
firefox:
  Installed: 34.0+build2-0ubuntu0.14.04.1
  Candidate: 34.0+build2-0ubuntu0.14.04.1
  Version table:
 *** 34.0+build2-0ubuntu0.14.04.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
        100 /var/lib/dpkg/status
     28.0+build2-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: evince 3.10.3-0ubuntu10.1
ProcVersionSignature: Ubuntu 3.13.0-43.72-generic 3.13.11.11
Uname: Linux 3.13.0-43-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.6
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Dec 21 14:00:07 2014
InstallationDate: Installed on 2014-12-11 (9 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
KernLog:

ProcEnviron:
 LANGUAGE=el
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=el_GR.UTF-8
 SHELL=/bin/bash
SourcePackage: evince
UpgradeStatus: No upgrade log present (probably fresh install)

Hi,

I'm no user of poppler but of Kovid's Calibre (http://calibre-ebook.com/) and this bug report arises by Kovid's suggestion about an issue in Calibre itself (https://bugs.launchpad.net/calibre/+bug/1375983)

The problem seems to be that certain new pdf files (http://usa.canon.com/CUSA/assets/app/pdf/brochures/EOS_7D_Mark_II_AF_guide_CUSA_9-2014.pdf?WT.mc_id=C126149) cannot be rendered by pdftoppm util which is used in Calibre.

As a wild guess it might be related to 256 bit AES encryption.

Vasilis Ilioglou (vasilisilio) wrote :

Vasilis Ilioglou, thank you for reporting this and helping make Ubuntu better. The issue you are reporting is an upstream one. Could you please report this problem to them following the instructions at https://wiki.ubuntu.com/DebuggingEvince ?

Please provide a direct URL to your upstream report once you have made it so that it may be tracked.

Thank you for your understanding.

description: updated
Changed in evince (Ubuntu):
importance: Undecided → Low
status: New → Triaged
tags: added: vivid
description: updated
summary: - Evince opens PDF files as locked
+ Evince opens attached PDF file as locked
Vasilis Ilioglou (vasilisilio) wrote :

Well, as far as i have done, my terminal appears these when i input the command:
vasilis@Vasilis-Laptop:~$ apt-cache policy evince libcairo2 libpoppler[0-9]
evince:
  Installed: 3.10.3-0ubuntu10.1
  Candidate: 3.10.3-0ubuntu10.1
  Version table:
 *** 3.10.3-0ubuntu10.1 0
        500 http://gr.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     3.10.3-0ubuntu10 0
        500 http://gr.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
libcairo2:
  Installed: 1.13.0~20140204-0ubuntu1
  Candidate: 1.13.0~20140204-0ubuntu1
  Version table:
 *** 1.13.0~20140204-0ubuntu1 0
        500 http://gr.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
libpoppler44:
  Installed: 0.24.5-2ubuntu4.1
  Candidate: 0.24.5-2ubuntu4.1
  Version table:
 *** 0.24.5-2ubuntu4.1 0
        500 http://gr.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     0.24.5-2ubuntu4 0
        500 http://gr.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

madbiologist (me-again) wrote :

I renamed the file attached to comment #2 to script.pdf and then tried to convert it with ghostscript via this command:

gs -q -dNOPAUSE -dBATCH -sDEVICE=pdfwrite -sOutputFile=unencrypted.pdf -c .setpdfwrite -f script.pdf

I received this warning:

**** This file uses an unknown standard security handler revision: 6
Error: /undefined in pdf_check_password
<snip>
GPL Ghostscript 9.10: Unrecoverable error, exit code 1

This is fixed in ghostscript 9.15 - see http://www.ghostscript.com/doc/9.15/News.htm

Created attachment 111902
PDF file

Originally reported on Ubuntu Vivid as https://bugs.launchpad.net/ubuntu/+source/evince/+bug/1404645 using poppler 0.28.1

Evince 3.14.1-0ubuntu1 (which uses poppler as it's renderer) prompts for a password when opening the attached file. Adobe Reader and Firefox 34's built-in PDF viewer can open the file.

The file has been created by a professor and is about Java programming.

Renaming the file to script.pdf and attempting to convert the file with ghostscript 9.10 via this command:

gs -q -dNOPAUSE -dBATCH -sDEVICE=pdfwrite -sOutputFile=unencrypted.pdf -c .setpdfwrite -f script.pdf

gives this warning:

**** This file uses an unknown standard security handler revision: 6
Error: /undefined in pdf_check_password
<snip>
GPL Ghostscript 9.10: Unrecoverable error, exit code 1

Ghostscript 9.15 now supports the PDF security handler revision 6 - see http://www.ghostscript.com/doc/9.15/News.htm

Perhaps you can reuse the new ghostscript code?

Changed in poppler:
importance: Unknown → Medium
status: Unknown → Confirmed

*** Bug 88151 has been marked as a duplicate of this bug. ***

madbiologist (me-again) wrote :
Changed in poppler:
importance: Medium → Unknown
status: Confirmed → Unknown
Changed in poppler:
importance: Unknown → Medium
status: Unknown → Confirmed
tags: added: wily

@Albert I would like to do "Implement SecurityHandler V6 in Poppler" project. The link to this project is given here https://community.kde.org/GSoC/2015/Ideas#Project:_Implement_SecurityHandler_V6_in_Poppler.

Great, work on it!

Cool.
Could please mentor me in this project? Also, How do I contact you?

If you're speaking about Google Summer of Code, that's not how it works, the application period is not even started.

If you're speaking about answering questions you may have. There's a poppler development mailing list.

I didn't mean GSOC. I am interested in this project and hope to finish it before GSOC application period starts. Actually I have taken this for my course project(B.Tech in IT). Also, I have some experience in open source contribution did for Mozilla and Julia so won't bother much.

OK, I'll use mailing list for this.

Will be fixed in next release.

Changed in poppler:
status: Confirmed → Fix Released
madbiologist (me-again) wrote :

This is fixed in poppler 0.42.0

Ubuntu 16.10 "Yakkety Yak" is scheduled for release on 20th October 2016 and will contain poppler 0.44.0-3ubuntu2

Changed in evince (Ubuntu):
status: Triaged → Fix Committed
Paul White (paulw2u) wrote :

Further to comment #17, file opens ok in Ubuntu 19.10 (dev)
so closing as fixed.

Changed in evince (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.