Tooltips for Next and Previous pages are mixed up

Bug #1318581 reported by TenLeftFingers on 2014-05-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Unassigned

Bug Description

* Impact
The button for the next page shows the tooltip "Previous Page" and vice versa. It's a little confusing :)

* Test Case
- run evince, open a document
- move the mouse over the previous/next buttons, read the tooltip displayed

* Regression potential
the change just inverts wrong labels in the code, it shouldn't create any issue

TenLeftFingers (tenleftfingers) wrote :
summary: - Tooltips for Next and Previous pages are mixed dup
+ Tooltips for Next and Previous pages are mixed up
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, confirming with trusty, that's an error in one of the Ubuntu changeset, I'm going to commit a fix for that and include it in the next update/SRU

Changed in evince (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in evince (Ubuntu):
status: Triaged → Fix Committed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 3.10.3-0ubuntu12

---------------
evince (3.10.3-0ubuntu12) utopic; urgency=medium

  * debian/patches/0001-Port-to-GMenuModel-and-add-menu-bar.patch:
    - use the correct "previous/next page" tooltips (lp: #1318581)

  [ Lars Uebernickel ]
  * restore keybindings that stopped working with the gmenumodel work
    (lp: #1313250, #1310782, #1312179)
 -- Sebastien Bacher <email address hidden> Tue, 03 Jun 2014 16:25:15 +0200

Changed in evince (Ubuntu):
status: Fix Committed → Fix Released

Hello TenLeftFingers, or anyone else affected,

Accepted evince into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/evince/3.10.3-0ubuntu10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

works for me, setting as verification-done

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for evince has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers