evince: show containing folder not working under Lubuntu 14.04

Bug #1290157 reported by ibere fernandes on 2014-03-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Unassigned

Bug Description

open a pdf file.

goto file> open containing folder.

error message appears:
Could not open the containing folder
Failed to execute child process "audacious" (Permission denied)

is it related to bug #1022962 ?

tks,
ibere

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: evince 3.10.3-0ubuntu9
ProcVersionSignature: Ubuntu 3.13.0-16.36-generic 3.13.5
Uname: Linux 3.13.0-16-generic i686
ApportVersion: 2.13.3-0ubuntu1
Architecture: i386
CurrentDesktop: LXDE
Date: Sun Mar 9 21:19:53 2014
InstallationDate: Installed on 2014-03-09 (0 days ago)
InstallationMedia: Lubuntu 14.04 "Trusty Tahr" - Alpha i386 (20140309)
SourcePackage: evince
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

print screen of evince error message.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1290157

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evince (Ubuntu):
status: New → Confirmed
Lyn Perrine (walterorlin) wrote :

I get the same message. I don't know why it would be trying to execute audacious here. Doesn't really make much sense.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that seems an apparmor issue. It's trying to run audacious because you probably made that the default handler for directories...

Changed in evince (Ubuntu):
importance: Undecided → Low

reply to comment #6: in fact it was a clean and fresh install, so my best guess is there's something wrong in the development side.

there were no changes in the default handler for directories on my side (user).

tks,
ibere

Sebastien Bacher (seb128) wrote :

The default software being buggy seems like a lubuntu issue then, apparmor could allow to run audacious from evince but I'm not sure that's the right user experience...

Lyn Perrine (walterorlin) wrote :

Wierd thing is I am not getting it in a live session when I was getting it before from a file in my downloads directory. I had saved some podcasts there. Although in the live seisson the pdf was saved in /tmp.

Changed in evince (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 3.10.3-0ubuntu15

---------------
evince (3.10.3-0ubuntu15) utopic; urgency=medium

  * debian/apparmor-profile:
    - allow site-wide dconf. Thanks to Lars Masden. (LP: #1355804)
    - allow read/write to files we own in /media (LP: #1096837)
    - allow read/write to files we own in /run/user/1000/at-spi2-*
      (LP: #1308488)
    - allow 'l' to /run/user/*/gvfs-metadata/** (LP: #1344810)
    - allow read/write of @{HOME}/.cache/dconf/user (LP: #1024605)
  * debian/apparmor-profile.abstraction:
    - allow read of /etc/xdg/lubuntu/applications/defaults.list (LP: #1290157,
      LP: #1299239)
    - allow read of /**.[eE][pP][sS][fFiI23] (LP: #1330430)
 -- Jamie Strandboge <email address hidden> Tue, 12 Aug 2014 14:30:43 -0500

Changed in evince (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers