some shortcuts stopped working

Bug #1290104 reported by Masoud Abkenar on 2014-03-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Lars Karlitski

Bug Description

Ctrl+PgUp / Ctrl+PgDn: for scrolling to the TOP of the previous / next page of the document.

Ctrl++ / Ctrl+-: for zooming in / zooming out.

BTW: HUD also doesn't work. HUD shows the entries, but selecting the action in HUD has no effect.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: evince 3.10.3-0ubuntu9
ProcVersionSignature: Ubuntu 3.13.0-16.36-generic 3.13.5
Uname: Linux 3.13.0-16-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Mar 9 20:36:27 2014
InstallationDate: Installed on 2014-02-15 (21 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140211)
SourcePackage: evince
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Masoud Abkenar (mabkenar) wrote :
Sebastien Bacher (seb128) wrote :

Thanks, I can confirm that. Lars, could you have a look? I guess it has to do with the gmenu changes

Changed in evince (Ubuntu):
assignee: nobody → Lars Uebernickel (larsu)
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

(the HUD issue is bug #1288025)

Lars Karlitski (larsu) on 2014-03-11
Changed in evince (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 3.10.3-0ubuntu10

---------------
evince (3.10.3-0ubuntu10) trusty; urgency=medium

  [ Lars Uebernickel ]
  * debian/patches/gtk310-secondary-keybindings.patch:
    - get multiple keybindings to work with gtk 3.10 (lp: #1290104)
  * debian/patches/0001-Port-to-GMenuModel-and-add-menu-bar.patch:
    "gmenumodel patch: restore zoom selector popup.
     It got deleted by accident in the last commit. (lp: #1289180)
 -- Sebastien Bacher <email address hidden> Tue, 11 Mar 2014 18:40:10 +0100

Changed in evince (Ubuntu):
status: In Progress → Fix Released
Masoud Abkenar (mabkenar) wrote :

Except one issue, I can confirm that the shortcuts are back. Thank you :)

And this is the remaining issue: Previously, the shortcut for zooming in was "Ctrl++". Now, for the same functionality you should press "Ctrl+Shift++". OK, literally speaking, the "+" key always means "Shift+=". But the shortcut was never like this before.

In Firefox, for example, both "Ctrl++" and "Ctrl+shift++" work. It is actually more convenient to use the former rather than the latter, since you don't have to hold one extra key.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers