evince rotion bug with postscript files

Bug #1256414 reported by JMB on 2013-11-29
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
High
Unassigned

Bug Description

Hi,

I ran in a problem with the final version of Xubuntu Saucy Salamander
(the flavour should not decisive in this case ... just for clarification).

evince is not able to render a side-viewed document (1x rotation left/right),
while 2x rotation (i.e. upside-down) works.
gv as well as okula both don't have any problem with rotation und 13.10 -
the same is true for evince in Xubuntu 13.04 (when started as workaround for
a known problem with `LANG=en_US evince').

Output:
evince mydocument.ps
(evince:3776): EvinceDocument-CRITICAL **: ev_document_get_n_pages: assertion 'EV_IS_DOCUMENT (document)' failed

(evince:3776): Gdk-CRITICAL **: gdk_pixbuf_get_from_surface: assertion 'width > 0 && height > 0' failed
(evince:3776): Gtk-WARNING **: drawing failure for widget `EvView': invalid matrix (not invertible)

(evince:3776): Gtk-WARNING **: drawing failure for widget `EvView': invalid matrix (not invertible)

Many thanks for your help - a fix or at least workaround for 13.10 would
be much appreciated.

Regards,

JMB

P.S.:
lsb_release -rd
  Description: Ubuntu 13.10
  Release: 13.10
  # final Xubuntu 13.10 Saucy Salamander
apt-cache policy evince
evince:
  Installed: 3.10.0-0ubuntu2
  Candidate: 3.10.0-0ubuntu2
  Version table:
 *** 3.10.0-0ubuntu2 0
        500 http://de.archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: evince 3.10.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.11.0-13.20-generic 3.11.6
Uname: Linux 3.11.0-13-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
Date: Fri Nov 29 19:51:24 2013
InstallationDate: Installed on 2013-10-17 (42 days ago)
InstallationMedia: Xubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016)
MarkForUpload: True
SourcePackage: evince
UpgradeStatus: No upgrade log present (probably fresh install)

JMB (jmb-tux) wrote :
tags: added: trusty
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evince (Ubuntu):
status: New → Confirmed
Sergio Benjamim (sergio-br2) wrote :

I can reproduce with this post script: accelconf.web.cern.ch/accelconf/jacow/templates/sample.ps‎

Steps to reproduce:

1. open the document with Evince
2. Click in the gear button, then Rotate Left, it's not possible see the document
3. Rotate Left again, then the document will be render by Evince, upside down

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1256414

tags: added: package-qa-testing
Sergio Benjamim (sergio-br2) wrote :

I can confirm with version 3.10.3-0ubuntu4, now it has menu:

1. open the document with Evince
2. Click "Edit --> Rotate Left" menu, it's not possible see the document
3. Rotate Left again, then the document will be render by Evince, upside down

Changed in evince (Ubuntu):
importance: Undecided → High
JMB (jmb-tux) wrote :

As the bug is still present in 14.04 LTS final is there any solution in reach?

Ubfan (ubfan1) wrote :

Yes, this bug is still present in 14.04 as of July 4, 2014. a2ps output 2 up will print, but not display until rotated (left or right) once, whereupon it looks like the page portrait view (two pages on their sides).

JMB, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please provide an example document that demonstrates this problem?

Changed in evince (Ubuntu):
status: Confirmed → Incomplete
JMB (jmb-tux) wrote :

Thanks for the reminder.
I can confirm that with the current Xubuntu 14.04.1 LTS,
evince 3.10.3 has no longer rendering problems when
rotating a document.

While this is nice, it looks to me as it was solved by chance.
I think to improve a distro users should get the impression
that bugs are cared for and solutions are actively looked for.
When I as an experienced sytsem administrator fight to stay
motivated reporting bugs (which is the case, unfortunately),
there is a problem.

Ubuntu needs the desktop - and with Unity and its still lacking
configuration options, the little care for even the LTS project
and the current focus this is not the right attitude.

Ubuntu/Debian and derivatives may still be the best desktop
solution - but in former times the product was more stable
and functional than today - despite the enormous advancements.

The bug can be closed - but the bug tracking can be shown to
not be effective just with this little (and boring) example.

JMB

"Without feedback, you cannot learn." -- Richard M. Stallman

Changed in evince (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers