EvinceDocument-CRITICAL **: ev_document_get_n_pages: assertion 'EV_IS_DOCUMENT (document)' failed

Bug #1247208 reported by Angel Guzman Maeso on 2013-11-01
54
This bug affects 12 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
evince (Ubuntu)
High
Unassigned

Bug Description

This is not a dupe of #1191692.

Generating a simple pdf with python and reportlab I get always the same warning opening in evince:

EvinceDocument-CRITICAL **: ev_document_get_n_pages: assertion 'EV_IS_DOCUMENT (document)' failed

The document has only 1 page, so if evince cannot properly get the number of pages with ev_document_get_n_pages, this should be a valid bug or remove the warning and report 0 pages instead.

I think that the macro EV_IS_DOCUMENT is failing in some point for detect the document mode or it is not supported. If that macro fails, should report why is not considered a valid document.

I attach a fully example python 2.7 script file for reproduce the problem with reportlab, and the pdf file generated for reproduce the problem.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: evince 3.10.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.8.0-13.23-generic 3.8.3
Uname: Linux 3.8.0-13-generic i686
NonfreeKernelModules: fglrx
ApportVersion: 2.12.6-0ubuntu1
Architecture: i386
Date: Fri Nov 1 18:25:26 2013
InstallationDate: Installed on 2013-02-03 (271 days ago)
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
MarkForUpload: True
SourcePackage: evince
UpgradeStatus: Upgraded to trusty on 2013-10-31 (1 days ago)

Angel Guzman Maeso (shakaran) wrote :
Angel Guzman Maeso (shakaran) wrote :

Upstream bug filled in gnome's bugzilla https://bugzilla.gnome.org/show_bug.cgi?id=711266

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evince (Ubuntu):
status: New → Confirmed
Changed in evince (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
importance: Undecided → High
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

the issue has been fixed in trusty and was due to a change applied upstream and still downstream as distro one
https://launchpad.net/ubuntu/+source/evince/3.10.0-0ubuntu3

Changed in evince (Ubuntu):
status: Confirmed → Fix Released
Paul White (paulw2u) wrote :

Closing as issue fixed some time ago.

Changed in hundredpapercuts:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.