[gutsy] evince-gtk depends on libgnome

Bug #121871 reported by Lionel Le Folgoc on 2007-06-23
6
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
High
Lionel Le Folgoc

Bug Description

Binary package hint: evince-gtk

Hi,

The current (0.9.1-0ubuntu1) version in gutsy is linked to libgnome, which is not correct.

$ apt-cache depends evince-gtk
evince-gtk
  [...]
  Depends: libgnome2-0
  Depends: libgnomecanvas2-0
  Depends: libgnomeui-0
  Depends: libgnomevfs2-0
  [...]

Thanks.

Related branches

Changed in evince-gtk:
assignee: nobody → mrpouit
importance: Undecided → Medium
status: New → Incomplete
Lionel Le Folgoc (mrpouit) wrote :

Oops, the source package is now evince, not evince-gtk.

Changed in evince:
assignee: mrpouit → xubuntu-team
status: Incomplete → Confirmed
Lionel Le Folgoc (mrpouit) wrote :

It seems that's because of gnome-vfs2.
All gnome-vfs2 calls/includes have to be moved between #ifdef WITH_GNOME / #endif, and replaced with a gtk/thunar-vfs equivalent (which probably doesn't exist).
So that's not very trivial.

Lionel Le Folgoc (mrpouit) wrote :

Jani, are you already working on it? If not, I'll work on it then.

Changed in evince:
status: Confirmed → In Progress
Jani Monoses (jani) wrote :

this is an upstream patch, based on the one I ortiginally submitted to evince log ago but dos keeps the gnomevfs deps
I think we could add an ubuntu patch to it that should not be hard, now that upstream has --disable-gnome and
both binaries buiold form the same source package.
If you feel like it please look at such a patch, originally with noops for gnome-vfs, we'll see in the future if a thunar
version is warranted.

Changed in evince:
assignee: xubuntu-team → mrpouit
Changed in evince:
assignee: mrpouit → nobody
status: In Progress → Triaged
Changed in evince:
assignee: nobody → mrpouit
importance: Medium → High
status: Triaged → In Progress
Lionel Le Folgoc (mrpouit) wrote :

This is bug caused by the changes made to fix the Bug #118931: the --sourcedir options have been removed, therefore dh_install doesn't know where to pick the file. It picks them from DEB_DESTDIR for both variants instead of using DEB_DESTDIR_evince-gtk for evince-gtk.

Calling dh_install -pevince --sourcedir=$(DEB_DESTDIR) and dh_install -pevince-gtk --sourcedir=$(DEB_DESTDIR_evince-gtk) in the binary-install/evince{,-gtk}:: rules should fix this (it reintroduces the gconf schemas registration bug though).

Subscribing Sebastien to have his opinion.

Changed in evince:
assignee: mrpouit → nobody
status: In Progress → Confirmed
Albin Tonnerre (lutin) wrote :

Hi,
here is a debdiff proposal that should fix the issue
Cheers

Lionel Le Folgoc (mrpouit) wrote :

Thanks, I'll upload it as soon as the freeze is over.

Changed in evince:
assignee: nobody → mrpouit
status: Confirmed → In Progress
Albin Tonnerre (lutin) wrote :

evince (0.9.3-0ubuntu2) gutsy; urgency=low

  * debian/rules:
    - use DEB_DESTDIR=debian/tmp/evince{,gtk} for evince{,gtk} so that the right
      files go in evince-gtk, instead of being copied from evince. (LP: #121871)
    - Move DEB_DESTDIR declaration after the includes so that it's not overriden
  * debian/evince{,gtk}.install.disabled: Make them work with the changes

 -- Albin Tonnerre <email address hidden> Tue, 21 Aug 2007 21:27:47 +0200

Changed in evince:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers