Annotation Font-Color is unreadable in Evince

Bug #1100320 reported by theghost on 2013-01-16
64
This bug affects 41 people
Affects Status Importance Assigned to Milestone
Evince
Fix Released
Wishlist
evince (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

* Impact:
notes added to pdfs are hard to read

* Test Case:

0. Select one of the Ubuntu themes
1. Open a PDF with Evince
2. Try to add an annotation
3. Write some text within the annotation

Expected to Happen:

The annotation font color is black, so that is readable on white background.

What happens instead:

The color is yellow, so that all written text is unreadable.

* Regression potential:
watch for the text's color of pdf notes

theghost (theghost) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-themes (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that's an evince bug, report upstream on https://bugzilla.gnome.org/show_bug.cgi?id=692450

affects: light-themes (Ubuntu) → evince (Ubuntu)
Changed in evince (Ubuntu):
importance: Undecided → Low
status: Confirmed → In Progress
Changed in evince (Ubuntu Precise):
importance: Undecided → Low
status: New → Triaged
Changed in evince:
importance: Unknown → Wishlist
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 3.6.1-1ubuntu2

---------------
evince (3.6.1-1ubuntu2) raring; urgency=low

  * debian/patches/workaround_notes_color_issue.patch:
    - don't define a color for the text of annotations otherwise we end
      up with yellow text on white background which is difficult to read
      (lp: #1100320)
 -- Sebastien Bacher <email address hidden> Fri, 25 Jan 2013 15:15:48 +0100

Changed in evince (Ubuntu):
status: In Progress → Fix Released
Changed in evince:
status: New → Fix Released
Florian Echtler (floe) wrote :

Will this be backported to precise?

Florian Echtler (floe) wrote :

Here's a patch for this issue, backported from 3.6.1 to 3.4.0-0ubuntu1.4, the current package in Precise.

Sebastien Bacher (seb128) wrote :

Thanks, there is an upload in the queue:
http://launchpadlibrarian.net/129345340/evince_3.4.0-0ubuntu1.5_source.changes

that should go in proposed, if possible, before a new version is uploaded

description: updated
Changed in evince (Ubuntu Precise):
status: Triaged → In Progress

Hello TheGhost, or anyone else affected,

Accepted evince into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/evince/3.4.0-0ubuntu1.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in evince (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Till W. (tillw.) wrote :

Hi everyone!

I am using the "Ambiance" GTK theme and was affected by this bug. I have Ubuntu 12.04.2 LTS installed on an AMD64 machine.
I just downloaded and installed the following packages (with dpkg -i):

evince_3.4.0-0ubuntu1.6_amd64.deb (md5sum: bb2e9efd4c8a20b29f2c054e43cda8d7)
evince-common_3.4.0-0ubuntu1.6_all.deb (md5sum: 3cea48dba3415a523b06449daec9c1dd)
libevince3-3_3.4.0-0ubuntu1.6_amd64.deb (md5sum: beed3be2fbebadb22e966a9a7e10fe04)

The text in the annotation popup notes is now black on white background and is therefore perfectly readable. The issue is fixed for me.

"Thank you" to everyone involved in fixing this!

tags: added: verification-done
removed: verification-needed
theghost (theghost) wrote :

What about Quantal ? I filed the bug originally for 12.10. It seems fixed for 12.04 + 13.04. But Quantal is also supported until April 2014.

Sebastien Bacher (seb128) wrote :

quantal is a nonLTS and we tend to fix only a limited of cosmetic issues on those, due to manpower limitation (you are welcome to help though if you really care about that issue to be fixed in quantal)

Florian Echtler (floe) wrote :

I'm pretty sure the patch should also apply cleanly for the quantal package.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 3.4.0-0ubuntu1.6

---------------
evince (3.4.0-0ubuntu1.6) precise; urgency=low

  * debian/patches/git_notes_text_color.patch:
    - don't define a color for the text of annotations otherwise we end
      up with yellow text on white background which is difficult to read
      (lp: #1100320)
 -- Sebastien Bacher <email address hidden> Thu, 07 Mar 2013 12:01:05 +0100

Changed in evince (Ubuntu Precise):
status: Fix Committed → Fix Released

This bug affects me and I'm using Ubuntu 18.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.