Evince can not print certain PDF documents

Bug #1032537 reported by Giulio Malventi on 2012-08-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cairo (Ubuntu)
Undecided
Unassigned
evince (Ubuntu)
Undecided
Unassigned

Bug Description

Printing of the attached document resulted in blank pages on two different machines running 12.04 with different printers. Printed normally with Adobe reader.
In case it is of any use, the print preview works if multiple pages per sheet are selected.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: evince 3.4.0-0ubuntu1.3
ProcVersionSignature: Ubuntu 3.2.0-27.43-generic 3.2.21
Uname: Linux 3.2.0-27-generic i686
ApportVersion: 2.0.1-0ubuntu11
Architecture: i386
Date: Fri Aug 3 10:15:44 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
KernLog:

SourcePackage: evince
UpgradeStatus: Upgraded to precise on 2012-06-07 (57 days ago)

Giulio Malventi (giulio-people) wrote :
Felix Möller (felix-derklecks) wrote :

I tried to print your file with evince on my 12.04 installation and had no problems.

Is this an evince problem? I think cups, cups-filters, or cairo might be involved as well.

Can you print it to PDF? Which printers are you using? Which CUPS drivers do they use?

Felix Möller (felix-derklecks) wrote :

Oops I meant to say I printed on my 12.10 installation...

Till Kamppeter (till-kamppeter) wrote :

I have tested the attached file with both Quantal (12.10) and Precise (12.04). In Quantal all is OK, in Precise the problem is in evince or in Cairo, as if I choose "Print to file" in the print dialog I get only blank pages in the output.pdf file.

I will close this now as it is fixed in 12.10. Please add a Precise task if you want to have a fix for Precise.

affects: cups (Ubuntu) → libcairo (Ubuntu)
Changed in libcairo (Ubuntu):
status: New → Fix Released
Changed in evince (Ubuntu):
status: New → Fix Released
Giulio Malventi (giulio-people) wrote :

Ok to close for me, thanks.

Tyson Williams (bender2k14) wrote :

@Till I would like a fix for Precise (12.04). Is there a workaround I could use?

Mathew Hodson (mhodson) on 2014-12-08
affects: libcairo (Ubuntu) → cairo (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers