Thumbnails sidepane cannot be shrunk once it has been enlarged

Bug #1021153 reported by Kim Nguyễn on 2012-07-05
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Undecided
Unassigned
Precise
High
Unassigned

Bug Description

When one elarges the thumbnail sidepane horizontally, (s)he cannot shrink it down to a smaller size:

steps to reproduce:

- open a pdf in evince with sufficiently many pages (say 3).
- Make the Thumbnail sidepane visible. Originally it should display one column with the three pages
- Hold the pane separator and drag to the right. When the pane is sufficiently wide, the content might (it does not
always do it...) reflow to show two columns and then three columns. If the thumbnails are not reflowed, just hit ctrl-r
to force a redraw.

- Try to shrink the sidepane to its original size. This cannot be done anymore (and if gvfs is installed, then the state of
evince UI is kept as metadata for the *file* and you need command line hackery to reset it, see the upstream bugreport).

What should happen instead:
I should be able to freely resize the side pane until it reaches its minimal width of 1 column.

Additional informations:
evince version: 3.4.0-0ubuntu1.1
ubuntu release: precise (12.04)
uname -a: Linux tartufo 3.2.0-26-generic #41-Ubuntu SMP Thu Jun 14 17:49:24 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evince (Ubuntu):
status: New → Confirmed
Chris J Arges (arges) wrote :

Attached is a video showing what happens.

Changed in evince (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → High
Chris J Arges (arges) wrote :

This appears to be working in Quantal and Raring.

Changed in evince (Ubuntu):
status: Confirmed → Fix Released
affects: evince (Ubuntu Precise) → gtk+3.0 (Ubuntu Precise)
aaron (nelaaro) wrote :

It would be nice to have a link to the upstream bug report and the command line trickery used to fix this for those who are still sitting with out a updated patched version.

aaron (nelaaro) wrote :

This is what I found

Debian Bug report logs - #429687
evince: Thumbnails get too wide

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=429687

affects: gtk+3.0 (Ubuntu) → ubuntu
affects: ubuntu → evince (Ubuntu)
affects: evince (Ubuntu) → gtk+3.0 (Ubuntu)
Ritesh Khadgaray (khadgaray) wrote :

commit 5a3601d1ccfc1adf3f91e60f6de27e3ee1a5c6a2
Author: Carlos Garcia Campos <email address hidden>
Date: Sun Jul 29 15:18:16 2007 +0000

Set horizontal scrollbar policy to AUTOMATIC instead of NEVER. Workaround

2007-07-29 Carlos Garcia Campos <email address hidden>
        * shell/ev-sidebar-thumbnails.c: (ev_sidebar_thumbnails_init):
        Set horizontal scrollbar policy to AUTOMATIC instead of
        NEVER. Workaround for bug #449462.

Ritesh Khadgaray (khadgaray) wrote :

[Impact]
 * Evince's "Thumbnails" side-bar cannot be minimized once you've expanded it to a point where 2 or more columns of page previews are shown.

[Test Case]
1. Open Evince.
2. Open a PDF document with multiple pages.
3. Move the side-bar border to the point where multiple pages will fit in one row.
4. Close and re-open Evince.
5. Attempt to move the side-bar border back to the left.

[Regression Potential]
 * n/a

[Other Info]

 * Upstream issue - https://bugzilla.gnome.org/show_bug.cgi?id=449462

Sebastien Bacher (seb128) wrote :

sponsored

affects: gtk+3.0 (Ubuntu) → ubuntu
Steve Langasek (vorlon) wrote :

The patch used for fixing this claims to be from 2007. Obviously, the evince in precise is much newer than that. Could someone please explain why a 6 year old patch is somehow the correct fix for a bug in a one-year-old release?

affects: Ubuntu Precise → evince (Ubuntu Precise)
Changed in evince (Ubuntu Precise):
status: In Progress → Incomplete

Hello Kim, or anyone else affected,

Accepted evince into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/evince/3.4.0-0ubuntu1.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in evince (Ubuntu Precise):
status: Incomplete → Fix Committed
tags: added: verification-needed
Ritesh Khadgaray (khadgaray) wrote :

Hi Steve

  The fix is a workaround for a bug in gtk. This was added to evince but later removed ,since the bug was fixed in gtk.

-- ritz

Ritesh Khadgaray (khadgaray) wrote :

Hi Steve

  Thanks. This fixes the issue on my system.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 3.4.0-0ubuntu1.7

---------------
evince (3.4.0-0ubuntu1.7) precise; urgency=low

  * debian/patches/git_sidebar_thumbnails.patch:
    - Thumbnails sidepane cannot be shrunk once it has been enlarged (lp: #1021153)
 -- Ritesh Khadgaray <email address hidden> Wed, 03 Jul 2013 21:10:45 +0530

Changed in evince (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.