evince 3.5.3 fails to upgrade

Bug #1018543 reported by Linuxexperte on 2012-06-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
High
Jeremy Bicha

Bug Description

I just did the current update and upgrade at 20:53 CET and got this error-message about empathy:

andrea@andrea-CR500:~$ sudo apt-get dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete werden ENTFERNT:
  libevince3-3
Die folgenden NEUEN Pakete werden installiert:
  libevdocument3-4 libevview3-3 libgxps2
Die folgenden Pakete werden aktualisiert (Upgrade):
  evince
1 aktualisiert, 3 neu installiert, 1 zu entfernen und 0 nicht aktualisiert.
Es müssen 641 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 534 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]? J
Holen: 1 http://archive.ubuntu.com/ubuntu/ quantal/main libgxps2 amd64 0.2.2-2 [50,5 kB]
Holen: 2 http://archive.ubuntu.com/ubuntu/ quantal-proposed/main libevdocument3-4 amd64 3.5.3-0ubuntu3 [265 kB]
Holen: 3 http://archive.ubuntu.com/ubuntu/ quantal-proposed/main evince amd64 3.5.3-0ubuntu3 [210 kB]
Holen: 4 http://archive.ubuntu.com/ubuntu/ quantal-proposed/main libevview3-3 amd64 3.5.3-0ubuntu3 [115 kB]
Es wurden 641 kB in 2 s geholt (270 kB/s).
Vormals nicht ausgewähltes Paket libgxps2:amd64 wird gewählt.
(Lese Datenbank ... 293592 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacken von libgxps2:amd64 (aus .../libgxps2_0.2.2-2_amd64.deb) ...
Vormals nicht ausgewähltes Paket libevdocument3-4 wird gewählt.
Entpacken von libevdocument3-4 (aus .../libevdocument3-4_3.5.3-0ubuntu3_amd64.deb) ...
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libevdocument3-4_3.5.3-0ubuntu3_amd64.deb (--unpack):
 Versuch, »/usr/lib/evince/4/backends/comicsdocument.evince-backend« zu überschreiben, welches auch in Paket libevince3-3 3.5.3-0ubuntu1 ist
Es wurde kein Apport-Bericht verfasst, da das Limit MaxReports bereits erreicht ist.
    dpkg-deb: Fehler: Unterprozess einfügen wurde durch Signal (Datenübergabe unterbrochen (broken pipe)) getötet
Vorbereitung zum Ersetzen von evince 3.5.3-0ubuntu1 (durch .../evince_3.5.3-0ubuntu3_amd64.deb) ...
Ersatz für evince wird entpackt ...
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/libevdocument3-4_3.5.3-0ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
andrea@andrea-CR500:~$ sudo apt-get -f install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  gir1.2-gtop-2.0 libboost-program-options1.49.0 libegl1-mesa
  libegl1-mesa-drivers libgbm1 libopenjpeg2 libopenvg1-mesa libpoppler25
  libwayland0 libx264-120 libxcb-xfixes0 python-gmenu python3-xkit
Use 'apt-get autoremove' to remove them.
Die folgenden zusätzlichen Pakete werden installiert:
  libevdocument3-4 libevview3-3
Die folgenden Pakete werden ENTFERNT:
  libevince3-3
Die folgenden NEUEN Pakete werden installiert:
  libevdocument3-4 libevview3-3
0 aktualisiert, 2 neu installiert, 1 zu entfernen und 0 nicht aktualisiert.
2 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 380 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 446 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]? J
(Lese Datenbank ... 293601 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacken von libevdocument3-4 (aus .../libevdocument3-4_3.5.3-0ubuntu3_amd64.deb) ...
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libevdocument3-4_3.5.3-0ubuntu3_amd64.deb (--unpack):
 Versuch, »/usr/lib/evince/4/backends/comicsdocument.evince-backend« zu überschreiben, welches auch in Paket libevince3-3 3.5.3-0ubuntu1 ist
Es wurde kein Apport-Bericht verfasst, da das Limit MaxReports bereits erreicht ist.
    dpkg-deb: Fehler: Unterprozess einfügen wurde durch Signal (Datenübergabe unterbrochen (broken pipe)) getötet
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/libevdocument3-4_3.5.3-0ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
andrea@andrea-CR500:~$

The important part of the error-code is this one:
unpacking libevincedocument3-4(from.../libevincedocument3-4_3.5.3-0ubuntu3_amd64.deb (--unpack):
Try to overwrite /usr/lib/evince/4/backaneds/comicsdocument.evince-backends, which is also in the package libevince3-3_3.5.3-0ubuntu1
no apport-report has been created, because the maxlimit is already reached
     dpkg-deb: error: subprocess input killed through signal (datatransferring interrupted (broken pipe))
errors occured at working on
/var/cache/apt/archives/libevincedocument3-4_3.5.3-0ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
andrea@andrea-CR500:~$

This shows, that the Software-Updater wants to overwrite /usr/lib/evince/4/backends/comicsdocument.evince-backends, which is also in the package libevince 3-3 3.5.3-0ubuntu1. And this leads to an error code, so that the upgrade of evince fails
This needs to be fixed!!!

Changed in evince (Ubuntu):
assignee: nobody → Jeremy Bicha (jbicha)
Linuxexperte (andrea-koeth) wrote :

hi Jeremy,

I found out something, what might perhaps interest you:

I think, I found a possible reason for this error. Because the error resolved, after I uninstalled evince completely through Synaptic and then it removed the package libevince3-3 and installed libevview3-3 instead. And since then, this error did not return anymore. Perhaps it is possible, that this package libevince3-3 is no longer needed, because libevview 3-3 took over??? Can this be a thing??

Can you try to reproduce this error throug the following way:

just open the Software-Updater in Gnome-Shell 3.5 and fetch the upgrade.

Does ist tell you the same error then?? And then close this and go to the Terminal and try the following commands:

sudo apt-get update && and sudo apt-get dist-upgrade

Then it brings up this error. Then it suggest to use the command -f

So I did that, but the error came again. So I closed Terminal ans went to Synaptic and opened it. Then I uninstalled evince completely and re-installed it and this seems to resolve this by removeing libevince3-3 and replacing it with libevview 3-3.

Can you check this for me please if the same thing happenes for you??

Greetings
Linuxexperte

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evince (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2012-06-27
Changed in evince (Ubuntu):
status: Confirmed → In Progress
summary: - evince fails to upgrade in GNome-shell 3.5
+ evince 3.5.3 fails to upgrade
Sebastien Bacher (seb128) wrote :

the fix is in quantal-proposed, will be moved to quantal after the a2 freeze lifting today

Changed in evince (Ubuntu):
importance: Undecided → High
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 3.5.3-0ubuntu4

---------------
evince (3.5.3-0ubuntu4) quantal-proposed; urgency=low

  * Add missing Breaks/Replaces against libevince3-3 (LP: #1018543)
 -- Jeremy Bicha <email address hidden> Wed, 27 Jun 2012 17:49:00 -0400

Changed in evince (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers