Oneiric Eucalyptus fails to start up

Bug #791607 reported by C de-Avillez on 2011-06-01
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
High
Clint Byrum
Oneiric
High
Clint Byrum

Bug Description

Release of Ubuntu: 11.10 Alpha1
Package Version:
Expected Results: after install Eucalyptus successfully starts.
ii eucalyptus-admin-tools 2.0.1+bzr1256-0ubuntu6
ii eucalyptus-cc 2.0.1+bzr1256-0ubuntu6
ii eucalyptus-cloud 2.0.1+bzr1256-0ubuntu6
ii eucalyptus-common 2.0.1+bzr1256-0ubuntu6
ii eucalyptus-gl 2.0.1+bzr1256-0ubuntu6
ii eucalyptus-java-common 2.0.1+bzr1256-0ubuntu6
ii eucalyptus-sc 2.0.1+bzr1256-0ubuntu6
ii eucalyptus-walrus 2.0.1+bzr1256-0ubuntu6

Actual Results:

18:39:59 INFO [Bootstrap:main] :1306967999741:Bootstrap:BOOTSTRAP_STAGE_COMPLETE:UnprivilegedConfiguration:SystemBootstrapper.load.127
18:39:59 INFO [Bootstrap:main] :1306967999742:Bootstrap:BOOTSTRAP_STAGE_AGENDA:SystemCredentialsInit:LOAD:Bootstrap.load.91
18:39:59 INFO [Bootstrap:main] :1306967999742:Bootstrap:BOOTSTRAP_STAGE_AGENDA:SystemCredentialsInit:com.eucalyptus.auth.SystemCredentialProvider:Bootstrap.load.91
18:39:59 INFO [Bootstrap:main] :1306967999742:Bootstrap:BOOTSTRAP_STAGE_AGENDA:SystemCredentialsInit:com.eucalyptus.configurable.PropertiesBootstrapper:Bootstrap.load.91
18:39:59 INFO [Bootstrap:main] :1306967999742:Bootstrap:BOOTSTRAPPER_LOAD:SystemCredentialsInit:com.eucalyptus.auth.SystemCredentialProvider:SystemBootstrapper.load.129
18:40:00 INFO [Bootstrap:main] :1306968000203:Bootstrap:BOOTSTRAPPER_LOAD:SystemCredentialsInit:com.eucalyptus.configurable.PropertiesBootstrapper:SystemBootstrapper.load.129
18:40:00 WARN [ConfigurationProperties:main] java.io.FileNotFoundException: /etc/eucalyptus/cloud.d/conf/system.properties (Permission denied)
java.io.FileNotFoundException: /etc/eucalyptus/cloud.d/conf/system.properties (Permission denied)
        at java.io.FileOutputStream.open(Native Method)
        at java.io.FileOutputStream.<init>(FileOutputStream.java:209)
        at java.io.FileOutputStream.<init>(FileOutputStream.java:160)
        at java.io.FileWriter.<init>(FileWriter.java:90)
        at com.eucalyptus.configurable.ConfigurationProperties.store(ConfigurationProperties.java:130)
        at com.eucalyptus.configurable.ConfigurationProperties.configure(ConfigurationProperties.java:32)
        at com.eucalyptus.configurable.ConfigurationProperties.doConfiguration(ConfigurationProperties.java:148)
        at com.eucalyptus.configurable.PropertiesBootstrapper.load(PropertiesBootstrapper.java:16)
        at com.eucalyptus.bootstrap.Bootstrap$Stage.load(Bootstrap.java:95)
        at com.eucalyptus.bootstrap.SystemBootstrapper.load(SystemBootstrapper.java:129)
18:40:00 INFO [Bootstrap:main] :1306968000207:Bootstrap:BOOTSTRAPPER_ERROR:SystemCredentialsInit:com.eucalyptus.configurable.PropertiesBootstrapper:SystemBootstrapper.load.129
18:40:00 FATAL [Bootstrap$Stage:main] Fatal error occured during bootstrap: com.eucalyptus.bootstrap.Bootstrap$Stage.load:101
java.lang.UnsupportedOperationException
        at com.google.common.collect.ImmutableMap.put(ImmutableMap.java:261)
        at com.eucalyptus.configurable.ConfigurationProperties.configure(ConfigurationProperties.java:66)
        at com.eucalyptus.configurable.ConfigurationProperties.doConfiguration(ConfigurationProperties.java:148)
        at com.eucalyptus.configurable.PropertiesBootstrapper.load(PropertiesBootstrapper.java:16)
        at com.eucalyptus.bootstrap.Bootstrap$Stage.load(Bootstrap.java:95)
        at com.eucalyptus.bootstrap.SystemBootstrapper.load(SystemBootstrapper.java:129)
18:40:00 ERROR [BootstrapException:main] Fatal error occured: com.eucalyptus.bootstrap.BootstrapException.fatal:54
java.lang.UnsupportedOperationException
        at com.google.common.collect.ImmutableMap.put(ImmutableMap.java:261)
        at com.eucalyptus.configurable.ConfigurationProperties.configure(ConfigurationProperties.java:66)
        at com.eucalyptus.configurable.ConfigurationProperties.doConfiguration(ConfigurationProperties.java:148)
        at com.eucalyptus.configurable.PropertiesBootstrapper.load(PropertiesBootstrapper.java:16)
        at com.eucalyptus.bootstrap.Bootstrap$Stage.load(Bootstrap.java:95)
        at com.eucalyptus.bootstrap.SystemBootstrapper.load(SystemBootstrapper.java:129)
18:40:00 ERROR [Exceptions:main] java.lang.UnsupportedOperationException
java.lang.UnsupportedOperationException
        at com.google.common.collect.ImmutableMap.put(ImmutableMap.java:261)
        at com.eucalyptus.configurable.ConfigurationProperties.configure(ConfigurationProperties.java:66)
        at com.eucalyptus.configurable.ConfigurationProperties.doConfiguration(ConfigurationProperties.java:148)
        at com.eucalyptus.configurable.PropertiesBootstrapper.load(PropertiesBootstrapper.java:16)
        at com.eucalyptus.bootstrap.Bootstrap$Stage.load(Bootstrap.java:95)
        at com.eucalyptus.bootstrap.SystemBootstrapper.load(SystemBootstrapper.java:129)

Related branches

C de-Avillez (hggdh2) on 2011-06-01
description: updated
tags: added: iso-testing
Scott Moser (smoser) on 2011-06-09
Changed in eucalyptus (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Dave Walker (davewalker) on 2011-07-06
tags: added: server-o-ors
Dave Walker (davewalker) on 2011-07-07
tags: added: server-o-rs
removed: server-o-ors

Currently discussing issue with upstream eucalyptus.

Dave Walker (davewalker) on 2011-07-15
Changed in eucalyptus (Ubuntu):
milestone: none → oneiric-alpha-3
Changed in eucalyptus (Ubuntu Oneiric):
assignee: nobody → Ubuntu Server Team (ubuntu-server)
Changed in eucalyptus (Ubuntu Oneiric):
milestone: oneiric-alpha-3 → ubuntu-11.10-beta-1
Clint Byrum (clint-fewbar) wrote :

Just an FYI, this is still present as of right now. Same error...

16:04:31 FATAL [Bootstrap$Stage:main] Fatal error occured during bootstrap: com.eucalyptus.bootstrap.Bootstrap$Stage.load:101
java.lang.UnsupportedOperationException
 at com.google.common.collect.ImmutableMap.put(ImmutableMap.java:261)
 at com.eucalyptus.configurable.ConfigurationProperties.configure(ConfigurationProperties.java:66)
 at com.eucalyptus.configurable.ConfigurationProperties.doConfiguration(ConfigurationProperties.java:148)
 at com.eucalyptus.configurable.PropertiesBootstrapper.load(PropertiesBootstrapper.java:16)
 at com.eucalyptus.bootstrap.Bootstrap$Stage.load(Bootstrap.java:95)
 at com.eucalyptus.bootstrap.SystemBootstrapper.load(SystemBootstrapper.java:129)
16:04:31 ERROR [BootstrapException:main] Fatal error occured: com.eucalyptus.bootstrap.BootstrapException.fatal:54
java.lang.UnsupportedOperationException
 at com.google.common.collect.ImmutableMap.put(ImmutableMap.java:261)
 at com.eucalyptus.configurable.ConfigurationProperties.configure(ConfigurationProperties.java:66)
 at com.eucalyptus.configurable.ConfigurationProperties.doConfiguration(ConfigurationProperties.java:148)
 at com.eucalyptus.configurable.PropertiesBootstrapper.load(PropertiesBootstrapper.java:16)
 at com.eucalyptus.bootstrap.Bootstrap$Stage.load(Bootstrap.java:95)
 at com.eucalyptus.bootstrap.SystemBootstrapper.load(SystemBootstrapper.java:129)
16:04:31 ERROR [Exceptions:main] java.lang.UnsupportedOperationException
java.lang.UnsupportedOperationException
 at com.google.common.collect.ImmutableMap.put(ImmutableMap.java:261)
 at com.eucalyptus.configurable.ConfigurationProperties.configure(ConfigurationProperties.java:66)
 at com.eucalyptus.configurable.ConfigurationProperties.doConfiguration(ConfigurationProperties.java:148)
 at com.eucalyptus.configurable.PropertiesBootstrapper.load(PropertiesBootstrapper.java:16)
 at com.eucalyptus.bootstrap.Bootstrap$Stage.load(Bootstrap.java:95)
 at com.eucalyptus.bootstrap.SystemBootstrapper.load(SystemBootstrapper.java:129)

Note that this does *not* happen with sun-java6-jre from partner. So one solution to this might be to set that as an explicit depends and move eucalyptus to multiverse, if this can't be resolved in code by the release date.

Changed in eucalyptus (Ubuntu Oneiric):
status: Confirmed → Triaged

It is my understanding that Eucalyptus 2 requires GWT 2 while the current version is 1.6: this bug relates to using the wrong version of GWT.

Martin Pitt (pitti) on 2011-08-31
Changed in eucalyptus (Ubuntu):
milestone: ubuntu-11.10-beta-1 → ubuntu-11.10-beta-2

There is an on-going effort to package the newer version of GWT on Debian. You can see the thread here http://lists.alioth.debian.org/pipermail/pkg-eucalyptus-maintainers/2011-August/thread.html. I'm not sure if it is of any interest for this bug, but I thought it was relevant.

Dave Walker (davewalker) wrote :

@graziano, thanks for the update. I'm confused why the current gwt doesn't work as it, and eucalyptus is untouched from Natty release.. :/

Thanks.

@dave: very good point! And my apologies: I'm trying to catch up but I'm clearly behind. I think you do carry patches to work with gwt 1.6, so you are indeed right: this issue is not a gwt one.

There may be an easy fix: would you be willing to try it? I attach it here. In short, the code seems wrong, since in one branch we change an immutable object. Since the fault happen in an else statement, I assume that oneric for whatever reason is triggering it. I don't know enough to really understand why though.

Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
Clint Byrum (clint-fewbar) wrote :

Hi Graziano, I'm trying out your patch now. May not be able to squeeze it in before beta 2 freeze in 26 minutes though. ;)

Changed in eucalyptus (Ubuntu Oneiric):
assignee: Ubuntu Server Team (ubuntu-server) → Clint Byrum (clint-fewbar)
status: Triaged → In Progress
Clint Byrum (clint-fewbar) wrote :

Good news! Graziano, your patch works. Smoke tested to the point of being able to login to Eucalyptus and making sure all daemons were running w/o spewing errors. Uploaded a new version of eucalyptus just now.. it may need release team ACK since beta2 freeze has begun.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 2.0.1+bzr1256-0ubuntu7

---------------
eucalyptus (2.0.1+bzr1256-0ubuntu7) oneiric; urgency=low

  * d/patches/28-fix-startup-crash.patch: Fix from Graziano Obertelli
    for startup crash. (LP: #791607)
 -- Clint Byrum <email address hidden> Thu, 15 Sep 2011 13:35:03 -0700

Changed in eucalyptus (Ubuntu Oneiric):
status: In Progress → Fix Released

Excellent news! Glad to hear that.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments