CC is not able to register nodes when DNS is left blank using Ubuntu Installer CD

Bug #773609 reported by Leonardo Borda
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
Medium
Unassigned

Bug Description

Overview
Eucalyptus-cc fails to register nodes when you leave blank, i.e., don't specify DNS settings. This is experienced when setting up static addresses during the Ubuntu installation process.

How to reproduce the issue:
1. Choose "Install Ubuntu Enterprise Cloud"
2. Instead of using dhcp settings configure static addresses for eth0 and leave the dns field blank
3. After the installation try to register a node using:
$ sudo euca_conf --register-nodes <ip-of-the-node>
It says that the node has been registered however CC is unable to list them when running:
$ sudo euca_conf --list-nodes
4. Looking at the cc.log you will get something like this:
======
[Fri Apr 29 16:13:00 2011][002104][EUCAERROR ] initialize(): cannot initialize background threads
[Fri Apr 29 16:13:00 2011] ERROR: doDescribeInstances() failed 1
[Fri Apr 29 16:13:00 2011][001988][EUCADEBUG ] init_thread(): init=0 E34E6000 81513000 87591000 E3467000
[Fri Apr 29 16:13:00 2011][001988][EUCADEBUG ] init_config(): initializing CC configuration
[Fri Apr 29 16:13:00 2011][001988][EUCAWARN ] init_config(): VNET_LOCALIP not defined, will attempt to auto-discover (consider setting this explicitly if tunnelling does not function properly.)
[Fri Apr 29 16:13:00 2011][001988][EUCAFATAL ] init_config(): in 'MANAGED' or 'MANAGED-NOVLAN' network mode, you must specify values for 'VNET_SUBNET, VNET_NETMASK, VNET_ADDRSPERNET, and VNET_DNS'
[Fri Apr 29 16:13:00 2011][001988][EUCAFATAL ] init_config(): bad network parameters, must fix before system will work
[Fri Apr 29 16:13:00 2011][001988][EUCAERROR ] initialize(): cannot initialize from configuration file
[Fri Apr 29 16:13:00 2011][001988][EUCAERROR ] initialize(): cannot initialize background threads
[Fri Apr 29 16:13:00 2011] ERROR: doDescribePublicAddresses() returned FAIL
====

Workaround:
1. Open /etc/eucalytus/eucalytus.conf and uncomment VNET_DNS parameter and set proper dns entries.
2. VNET_DNS="8.8.8.8"
3. sudo restart eucalyptus-cc CLEAN=1

Proposed Solution #1
1. Make DNS Field mandatory during the installation process for the option "Install Ubuntu Enterprise Cloud" since the installation will be using MANAGED-NOVLAN anyway.
OR
If field is left blank make sure the eucalyptus installer takes care of adding a fake or public dns to the VNET_DNS variable.

This is experienced in Lucid and Natty. Maverick has not been tested.

Description: Ubuntu 11.04
Release: 11.04

ii eucalyptus-admin-tools 2.0.1+bzr1256-0ubuntu4 Elastic Utility Computing Architecture - Admin tools
ii eucalyptus-cc 2.0.1+bzr1256-0ubuntu4 Elastic Utility Computing Architecture - Cluster controller
ii eucalyptus-cloud 2.0.1+bzr1256-0ubuntu4 Elastic Utility Computing Architecture - Cloud controller
ii eucalyptus-common 2.0.1+bzr1256-0ubuntu4 Elastic Utility Computing Architecture - Common files
ii eucalyptus-gl 2.0.1+bzr1256-0ubuntu4 Elastic Utility Computing Architecture - Logging service
ii eucalyptus-java-common 2.0.1+bzr1256-0ubuntu4 Elastic Utility Computing Architecture - Common Java package
ii eucalyptus-sc 2.0.1+bzr1256-0ubuntu4 Elastic Utility Computing Architecture - Storage controller
ii eucalyptus-walrus 2.0.1+bzr1256-0ubuntu4 Elastic Utility Computing Architecture - Walrus (S3)
ii libeucalyptus-commons-ext-java 0.5.0-0ubuntu2 Eucalyptus commons external Java library

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: eucalyptus-cc 2.0.1+bzr1256-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-8.42-server 2.6.38.2
Uname: Linux 2.6.38-8-server x86_64
.etc.eucalyptus.eucalyptus.cc.conf: CC_NAME="cluster1"
Architecture: amd64
Date: Fri Apr 29 15:50:02 2011
InstallationMedia: Ubuntu-Server 11.04 "Natty Narwhal" - Release amd64 (20110426)
ProcEnviron:
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: eucalyptus
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Leonardo Borda (lborda) wrote :
summary: - CC is not able to register nodes when DNS is left blank during Ubuntu
+ CC is not able to register nodes when DNS is left blank using Ubuntu
Installer CD
Chuck Short (zulcss)
Changed in eucalyptus (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Kiran Kumar (kiran-kumar-1991) wrote :

Thanks a lot Leonardo Borda. Thanks for finding the bug and providing a work around.We too encountered the exact problem and was striving with it for days.Thanks to your info,it got solved in a jiffy! :)

Revision history for this message
Leonardo Borda (lborda) wrote :

Hi Kiran

My pleasure! :)

Leonardo

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers