package eucalyptus-common 2.0.1 bzr1255-0ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #726769 reported by maninred on 2011-02-28
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
High
Dave Walker
Natty
High
Dave Walker

Bug Description

just installed it in a virtual enviroment(virtualbox4.04). May be the problem, but shouldnt affect.

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: eucalyptus-common 2.0.1+bzr1255-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
Architecture: i386
Date: Mon Feb 28 20:54:52 2011
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110228)
SourcePackage: eucalyptus
Title: package eucalyptus-common 2.0.1+bzr1255-0ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

maninred (maninred) wrote :
Andres Rodriguez (andreserl) wrote :

I confirm this bug when trying to install eucalyptus-cloud:

Warning: The home dir /var/lib/eucalyptus you specified already exists.
Adding system user `eucalyptus' (UID 110) ...
Adding new group `eucalyptus' (GID 120) ...
Adding new user `eucalyptus' (UID 110) with group `eucalyptus' ...
The home directory `/var/lib/eucalyptus' already exists. Not copying from `/etc/skel'.
adduser: Warning: The home directory `/var/lib/eucalyptus' does not belong to the user you are currently creating.
eucalyptus start/running, process 9532
start: Unknown parameter: IFACE
invoke-rc.d: initscript eucalyptus-network, action "start" failed.
dpkg: error processing eucalyptus-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of uec-component-listener:
 uec-component-listener depends on eucalyptus-common; however:
  Package eucalyptus-common is not configured yet.
dpkg: error processing uec-component-listener (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of eucalyptus-java-common:
 eucalyptus-java-common depends on eucalyptus-common; however:
  Package eucalyptus-common is not configured yet.
dpkg: error processing eucalyptus-java-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of eucalyptus-cloud:
 eucalyptus-cloud depends on eucalyptus-common; however:
  Package eucalyptus-common is not configured yet.
 eucalyptus-cloud depends on uec-component-listener; however:
  Package uec-component-listener is not configured yet.
 eucalyptus-cloud depends on eucalyptus-java-common; however:
  Package eucalyptus-java-common is not configured yet.
dpkg: No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
 error processing eucalyptus-cloud (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-image-store-proxy:
 python-image-store-proxy depends on eucalyptus-common; however:
  Package eucalyptus-common is not configured yet.
dpkg: error processing python-image-store-proxy (--configure):
 dependency problems - leaving unconfigured

Changed in eucalyptus (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Michael Vogt (mvo) wrote :

I ran into this today as well (in my auto-upgrade-tester), here is the output of sh -x on the postinst:

+ [ configure = configure ]
+ getent passwd eucalyptus
+ [ -z 2.0+bzr1241-0ubuntu4.1 ]
+ dpkg --compare-versions 2.0+bzr1241-0ubuntu4.1 lt 2.0-0ubuntu1
+ dpkg-statoverride --list /usr/lib/eucalyptus/euca_rootwrap
+ chown root:eucalyptus /usr/lib/eucalyptus/euca_rootwrap
+ chmod 04754 /usr/lib/eucalyptus/euca_rootwrap
+ chown -R eucalyptus:eucalyptus /var/lib/eucalyptus/ /var/log/eucalyptus
+ chmod 700 /var/lib/eucalyptus/keys
+ [ -e /etc/init/eucalyptus.conf ]
+ start eucalyptus
eucalyptus start/running, process 1341
+ [ -e /etc/init/eucalyptus-network.conf ]
+ invoke-rc.d eucalyptus-network start
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service eucalyptus-network start

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the start(8) utility, e.g. start eucalyptus-networ
k
start: Unknown parameter: IFACE
invoke-rc.d: initscript eucalyptus-network, action "start" failed.
+ exit 1

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 2.0.1+bzr1256-0ubuntu3

---------------
eucalyptus (2.0.1+bzr1256-0ubuntu3) natty; urgency=low

  * Separate admin tools from eucalyptus-common package(LP: #732082)
    - debian/control:
      + Add eucalyptus-admin-tools binary package.
      + Add missing Depends on python-psutil. (LP: #731672)
      + eucalyptus-cloud: Depends on eucalyptus-admin-tools.
    - debian/eucalyptus-admin-tools.install: Added.
    - debian/eucalyptus-common.install: Drop installation of admin tools.
  * Switch to dh_python2 instead of python-central.
    - debian/control. Bump Depends on cdbs to (>= 0.4.90~); bump depends on
      python to (>= 2.6.6-3).
  * Add powernap configs to leverage recent PowerNap changes (LP: #726769):
    - debian/powernap/eucalyptus.conf: Add config.
    - debian/eucalyptus-nc.install: Install config.
    - debian/eucalyptus-nc.links: Symlink to /etc/powernap/config.d/.
  * debian/control: Change Recommends order of bittorrent to bittornado
    first. Allows demontion of bittorrent. (LP: #697753)
 -- Andres Rodriguez <email address hidden> Thu, 17 Mar 2011 15:23:36 -0400

Changed in eucalyptus (Ubuntu Natty):
status: Confirmed → Fix Released
Andres Rodriguez (andreserl) wrote :

Re-opening this bug report as it wasn't really closed. There was a mis-reference in the changelog that caused this.

Changed in eucalyptus (Ubuntu Natty):
status: Fix Released → Confirmed
Dave Walker (davewalker) on 2011-04-18
tags: added: server-nrs
Dave Walker (davewalker) on 2011-04-18
Changed in eucalyptus (Ubuntu Natty):
assignee: nobody → Dave Walker (davewalker)
Dave Walker (davewalker) wrote :

This is now fix released with the current version in the archive. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers