[FTBFS] Eucalyptus doesn't build on maverick, with -security pocket enabled

Bug #688522 reported by Dave Walker on 2010-12-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Eucalyptus
New
Undecided
Neil Soman
eucalyptus (Ubuntu)
Undecided
Unassigned
Maverick
High
Unassigned
openjdk-6 (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Attempting to rebuild the current maverick package, with the release and security pocket enabled, it fails to build. This issue could be a bug with openjdk.

Build log attached.

Dave Walker (davewalker) wrote :
Dave Walker (davewalker) wrote :

Confirming that on a clean maverick chroot it builds, upgrading the following from security causes it to fail.
openjdk-6-jdk
openjdk-6-jre
openjdk-6-jre-headless
openjdk-6-jre-lib

Matthias Klose (doko) wrote :

reverting for maverick:

    - S6638712: Inference with wildcard types causes selection of
      inapplicable method.
    - S6650759: Inference of formal type parameter (unused in formal
      parameters) is not performed.

currently not reverting for natty

Changed in openjdk-6 (Ubuntu Maverick):
milestone: none → maverick-updates
status: New → In Progress
Matthias Klose (doko) on 2010-12-10
Changed in openjdk-6 (Ubuntu):
status: New → Confirmed
Kees Cook (kees) on 2010-12-13
Changed in eucalyptus (Ubuntu Maverick):
status: New → Invalid
Changed in openjdk-6 (Ubuntu Maverick):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openjdk-6 - 6b20-1.9.2-0ubuntu2

---------------
openjdk-6 (6b20-1.9.2-0ubuntu2) maverick-security; urgency=low

  * Revert two backports. LP: #688522:
    - S6638712: Inference with wildcard types causes selection of
      inapplicable method.
    - S6650759: Inference of formal type parameter (unused in formal
      parameters) is not performed.
 -- Matthias Klose <email address hidden> Fri, 10 Dec 2010 19:34:46 +0100

Changed in openjdk-6 (Ubuntu Maverick):
status: Fix Committed → Fix Released
Dave Walker (davewalker) wrote :

On natty, this is currently blocked from testing by bug #687970.

Changed in eucalyptus (Ubuntu):
status: New → Invalid
Matthias Klose (doko) wrote :

I asked to check, if this issue is seen with openjdk-7 too. please investigate. openjdk-7 packages can be found in the ~openjdk PPA. the maverick packages can be installed in natty too.

Changed in openjdk-6 (Ubuntu):
status: Confirmed → Incomplete
Changed in eucalyptus (Ubuntu):
status: Invalid → Incomplete
Matthias Klose (doko) wrote :

Dave, please backport the natty change to maverick and lucid, so that we do not have to back out the openjdk change for maverick and lucid anymore.

Changed in eucalyptus (Ubuntu Maverick):
importance: Undecided → High
milestone: none → maverick-updates
status: Invalid → Confirmed
Changed in eucalyptus:
assignee: nobody → Neil Soman (neilsoman)
JC Hulce (soaringsky) wrote :

This bug affects Ubuntu 10.10, Maverick Meerkat. Maverick has reached end-of-life and is no longer supported, so I am closing the bugtask for Maverick. Please upgrade to a newer version of Ubuntu.
More information here: https://lists.ubuntu.com/archives/ubuntu-announce/2012-April/000158.html

Changed in eucalyptus (Ubuntu Maverick):
status: Confirmed → Invalid
Andy Grimm (agrimm) wrote :

This issue is now being tracked upstream at http://eucalyptus.atlassian.net/browse/EUCA-2747

Please watch that issue for further updates.

Dave Walker (davewalker) wrote :

Marked as obsolete upstream.

Changed in openjdk-6 (Ubuntu):
status: Incomplete → Won't Fix
Changed in eucalyptus (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers