[maverick] Registration unreliable

Bug #609112 reported by C de-Avillez on 2010-07-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Eucalyptus
Fix Released
Undecided
chris grzegorczyk
eucalyptus (Ubuntu)
High
Dave Walker
Maverick
High
Dave Walker

Bug Description

Eucalyptus 2.0, running topo1, A3 candidate
After installing the CLC+WC+CC+SC, sometimes (40% of the time ?) the registration.log shows components fail to autoregister (return code 1 on the euca_conf call).

Some people reported being able to register manually by running euca_conf --register-* after that, so it looks like a timing issue. More details as we reproduce it.

C de-Avillez (hggdh2) wrote :
Thierry Carrez (ttx) on 2010-07-28
Changed in eucalyptus (Ubuntu):
assignee: nobody → Dave Walker (davewalker)
importance: Undecided → High
milestone: none → maverick-alpha-3
status: New → Confirmed
Dave Walker (davewalker) wrote :

Currently wondering if this is related to the NODES= population issue.

Thierry Carrez (ttx) wrote :

Installing from the 20100803 ISO everything registers correctly.

Looks like it's an issue in the preseeding that is done to automate your installs. Everything is working OK as far as the node autoregistration is concerned.

I suspect the preseeding fails top deploy the CC key to the NC /var/lib/eucalyptus/.ssh/authorized_keys, please doublecheck that you can find your CC public key there after a fresh preseeded install.

Unmilestoning for alpha-3 since the ISO works correctly.

Changed in eucalyptus (Ubuntu Maverick):
milestone: maverick-alpha-3 → none
status: Confirmed → Incomplete
C de-Avillez (hggdh2) wrote :

This was an all-in-one (CLC, CC, Walrus, and SC) install. All keys were correctly deployed via the eucalyptus udeb; after install I confirmed deployment of the keys.

This does not seem to happen every time (twice in 6 installs), and sounds like some sort of race. I will leave incomplete, and see if it happens again.

C de-Avillez (hggdh2) wrote :

> all keys were correctly deployed via the eucalyptus udeb

What I mean here is that I am *not* passing the keys in the preseed (although we can).

Confirmed on topo1, sometimes the stuff ends up registered, sometimes it doesn't. Looks like some kind of race.

summary: - euca_conf --discover-nodes fails to register nodes
+ Registration unreliable
Changed in eucalyptus (Ubuntu Maverick):
milestone: none → ubuntu-10.10-beta
milestone: ubuntu-10.10-beta → none
status: Incomplete → Confirmed
summary: - Registration unreliable
+ [maverick] Registration unreliable
Changed in eucalyptus (Ubuntu Maverick):
milestone: none → ubuntu-10.10-beta
tags: added: iso-testing
Thierry Carrez (ttx) on 2010-08-04
description: updated
chris grzegorczyk (chris-grze) wrote :

I am not sure if i have understood the issue here correctly. Is it specific to --register-nodes or does it also effect --register-{cluster,walrus,sc}? If cluster, walrus, sc were also causing problems, could you see if the current r1220 resolves the problem for them (it does not address nodes).

Thierry Carrez (ttx) wrote :

In the case uncovered by ISO testing, it was --register-{cluster,walrus,sc} that was regularly half-failing (returns 1). We'll test the r1220 to see if it also fixes this one.

Dave Walker (davewalker) wrote :

@Thierry, A new upstream revision should be landing shortly. I'll try and reproduce against that.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 2.0~bzr1224-0ubuntu1

---------------
eucalyptus (2.0~bzr1224-0ubuntu1) maverick; urgency=low

  [ Dave Walker (Daviey) ]
  * New upstream merge, r1224, should fix LP: #610259, #609112, #613033
  * debian/patches/10-disable-iscsi.patch: Removed, we should now be
    supporting iscsi.
  * debian/control: Promoted tgt from Recommends to Depends for
    eucalyptus-sc. (LP: #614503)

  [ Scott Moser ]
  * work around kvm virtio bug with -kernel by using boot floppy LP: #615529
  * remove the listing of dependency on grub-pc for workaround. LP: #613463
 -- Dave Walker (Daviey) <email address hidden> Wed, 11 Aug 2010 13:46:50 +0100

Changed in eucalyptus (Ubuntu Maverick):
status: Confirmed → Fix Released
Changed in eucalyptus:
status: New → Fix Released
assignee: nobody → chris grzegorczyk (chris-grze)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers