Ubuntu

Eucalyptus doesn't start with latest stable version of "Groovy"

Reported by Dave Walker on 2010-06-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Eucalyptus
Invalid
Undecided
Unassigned
eucalyptus (Ubuntu)
High
Dave Walker
Maverick
High
Dave Walker

Bug Description

Eucalyptus (1.6.2), doesn't work with the latest version of Groovy (1.7). This version is the version in Maverick, it is only possible to start Eucalyptus if lucid's version of Groovy (1.6) is installed.

A developmental work around is to enable the following PPA, which installs 1.6 following an upgrade:
ppa:davewalker/groovy

This is not an ideal solution, but a development work around until Eucalyptus is compatible with Groovy 1.7 (or in the worst case, Groovy 1.6 is shipped in Maverick).

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: eucalyptus-cloud 1.6.2+bzr1230-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-3.4-server 2.6.35-rc3
Uname: Linux 2.6.35-3-server x86_64
.etc.eucalyptus.eucalyptus.cc.conf: CC_NAME="cluster1"
Architecture: amd64
Date: Thu Jun 17 10:00:33 2010
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: eucalyptus

Dave Walker (davewalker) wrote :
Dave Walker (davewalker) on 2010-06-17
Changed in eucalyptus (Ubuntu):
importance: Undecided → High
Thierry Carrez (ttx) on 2010-06-17
Changed in eucalyptus (Ubuntu Maverick):
milestone: none → maverick-alpha-2
assignee: nobody → Dave Walker (davewalker)
Dave Walker (davewalker) wrote :

More simple resolution than expected:
$ sudo ln -sf /usr/share/java/groovy-all.jar /usr/share/eucalyptus/groovy.jar

Will be fixed in my next upload. Marking triaged.

Changed in eucalyptus (Ubuntu Maverick):
status: New → Triaged
Changed in eucalyptus:
status: New → Invalid
Dave Walker (davewalker) wrote :

Marking invalid for Eucalyptus upstream, as it's a resolution based in the packaging.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6.2+bzr1230-0ubuntu3

---------------
eucalyptus (1.6.2+bzr1230-0ubuntu3) maverick; urgency=low

  * debian/eucalyptus-java-common.links: Changed symlink for groovy, point to
    groovy.all.jar, making compatiable with groovy versions >1.7. (LP: #595421)
  * debian/control: Build Depend & Depend for eucalyptus-java-common on groovy
    >=1.7, as we now require that version or above.
  * debian/patches/22-ebs-virtio.patch: New patch, changing dynamic block storage
    to use virtio. (LP: #588410)
 -- Dave Walker (Daviey) <email address hidden> Tue, 29 Jun 2010 23:47:12 +0100

Changed in eucalyptus (Ubuntu Maverick):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers