EBS volume cannot be detached after i reboot a instance

Bug #586542 reported by Jônata Tyska Carvalho on 2010-05-27
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fix Committed
Neil Soman
eucalyptus (Ubuntu)
Nominated for Lucid by Dave Walker

Bug Description

I have a determined volume attached to one instance. If i reboot this intance, and after the reboot i try to use the volume from the instance i cannot see the volume. I attached the volume in the /dev/sdb but when i run fdisk -l after the reboot command, is just listed the /dev/sda. But when i run euca-describe-volumes the volume is still attached to that instance, and when i run euca-detach-volume the volume is not detached (with no error messages). Neither delete the volume is possible after that.

Im using eucalyptus with the Ubuntu 10.04 LTS.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: eucalyptus-common 1.6.2-0ubuntu30
ProcVersionSignature: Ubuntu 2.6.32-21.32-server
Uname: Linux 2.6.32-21-server x86_64
.etc.eucalyptus.eucalyptus.cc.conf: CC_NAME="c3cluster1"
Architecture: amd64
Date: Thu May 27 17:20:24 2010
InstallationMedia: Ubuntu-Server 10.04 LTS "Lucid Lynx" - Release amd64 (20100427)
SourcePackage: eucalyptus

Related branches

Thierry Carrez (ttx) on 2010-06-02
Changed in eucalyptus (Ubuntu):
importance: Undecided → High
status: New → Confirmed

Someone can verify this please? It seems a big problem and, even according this tool, no one is working on it.

C de-Avillez (hggdh2) wrote :

Hi Jônata,

Can you please give us the volume Id (and, if possible, the instance ids)?

Neil Soman (neilsoman) on 2010-06-28
Changed in eucalyptus:
assignee: nobody → Neil Soman (neilsoman)
importance: Undecided → High
status: New → Fix Committed
Neil Soman (neilsoman) wrote :

FYI, this does not affect xen users. Only kvm is affected.

Dave Walker (davewalker) wrote :

According the Neil's comment, this issue has been fixed in the current development version on Maverick. Nominating against Lucid, as i believe this could be a potential SRU candidate.

Changed in eucalyptus (Ubuntu):
status: Confirmed → Fix Released
Andy Grimm (agrimm) wrote :

This issue is now being tracked upstream at http://eucalyptus.atlassian.net/browse/EUCA-2705

Please watch that issue for further updates.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers